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In this tutorial, you will learn how to:

e Check run a solver deck generated with Altair Inspire

e OUT file comparison of Altair OptiStruct-written result file after the check run
These additional options are available for the check run of the solver

1. Two OUT files generated from an Altair Inspire (Altair OptiStruct solver) run can be
compared.

2. A current solver run OUT file can be compared with a reference OUT file.

3. Two OUT files generated from same solver deck using two different Altair Inspire (Altair
OptiStruct solver) versions can be compared.

4. Solver version result comparison for Altair OptiStruct results for a model generated in
Inspire

o If the result files are not available, the solver run can be done in the background;
result generated are used in the result comparison.

Step 1: Check run a model built in Altair Inspire (Altair OptiStruct
deck).

1. From the Start menu, select All Programs > Altair HyperWorks 2017 > Tools >
HyperWorks Verification and Validation Harness.

2. Select the Design tab, followed by the Check Run tab.
3. Select the Check run button.
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For File type, select Inspire (default).

5. For Current version, select 2017_2017 (referring to Altair Inspire and Altair

HyperWorks versions).

al

6. Under the Input file field, click the open file icon, = , to search for and load

additional input files. Load the hat. fen file, located in
..\tutorials\hvvh\Design\Inspire\Check-Run.

7. For the Output directory field, use the open file icon,
directory.

8. Click Check Run.

d

, to select an output

9. In the Messages window, the run details are displayed along with the log file location.

10.Errors are indicated as Fail otherwise, they are shown to Pass.

11.Click HTML Report to generate a check run report.
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HvperWorks Verification and Validation Harness

Inspire - Check Run Report

File Type : Inspire HW Version : 2017_2017

| Eesult file |iRun statusl
[C:/HVVH OutDir Inspire_CheckRun Currcnr_lmt.cmtl-

Step 2: Compare two OUT files (out files comparison).
Out files generated from an Altair OptiStruct solver check run can be directly compared.
1. From the Design tab > Check Run tab, select the Out compare button.

4 | :
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7\ HVWVH - HyperWorks Verification and Validation Harness (v2017) [C=1r e g

File Edit Help

Design |CAD | FE Model | Solution| Result|Manufacturing solution

Inspire
Check Run |Solver version result comparison
File type : Inspire - Current Version : | 2017 2017  + Reference Version: | 2017 140.00 - © Check run © Out Ref. compare
& Out compare € Out file comparison
Input OUT file :
I(:/AImnr/ZOl1.0.0.L’I/dcmos/hwh/ues|gn/ln5pue/£heck Run/Current_hat.out ?:J
Reference OUT file :
|C:/’All.-n1/2017.0.0.Mldemos/hwh/Deugn/‘lnspue/(‘.hetk-Run/Refelen(.eihaLcul = i
Output directory :
PR |
|C:\HVVH\Oul0|r LE)"
Check Run T
Result file Run status QUT comparison

C:/HVVH/OutDir/Inspire_CheckRun_3/Reference_Reference_hat.out

Html Report

7| Messages &

Please refer logfile for status : C:/HVVH/OutDir/Inspire_CheckRun_3/logfile_CheckRun.txt

Il Completed check run.

Comparing C:/Altair/2017.0.0.14/demos/hvvh/Design/Inspire/Check-Run/Current_hat.out & C:/Altair/2017.0.0.14/demos/hvvh/Design/Inspire/Check-Run/Referen

For File type, select Inspire (default).

|
Under the Input file field, click the open file icon, = , to search for and load
additional input files. Load the hat. fen file, located in
..\tutorials\hvvh\Design\Inspire\Check-Run.

Tl

Use the open file icon, = , to open file browser and load the Input OUT file
Current hat.out, located in
..\tutorials\hvvh\Design\Inspire\Check-Run.

al

Use the open file icon, = , to open the file browser and load the Altair OptiStruct
Reference OUT file Reference hat.out, located in

..\tutorials\hvvh\Design\Inspire\Check-Run.
This file is used to compare the first OUT file.
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10.

al

For the Output directory field, use the open file icon, = , to select an output
directory.

Click Check Run.

The two OUT files selected are compared. Some of the important blocks in the OUT files
are compared. More blocks will be added in other versions.

After the Check run [OUT file comparison] the status of the comparison is displayed in
the Messages window. In the Messages window, the run details are displayed along
with the log file location.

Errors are indicated as Fail otherwise, they are shown to Pass.

Click HTML Report. Comparisons of different blocks of results are shown line-by-line.
Warnings are in light orange and errors are in dark orange.

HvperWorks Verification and Validation Harness

Inspire - Check Run Report

File Type : Inspire Current Version : 2017_2017 Reference Version : 2017_140.00

| Result file |jRun statu 5]|DL"T i:umpan'sun]

|C'. HVVH ' COutDhir/ Inspire CheckPun_ 3 R:ﬂ:rﬂ]cc_R.:fcrctm:_h.at_nut|_—

Step 3: OUT file comparison with a reference file.

Out files generated from an Altair OptiStruct solver check run can be compared with a pre-
certified or reference OUT file.
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*, HVVH - HyperWorks Verification and Validation Hamess (v2017) b () S

File  Edit Help

Performing check run on file: C:\Altair\ 2017.0.0.14\demos\hwwh\Design\Inspire\Check-Run\hat.fem
Current Solver Path : C:/Altair/2017.0.0.14/5TDesign2017_7305/inspire/unity/bin/winb4/optistruct.exe
Completed check run.

Design O\D?FE Mooatlsocwonlﬂm Manufacturing solution

Inspire

Chack Run Solver version result comparison

File type : inspire b Cutrant Version ; W17 2087 ~ Reference Version :

" Check ren @ Out Ref. compare

€ Out compare © Out file comparison

Input file (sohver deck) :

-
I( NANIN2017.0.0. 18\ demos\wwvh\Design\inspire\Chack-Rua\hat fem =
Reference OUT file :
I( AN/ 2017.0.0. 04/ demos/wh/Design/inspire/Checi-Run/Reference_hat.out =
Output directory -
I(.‘.Nww\o-.ﬂ.ou -3
Check Run
Result file R status OUT comparison
C/MVVH/OutONInspire_CheckRun_2/Reterence_hat.out _ ws S
Htmi Report
7 Messages ¢

(oKl &

i
1.
2.
3

From the Design tab > Check Run tab, select the Out Ref. compare button.
For File type, select Inspire (default).
For Current Version, select 2017.

vl

Under the Input file field, click the open file icon, = , to load the hat. fem file, located
in ..\tutorials\hvvh\Design\Inspire\Check-Run. This is used for Inspire to run in
the background.

Tl
Use the open file icon, = , to open file browser and load the Reference OUT file
Reference hat.out, located in ..\tutorials\hvvh\Design\Inspire\Check-Run.
This is used to compare the first generation OUT file.

d

For the Output directory field, use the open file icon, = , to select an output
directory.

Click Check Run.
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The two OUT files selected are compared. Some of the important blocks in the OUT files
are compared. More blocks will be added in other versions.

8. After the Check run [OUT file comparison] the status of the comparison is displayed in
the Messages window. In the Messages window, the run details are displayed along
with the log file location.

9. Errors are indicated as Fail otherwise, they are shown to Pass

10.Click HTML Report. Comparisons of different blocks of results are shown line-by-line.
Warnings are in light orange and errors are in dark orange.

HvperWorks Verification and Validation Harness

Inspire - Check Run Report

File Type : Inspire Current Version : 2017_2017 Reference Version : 2017_140.00

| Result file ||Run status”ﬂ[’T tumpaﬁsﬂnl

\C:/HVVH/OutDir/ Inspire_CheckRun_2 R:f:r:nc:_hat.nuﬂ__

Step 4: Out file comparison from solver check runs.
Out files generated from different Inspire versions can be directly compared.

4 | -
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"\ HVWH - HyperWorks Veriication and Vabidation Haeness (v2017) ESSIER X |
File  Edit| Melp
Desgn CAD/|FE Moded | Sotution | Resut | Manutacturing solution
Inspire
Creci Run Solver version resuit comparnson
File Type : | Vagire *|  CureotVersion :| 2017 2017 - Roforence Versson : l 2017 34000 " Check run " Out Ref. compare
" Ot compare @ Ot e comparison
Irput Nile (sodver Seck) ©
[( \AIZ2IN2017.0.0 14\ demos\tvvh \Design\Inspire \Ohack-Run\ hat . fem 3
Reterence OUT hie :
Output cirectory :
——— E;
Check Run
Nova Me Run statud QUT companson
WO g oacktunpeteence pa o L e —
Himi Report
7 Messages o
Current Solver Path : C:/AlItalr/2017.0.0.14/5TDesign2017 _7305/inspire/unity/bin/winb4/optistruct exe 4
Reference Solver Path : C:/AIRaIr/14.0_Mainline_inspire/sTDesign2016_5384/Inspire/unity/bin/winbd/optistruct exe e

Completed check run J!

From the Design tab > Check Run tab, select the OUT file comparison radio button.

For File type, select Inspire (default).

For Current version, select 2017_2017 (referring to the Altair Inspire and Altair
HyperWorks versions).

4. For Reference version, select 2017_14.0.0.

W N =

|
4. Under Input file, click E” and load the hat. fen file, located in
..\tutorials\hvvh\Design\Inspire\Check-Run.

This is the solver file that will be used to run the solver for the Check run. An OUT file is
created in the output directory.

il
5. For the Output directory field, click = to select an output directory.
Click Check Run.

From the same input file, the current version OUT file and reference version OUT file are
generated and compared. Some of the important blocks in the OUT files are compared.

7y Altair
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7. After the Check run (OUT file comparison), the status of the comparison is displayed in
the Messages window. In the Messages window, the run details are displayed along
with the log file location.

8. Errors are indicated as Fail otherwise, they are shown to Pass.

9. Click HTML Report. Comparisons of different blocks of results are shown line-by-line.
Warnings are in light orange and errors are in dark orange.

HvperWorks Verification and Validation Harness

Inspire - Check Run Report

File Type : Inspire Current Version : 2017_2017 Reference Version : 2017_140.00

Result file "Ruu stams”ﬂ[, T mmpnrisnnl

|C HVVH/OutDir/Inspire_CheckRun_1/Reference_hat. -:H.ll:]-_

Step 5: Solver version result comparison.

This step illustrates solver version result comparison for Altair OptiStruct results for a model
generated in Inspire. If the result files are not available, the solver run can be done in the
background. The results generated are used in result comparison.

1. From the Design tab, select the Solver version result comparison tab.
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HVWH - RyperWorks Verification and Validation Harness (v2017) -

Design CAD | FE Model | Salutian | Result Manufacturing solution
Inspire

Cheeck Bun SChver wersion nssull companson

Lobewr Typa: |inspine " Toberano : Idnr.iull: B Lie-& Apply Rursulr: opr ~ HTML Repoet | &

OPE
Version m_amr * R golved Version H18_1aan " R gobved
Lo Maode! [ é Livasd Mode! [ -5
Losd Rasult = Lowd Rasult | =
Output | =
dirsciony
Hyperin Run Solver Apply
Lisbase Simulation Rewali fype
Al All All
Apgly
Compare result ;
Currend file Reference file Rapart
R
Rt
Hemi Reporn
1 Meltages #

For the Solver Type, select Inspire (default).

3. For the Tolerance, select default and leave 1e-06 as the value. You can set any
tolerance for the Scalar, Vector or Tensor data types.

For Result, select H3D.
5. Click HTML report.

Tl
6. Under Current/Load Model, click B and load the hat. fem file, located in
..\tutorials\hvvh\Design\Inspire\Solver-version-result-comparison.

al

7. Under Reference/Load Model, click B and load the hat. fem file, located in
..\tutorials\hvvh\Design\Inspire\Solver-version-result-comparison.

al

8. For the Output directory field, click = to select an output directory.

4 | -
Proprietary Information of Altair Engineering ) A ta I f



Altair HYVH 2019 Tutorials p.11

" HYWH - HyperWorks Verification and Validation Hamess (v2017) | () ]
File Edit Help
Design \cAD| Fe Model | Sotution] Resutt| Manutacting solution
| Check w.m Solver version result Compadison .
Sodbvad Typad ! |I'|-I|IIM " Tolersee 2 [dd-b..h j I 6| Apply Rtz I HE ™ HTML Ripont | |
Current Riference
Vesion  [2007 3017 7| 5 Run solver Virsion |a¢|?_:-¢u: ™| Rum zobrer
1
Load Model |hwh.|"|:le:Jgnflm-plm's-uhfﬁnnbﬂ-mult-mwﬂwﬂut.fﬂn ﬂ Load Model Iworslwlnwmwm-rmh1dmpvlmfh¢1.1w ﬂ i
Load Result | = Load Result I =
[ — —
Output II:-.."‘m'w'."ﬂu:D-e ﬂ
directony : |
. Hyperiew ] | Foun Solver ] [ Agply . I

9. Activate the Run solver option.

10.Click the Run Solver button. This runs the solver in different versions of Altair Inspire
and loads the results in the Load Result box.

" 7, HVVH - HyperWorks Verification and Validation Hamess {v2017) - b (S
| File Eait Help
Design |CAD| FE Model | Solution| Resut| Manutacturing solution

‘ Inspire

Check Run Sobver version result comparison

Solver Type : Iimuo ': Toleraece : Idohdl '1 I le-6 ‘F Apply ;mn: W30 '} HTML Raport i:

Current Reference
version (10172017 *| |7 Run soiver Version |mr_m.a‘«‘ 71 Run solver
If
Load Model lhwmt‘:\/lnwue}sohu-\vm-vﬂul(~<omp¢nwn/'hstfm 3} Load Mode! Iwthestgn/lmplrdSolvef-mowrewﬂwmtwnfw.'em =3
1
"r Load Result [c:mvvu/omo«/solutm_nmsmlcmwm:_du.m 5} Load Result Ic'JvaH/Ommr/wmm_nunm“lnﬂ«mo/m_du_nm =3
Output o Myvm/Outoie =)
dwectory : —J

\ | Hypeiew | RanSover || Agply

11.Click Apply.

The results available (Subcase, Simulation, and Result type) in the result file are loaded
in the corresponding windows.

Subcaze Semulation Result type
Design *  Ieraticnd shape Change
Ieration 1
Ieraticn 2
=  Ieration 3 = -
All 1A Clan
Tolerance Apply ]

7y Altair
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12.Activate each All option beneath the result windows and click the second Apply button.

13.You can also select any combination of the Subcase, Simulation, and Result types to
compare fewer results.

Result comparisons of the current results and reference results are generated.
14.1In the Messages window, the run details are displayed along with the log file location.
15.If difference > tolerance, it is indicated as Fail otherwise, they are shown to Pass.

16.Click HTML Report. Comparisons of different data types are available. For example,
for a vector (Displacement), all the components Magnitude, X-displacement, Y-
displacement, and Z-displacement are compared for the whole model and the results are
shown.

HyperWorks Verification and Validation Harness

Solution - Solver Version Result Comparison Report

Solver Type : Inwpire Current Vericn : 2017 2017 Reference Vernon : 2017 140,00

L Currentfile L _ Referemcefle =~~~ = = [ReportiLaunch HV]
{C-HVVH OutDir Soluticn,_SolverVerCompare Current_hat_des_ShapeChange _1J/C-HVVH OwDir Soluticn,_SolverVerCompare Reference_hat_des_ShapeChange 1| [N DNNENIN

Min-Max values across loadcase

_Data Type |Lead Case Number of Simultien)

E\'lu;-:(*r.nm: Design i 18

Shape Chasge, Mag | X |
" Current Min [0,000E+00 0.000E+001-:

[Corrvar Max L 13IEOT [os66E6]
T DifTMin 00 10,000 +00] 0.000% +00][0.000E+00]
| DHTMax_ 0,000E+00) 0,000 +00] 0.000E+00)[0.000E+00]

17.Click on Pass/Fail in the HTML report to open a detailed comparison report.
18.If difference > tolerance, it is indicated as Fail otherwise, they are shown to Pass.

Mervien

Design, ShapeChange
* Dabgn, ShapeChangs
Dynamic MinMax Result

e 1 LU LR
[P——

M g

LS )
o 207

AL 007 ™
— Max ShapeCharge 0% 1)

g

o

-
g

Al o7

Dynamic MinMax Result Vadoe

Lo

8€ 007

4

‘oo —o——
0 2 4 0 B YW 12 WMWY
Time

19.1In the above report, the left window displays the diff contour (Current-Reference) and
the right window displays the diff plot in Altair HyperGraph.

4 | -
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20. Click the left window to open the diff-values H3D in HyperView Player. You can view the
difference in the contour and view the area where there are differences in case of failure.

21. Click the right window to maximize/minimize the plot. The difference values for each
step are calculated and the min/max values of difference are plotted.

22. For following two options, please refer to the Solution tab > Solver version result
comparison section:

Solver version result comparison (Altair HyperView option)

e Solver version result comparison (Run solver option)

7y Altair
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