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HS-4420: Optimization Study of a Spherical Impactor 

This tutorial demonstrates how to perform an advanced study that has both size and shape 

input variables on a RADIOSS finite element model.   

The sample base input template can be found in <hst.zip>/HS-4420/. Copy the files 

impactor.hm, impactor_0000.rad, and impactor_0001.rad from this directory to your 

working directory. 

The steps taken in this tutorial demonstrate how to analyze the input variables in order to 

identify the most important variables and how to do an Optimization. The objective of the 
Optimization is to minimize the maximum acceleration of the impactor, while keeping 

maximum displacement lower than 16 mm. 

In this tutorial, you will: 

• Create a base input template from a RADIOSS input file using the HyperStudy Editor

• Set up a study

• Run a DOE study (screening DOE)

• Post process DOE results in order to define the most important variables and reduce

the number of variables (screening)

• Create a new DOE in order to create an approximation

• Create an approximation

• Run an Optimization study based on the approximation created

This model simulates the dynamic impact of a sphere with an initial velocity on a box. There 

are eight variables: four size variables, which are four box thickness, and four shapes 

variables.  

Size variables 
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Shapes variables 

Step 1: Export the Shape Parameterization from HyperMesh 

1. Start HyperMesh Desktop.

2. In the User Profiles dialog, change the user profile to RADIOSS.

3. From the menu bar, click File > Open > Model.

4. In the Open Model dialog, open the impactor.hm file. The impactor.hm database has

the RADIOSS analysis setup, and the shapes have already been created. You must

export the shapes variables so that they are included in the template file.

5. From the Tool page, click Shape.

6. Go to the desvar subpanel.

7. Switch single desvars to multiple desvars.
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8. In the initial value= field, enter 0.

9. In the lower bound= field, enter -1.

10. In the upper bound= field, enter 1.

11. Click the shapes selector.

12. Select all of the shapes.

13. Click select.

14. Click create. A shape design variable is created for each shape.

15. Optional.

• If you would like to animate or visualize the shapes, click animate.

• In the Deformed panel, click linear or modal to animate the shape variables in

the graphics area.

• While the shape is animating, you can adjust the animation speed by moving the

slider as indicated in the image below.

16. Go to the export subpanel.

17. For analysis code, select HyperStudy.

18. For sub-code, select Radioss51.

19. In the File field, enter impactor.shp.



Altair HyperStudy 2019 Tutorials p.4

Proprietary Information of Altair Engineering 

20. Click export as.

21. In the Save As dialog, navigate to your working directory and save the file as

impactor.shp. HyperMesh writes the following files:

impactor.radioss51.node.tpl Grid coordinates template. 

impactor.shp Grid perturbation vector data read by 

impactor.radioss51.node.tpl. 

22. Exit HyperMesh Desktop.

Step 2: Create the Base Input Template in HyperStudy 

1. Start HyperStudy.

2. From the menu bar, click Tools > Editor.

3. In the Editor dialog, File field, open the impactor_0000.rad file.

4. Right-click anywhere in the editor and select Select Nodes > /NODE from the context

menu. All of the /NODE cards in the impactor_0000.rad file highlight.

5. Right-click on the highlighted cards and select Include Shape from the context menu.

6. In the Shape Template dialog, open the impactor.radioss51.node.tpl file. The

shape variables are now created and the grid has been replaced by the parameter file

(which contains the grid parameterized by the shapes) exported during step 1.

7. Locate the shape variable prop_external_skin.

8. Select the thickness value for prop_external_skin, as indicated in the image below. In a
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RADIOSS deck, each field within a card is 20 characters long. 

Tip: To assist you in selecting 20-character fields, press CTRL to activate the 

Selector (set to 20 characters) and then click the value. HyperStudy highlights 

20 fields. 

9. Right-click on the highlighted fields and select Create Parameter from the context

menu.

10. In the Parameter - varname_1 dialog, Label field, enter th_external_skin.

11. Change the Lower Bound to 1.0, the Nominal value to 1.0, and the Upper Bound to

2.0.

12. Change the Format to %20.5f.

13. Click OK.
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14. Define three more input variables for thickness using the information provided in the

table below.

Input Variable Label Lower 

Bound 

Nominal 

Value 

Upper 

Bound 

Format 

prop_internal_skin th_internal_skin 1.0 1.0 2.0 %20.5f 

prop_external_flange th_external_flange 1.0 1.0 2.0 %20.5f 

prop_internal_flange th_internal_flange 1.0 1.0 2.0 %20.5f 

15. Click Save.

16. In the Save Template dialog, navigate to your working directory and save the file as

impactor.tpl.

17. Close the Editor.

Step 3: Perform the Study Setup 

1. To start a new study, click File > New from the menu bar, or click  on the toolbar. 

2. In the HyperStudy – Add dialog, enter a study name, select a location for the study,

and click OK.

3. Go to the Define models step.

4. Add a Parameterized File model.

a. From the Directory, drag-and-drop the impactor.tpl file into the work area.

b. In the Solver input file column, enter impactor_0000.rad. This is the name of
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the starter input file HyperStudy creates from the parameterization, and the name 

of the Engine file. 

c. In the Solver execution script column, select RADIOSS (radioss).

d. In the Solver input arguments column, enter -nproc 4 after ${file}.

5. Define a model dependency.

a. Click Model Resources.

b. In the Model Resource dialog, click Add Resource > Add Input Resource.

c. In the Select File dialog, navigate to your working directory and open the

impactor_0001.rad file.

d. Set Operation to Copy.

e. Click Close.

6. Click Import Variables. Eight input variables are imported from the impactor.tpl

resource file.

7. Go to the Define Input Variables step.

8. Review the lower and upper bound ranges of the input variables.

9. Go to the Specifications step.

Step 4: Perform the Nominal Run 

1. In the work area, set the Mode to Nominal Run.

2. Click Apply.
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3. Go to the Evaluate step.

4. Click Evaluate Tasks. An approach/nom_1/ directory is created inside the study

directory. The the approaches/nom_1/run__00001/m_1 sub-directory contains the

impactorT01 file, which is the result of the nominal run.

5. Go to the Define Output Responses step.

Step 5: Create and Define Output Responses 

In this study, we want to analyze the maximum acceleration and the maximum 

displacement observed by the box.  This study is a function of the time; we need to extract 

the maximum of each output response vector over time. 

1. Create a file source for time.

a. From the Directory, drag-and-drop the impactorT01 file, located in

approaches/nom_1/run_00001/m_1, into the work area.

b. In the File Assistant dialog, set the Reading technology to Altair®

HyperWorks® and click Next.

c. Select Single item in a time series, then click Next.

d. Define the following options, then click Next.

• Set Type to Time.

• Set Request to Time.

• Set Component to Time.
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e. Clear the Linked to a new Response checkbox.

f. Click Finish
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2. Create a second file source for impactor acceleration along the Z axis. Repeat step 1,

except define the following options:

• Set Type to Node/TH_node_sphere.

• Set Request to 4206 rigid_sphere_4206.

• Set Component to AZ-Z Acceleration.

3. Create a third file source for impactor displacement along the Z axis. Repeat step 1,

except define the following options:

• Set Type to Node/TH_node_sphere.

• Set Request to 4206 rigid_sphere_4206.

• Set Component to DZ-Z Displacement.

You have finished creating all of the result vectors for the Max_Acceleration output 

response. As you can see from the graph on the left-hand side below, it has some noise. To 
eliminate the noise, you will use a filter and work on the filtered output response as seen 

from the graph on the right-hand side below. 
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4. Add two output responses.

a. Click Add Output Response twice.

b. In the work area, change the labels for the output responses to Max_Acceleration

and Max_Displacement.

5. Define the Max_Acceleration output response.

a. In the Expression column of the output response Max_Acceleration, click . 

b. In the Expression Builder, click the Functions tab.

c. From the list of functions, select saefilter. This function will apply a filter to the

acceleration vector.

d. Click Insert Varname. The function saefilter(,,) appears in the Evaluate

Expression field.

You can now add the time vector and the acceleration vector as arguments to the

function, with a class parameter of 180.

e. In the Evaluate Expression field, enter (m_1_ds_1,m_1_ds_2,180) in the

saefilter function.

f. To calculate the max of the expression, add the max function to the beginning of

the expression.

The expression should read: max(saefilter(m_1_ds_1,m_1_ds_2,180)).

g. To express the result in G, divide the max of the expression by 9810.

The expression should read: max(saefilter(m_1_ds_1,m_1_ds_2,180)/9810).
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h. Click OK.

6. Define the Max_Displacement output response.

a. Optional. Plot the displacement with respect to the time, to obtain the curve

illustrated below:

b. In the Expression column of the output response Max_Displacement, click . 

c. In the Expression Builder, click the Functions tab.

d. From the list of functions, select abs.

e. Click Insert Varname. The function abs()appears in the Evaluate Expression

field.

f. From the list of functions, select min.

g. Click Insert Varname. The expression should now read, abs(min()).

h. In the Evaluate Expression field, enter m_1_ds_3 in the min function.

i. Click OK.

7. Click Evaluate to extract the output response values of each expression.
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Step 6: Run a Screening DOE Study 

The model has 8 variables which may lead to high computation times for direct optimization 

or even for creating a response surface. 

You will reduce the number of actual input variables by running a screening experiment.  A 
full factorial experiment with 8 factors at 2 levels will require 28 (256) runs and with 3 

levels, it will increase to 6561 runs.  You will try to screen out some input variables by first 

doing a Fractional Factorial screening DOE. 

1. In the Explorer, right-click and select Add from the context menu.

2. In the Add - HyperStudy dialog, select DOE and click OK.

3. Go to the Specifications step.

4. In the work area, set the Mode to Fractional Factorial.

5. In the Settings tab, set Resolution to IV.

Note: Resolution IV enables an estimate of main effects unconfounded by two-factor
interactions. It also enables an estimate of two-factor interaction effects, which 

may be confounded with other two-factor interactions. 

6. Verify that the Number of runs is set to 16.

7. Click Apply.

8. Go to the Evaluate step.

9. Click Evaluate Tasks to execute the run matrix and extract the output responses for
all of the runs. HyperStudy runs 16 simulations in Fractional Factorial mode, therefore

the evaluation will take some time.

10. Go to the Post-Processing step.
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Step 7: Post Process the Screening DOE Study 

1. Click the Linear Effects tab to review the linear effects. Observe the main effect of the

input variables on both output responses.

2. Click the Pareto Plot tab, then use the Channel selector to select both of the output

responses. Observe that results.

Note: A linear effects plot and a pareto plot with the Linear effects option enabled

(shown below) provide the same information. However, with a pareto plot, you 

can use a statistical measure (that is, the 80-20 rule) to decide which input 

variables are more significant and which input variables can be neglected. 
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For this tutorial, you will use the 80/20 rule to eliminate input variables that are not 
significant to the study. The 80/20 rule is a Pareto principle that proposes 80% of the 

total effects comes from only 20% of the variables. 

Note: You should also use other practices to eliminate input variables that you feel 

should be taken in consideration. 

For screening purpose, you can see which input variables contribute to 80% or more of 

the given output response. In the images below you can see that:  

• For Max_Acceleration, the input variables length_internal, th_internal_skin, and

th_external_skin contribute to 80% of the linear effect.

• For Max_Displacement, the input variables length_internal and th_internal_skin fall

under the 80/20 rule.

For n responses, you can list out the input variables that follow the 80/20 rule, and take 
union of the sets. In this case, the input variables that follow the 80/20 rule include: 

length_internal, th_internal_skin, and th_external_skin. This narrows your list to three 

significant input variables.  

Step 8: Run a DOE Study for Approximation 

Since this optimization is based on response surfaces, a central composite experiment will 

be used, which will create a 2nd order response surface. 

1. In the Explorer, right-click and select Add from the context menu.

2. In the Add - HyperStudy dialog, select DOE and click OK.

3. Go to the Select Input Variables step.

4. In the Active column, keep only the three significant input variables (established in

step 7) selected. Clear the corresponding checkboxes for all other input variables.
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5. Go to the Specifications step.

6. In the work area, set the Mode to Central Composite.

7. Click Apply.

8. Go to the Evaluate step.

9. Click Evaluate Tasks to execute the run matrix and to extract the output responses.

Step 9: Run a DOE Study for the Validation Matrix 

Other points will be used to check the quality of the approximation. The points will be 

defined by a new DOE. In this DOE study, a Latin Hypercube of 10 runs will be used.  

1. Add a third Doe to the study by repeating Step 8: Run a DOE Study for

Approximation.

a. In the Specifications step, set the Mode to Latin HyperCube.

b. In the Settings tab, change the Number of runs to 10.

Step 10: Create an Approximation 

1. In the Explorer, right-click and select Add from the context menu.

2. In the Add - HyperStudy dialog, select Fit and click OK.

3. Go to the Select Matrices step.

4. Click Add Matrix twice.

5. Define FitMatrix1 and FitMatrix2 by selecting the options indicated in the image

below.
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6. Click Import Matrix.

7. Go to the Select Input Variables step.

8. Review the input variables and output responses. Only the length_internal,

th_internal_skin, and th_external_skin input variables should be active.

9. Go to the Specifications step.

10. In the work area, set the Mode to Moving Least Squares (MLSM).

11. In the Settings tab, verify that Regression Model is set to Linear (default).

Note:   It is advisable to start with lowest order and increment it in case model

Residuals and Diagnostics do not look feasible. 

12. Keep all other parameters to default as well.

13. Click Apply.

14. Go to the Evaluate step.

15. Click Evaluate Tasks.

16. Go to the Post-Processing step.

17. To assess the accuracy of the regression equations, click the Residuals and

Diagnostics tab.

18. To review the output response curves and surfaces, click the Trade-Off tabs.

In the Trade-Off 3D tab, use the Channel selector to plot input variables and output

responses. The values for the input variables which are not plotted are modified in the
top frame (Inputs). Move the sliders in the Value column to modify the other input

variables, while studying the output response throughout the design space.

Step 11: Run an Optimization Study 

1. In the Explorer, right-click and select Add from the context menu.

2. In the Add - HyperStudy dialog, select Optimization and click OK.

3. Go to the Select Input Variables step.

4. In the Active column, clear the checkboxes for all input variables except

length_internal, th_internal_skin and th_external_skin.

5. Go to the Select Output Responses step.

6. Apply an objective on the Max Acceleration output response.

a. In the Objectives column for Max Acceleration, click .

b. In the pop-up window, set Type to Minimize and click OK.

c. Set Evaluate From to Max_Acceleration__MLSM (r_1_fit_1).
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7. Apply a constraint on the Max Displacement output response.

a. In the Constraints column for Max Displacement, click .

b. In the pop-up window, define the following and click OK.

• Set Type to Deterministic.

• Set Bound Type to <= (less than or equal to).

• For Bound Value, enter 16.

c. Set Evaluate From to Max_Displacement__MLSM (r_2_fit_1).

8. Click Apply.

9. Go to the Specifications step.

10. In the work area, set the Mode to Genetic Algorithm (GA).

Note: Only the methods that are valid for the problem formulation are enabled.

11. In the Settings tab, change the Constraint violation tol. to 0.0.

Note: Optimization algorithms are usually solved so that a small violation in the

constraint is acceptable in order to save time in resolving the variables’ 
precision beyond a physical significance. Setting the Constraint violation tol. to 

zero will force HyperStudy to satisfy the constraint identically, which can 

increase the run time of the optimization in some cases. 

12. Click Apply.

13. Go to the Evaluate step.

14. Click Evaluate Tasks to optimize the design that minimizes the maximum acceleration

while keeping the displacement of node 35527 smaller than 16.

15. Click the Iteration Plot tab to monitor the Optimization iteration.
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16. Click the Iteration History tab to review a table of each iteration. The iterations that

do not respect the constraint are displayed red, the optimal design is displayed green.

Step 12: Evaluate the Results of the Approximate Optimal Design 

You have now determined the best design evaluated from the approximation. You can 

launch a solver run with the following input variables to check if the solution found by the 

approximation is close to the solver results. 

1. In the Explorer, study Setup, go to the Define Input Variables step.

2. In the work area, change the Nominal values to the values defined in the table below:

Variable Name Optimum Value 

th_external_skin 1.9216688 

th_internal_skin 1.9999998 

th_external_flange 1.00 

th_internal_flange 1.00 

Radius 0.00 

length_external 0.00 

width_external 0.00 

length_internal -0.9999824

3. Go to the Evaluate step.
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4. Click Evaluate Tasks.

5. Go to the Define Output Responses step.

6. Compare the optimum solution evaluated from the approximation to the same design

evaluated by the solver.

Note: Due to the use of different solver versions, results may vary. In following

comparison, the solver and approximation are in very good agreement with < 

1% error.  

Output Responses Approximation Solver 

Max_Acceleration 12.246401 12.293556 

Max_Displacement 15.999990 16.046738 
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