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HS-4220: Size Optimization Study on an Impact Simulation
Using RADIOSS

This tutorial demonstrates how to perform a size optimization on a finite element model
defined for RADIOSS. The RADIOSS model shown in figure 1 is run using the RADIOSS
Starter and Engine. The sample base input files boxbeaml 0000.rad and

boxbeaml 0001.rad can be found in <hst.zip>/HS-4220/and copied to your working
directly.

The objective is to minimize the mass of the beam under the following two constraints: the
internal energy must be more than 450, and the resulting reaction force must be less than
75. The input variables are the thicknesses of the four components defined in the input
deck boxbeaml. 0000.rad via the /PROP/SHELL entries. They are combined into two input
variables. The thickness should be between 0.5 and 2.0; the initial thickness is 1.0. The
optimization type is size.

Figure 1. Boxbeam model, undeformed.
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Figure 2. Boxbeam model, deformed, t = 2.001.
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Step 1: Create the Base Input Template in HyperStudy

Start HyperStudy
2. From the menu bar, click Tools > Editor. The Editor opens.

In the File field, navigate to your working directory and open the boxbeaml 0000.rad
file.

4. In the Find area, enter /PROP/SHELL/1.
Click P until you find /PROP/SHELL/1.
Highlight the field for thickness.

Tip: To assist you in selecting 20-character fields, press CTRL to activate the
Selector (set to 20 characters) and then click the value. HyperStudy highlights
20 fields.
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7. Right-click on the highlighted fields and select Create Parameter from the context
menu.

In the Parameter - varname_1 dialog, Label field, enter Upper part.

Set the Lower Bound to 0.5, the Nominal to 1.0, and the Upper Bound to 2.0.
10. Set the Format to %20.5f.
11. Click OK.

Parameter: varname_l - HyperStudy =)

Label: Upper part

Varname: varname_1

Lower Bound MNominal Upper Bound
0. 50000 1.00000 2.00000
(") Setpercent: +-
@ Setvalue: +-
Format:  420.5f - | =
Ok ] [ Cancel ] [ Apply ]
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Find /PROP/SHELL/2 and highlight the field for thickness.

p.3

Assign it the same thickness as /PROP/SHELL/1 by right-clicking on the highlighted

fields and selecting Attach to > varname_1 from the context menu.
Find /PROP/SHELL/3 and highlight the field for thickness.

Right-click on the highlighted fields and select Create Parameter from the context

menu.

In the Parameter - varname_2 dialog, Label field, enter Lower part.

Set the Lower Bound to 0.5, the Nominal to 1.0, and the Upper Bound to 2.0.

Set the Format to %20.5f.
Click OK.

Parameter: varname_2 - HyperStudy

Label: Lower part

Varmame: wvarname_2

Lower Bound Mominal Lpper Bound
0.5 1 2
Set percent: +
@ Setvalue: +-
Format:  9x20.5f =1
[ Ok ] | Cancel | | Apply

Find /PROP/SHELL/4 and highlight the field for thickness.

Assign it the same thickness as /PROP/SHELL/3 by right-clicking on the highlighted

fields and selecting Attach to > varname_2 from the context menu.

Click Save.

In the Save Template dialog, navigate to your working directory and save the file as

boxbeaml. tpl.
Close the Editor.
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Step 2: Optional. View the Base Input Template in TextView

Start HyperGraph.

2. On the Client Selector toolbar, select TextView.

'EEEE?E(‘-@

3. From the menu bar, click File > Open > Document.
4. In the Open Document dialog, open the boxbeaml.tpl file. The text editor displays
the following input variables that are defined by Templex parameter statements:

{parameter (tl, "Upper part",1.0,0.5,2.0)}
{parameter (t2, "Lower part",1.0,0.5,2.0)}

On the Text toolbar, click @
In the Find dialog, Find field, enter /PROP/SHELL.

7. Click #. The parameterized /PROP/SHELL cards, which reference the input variables,

highlight.
[/ p2op/ SHELLEGE
1
k-3 Ishell Ismstr
1 Z
-3 hm hif hr dm dn
i} i} 0 0 i}
£ N Istrain Thick Eshear Ithick Iplas
2 O{varmame 1, %20.5I} 1 a a
#3457 |-—8—-|——5——— | 10—
FEROEB/SHELL/Z
Z
k-3 Ishell Ismstr
1 Z
-4 hm hf hr dm dn
a a 4] 4] a
¥ N Istzrain Thick Lshear Ithick Iplas
z O{varname_1, %20.5f} 1 a a
#3457 |-—8—-|——5——— | 10—
FEROPB/SHELL/3
3
£ Ishell Ismstr
1 2
£ hm hi hr dm dn
a a a a a
¥ N Istzrain Thick Lshear Ithick Iplas
z O{varname_ 2, %20.5f} 1 a a
#7285 -——7"-|-———8—|——5%—— | 10—
SEROP/SHELL/ 4
4
£ Ishell Ismstr
1 z
£ hm hi hr dm dn
a a a a a
¥ H Istzrain Thick Lshear Ithick Iplas
2 Of{varname 2 %20_5f} 1 a a
#=---|----—|--—3—|--—4-—-—| -5 |- | ——-T-——— | ————F-——— | ———=F———— | ——=10-—-]
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8. On the Text toolbar, click #. The text editor evaluates the Templex statements, and

replaces the parameters with their initial values.

9. Repeat steps 2.5 through 2.7, and search for /PROP/SHELL again. You will find:

/PROP/ SHELLIEE

1
£ Ishell Ismstr
1 2
£ hm hf hr dm dn
u} a} u} u} a}
£ N Istrain Thick Lshear Ithick Iplas
2 a 1.00000 1 a a
i —1-—--——-——3—]-—- 4--—|--—5-—|-—c-—-|-—-T-—|—- g-—-—|-—%-——|-—10-—-
SEROB/SHELLSZ
2
£ Ishell Ismstr
1 Z
£ hm hi hr dm dn
a a a a a
£ N Istrain Thick Lshear Ithick Iplas
2 a 1.00000 1 a a
¢E-—1--—--—2-—-—|-—-—3-—-|-—- 4-——|-—--5-——|-————f-—| =T | ———- g--—|-—---%-———|-——10-——
SEROB/SHELLS 3
3
§ Ishell Ismstx
1 Z
£ hm hi hr dm dn
a a a a a
-4 N Iatrain Thick Eshear Ithick Iplas
Z u} 1.00000 1 u} u}
F——l--—|-——i-——=|———=3-———| - 4-——|-——=5-———|————f——— | =T | == g-————|-——=5———| -——10-——-
SEROEB/SHELL 4
4
£ Ishell Ismstr
1 z
£ hm hf hr dm dn
i} i} u} i} i}
§ N Istrain Thick Eshear Ithick Iplas
2 a 1.00000 1 a a
¢—1-———2i—|-—3——-|-— 4—|-——5—-—8—|-——-T-——-|-—- g-——|-—"5%———|-—10—-

10. Close HyperGraph; you do not need to save the session.

Step 3: Perform the Study Setup

1. Return to HyperStudy.

To start a new study, click File > New from the menu bar, or click '-= on the toolbar.

In the HyperStudy - Add dialog, enter a study name, select a location for the study,

and click OK.
4. Go to the Define models step.

Add a Parameterized File model.

a. From the Directory, drag-and-drop the boxbeaml.tpl file into the work area.

Proprietary Information of Altair Engineering
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42 Explorer = Directory f Define Models
Marne ‘ Size Type
4 | CAHS-4220 Add Model D Remove Model
& 859 bytes
¥, study lockxml Ytes Study Lock Active Label Varname Model Type

| | boxbeaml 0001.rad 412 bytes rad File
| | boxbeaml 0000.rad 142 KB rad File

;J boxbeaml.tpl ¢ L42KEB tpl File = boxbeamLtpl L‘-\S
» L0 _usr Settings Folder
|| Study_1.xml 3KE yml File

b. In the Solver input file column, enter boxbeaml 0000.rad. This is the name of
the solver input file HyperStudy writes during any evaluation.

c. Inthe Solver execution script column, select RADIOSS (radioss).

Active  Label Varname Model Type Resource Solver input file Solver execution script  Solver input arguments
[l
1 Model1l m_1 {} Parameterized File Ci/.../H5-4220/boxbeam].tpl (5 boxbearnl_0000.rad C‘j}.‘ RADIOSS (radioss ) S{file} [ 7]

6. Define a model dependency.
a. Click Model Resources.
b. In the Model Resource dialog, click Add Resource > Add Input Resource.

c. In the Select File dialog, navigate to your working directory and open the
boxbeaml 0001.rad file.

d. Set Operation to Copy.

e. Click Close.

f Model Resources - HyperStudy = @
IEI Add Resource ﬂ Remove Resource Run Directory Preview
Resources Run Directory Preview
MName Operation Varname MName
- & Study 1 (s1) A4 run_00001
v {} Model1(m1) - m1
boxbeaml.tpl @ Write Input m_1file_1 boxbeaml_0000.rad
boxbeaml_0001.rad Copy m_1.file_2 boxbeaml_0001.rad
] n b

= Model Resources

Close

7. Click Import Variables. Two input variables are imported from the boxbeaml.tpl
resource file.

7y Altair
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8. Go to the Define Input Variables step.

9. Review the input variable's lower and upper bound ranges.

10. Go to the Specifications step.

p.7

Step 4: Perform the Nominal Run

In the work area, set the Mode to Nominal Run.
Click Apply.
Go to the Evaluate step.

D W N B~

Click Evaluate Tasks. An approaches/nom 1/ directory is created inside the study

directory. The approaches/nom 1/run_ 00001/m_1 directory contains the result files.

5. Go to the Define Output Responses step.

Step 5: Create and Define Output Responses

1. Create the Energy output response, which is the internal energy of the model.

a. From the Directory, drag-and-drop the boxbeaml1T01 file, located in
approaches/nom_1/run_00001/m 1, into the work area.

b. In the File Assistant dialog, set the Reading technology to Altair®

HyperWorks® (hgradioss++.exe) and click Next.

Select Single item in a time series, then click Next.

d. Define the following options, and then click Next.
e Set Type to Global Variables.
e Set Request to Internal Energy.
¢ Set Component to MAG.

é File Assistant @

Single serial or time series

Subcase:

Type: | Global Variables - |

Request: |Interna| Energy > | Filter Y-

Component: | MAG - |

V| Preview:

4001
300
2009
1001

u
0 500 1000 1500 2000 2500
Index

< Back |[ MNext = ]| Cancel
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e. Label the output response Energy.
f. Set Expression to Maximum.
A File Assistant @
Create a Data Source and a Response
Creating a new Data Source
'= Label: Data Source 1
- Varname: m_1_ds_1
+/| Linked to a new Response
Label: Energy
J Varname: m_1r_1
Comment:  Data Source 1
Expression: |max(m_1_ds_1) Maximum -
| < Back | [ Finish ] | Cancel |
g. Click Finish. The Energy output response is added to the work area.
2. Create the Force output response, which is the resultant reaction force in the Z-
direction.
a. From the Directory, drag-and-drop the boxbeaml1T01 file, located in

e.

f.

g.

approaches/nom 1/run 00001/m 1, into the work area.

In the File Assistant dialog, set the Reading technology to Altair®
HyperWorks® (hgradioss++.exe) and click Next.

Select Single item in a time series, then click Next.
Define the following options, and then click Next.

e Set Type to Rigid wall/Wall Force.

e Set Requestto 1 RWALL 1.

e Set Component to FNZ-Z NORMAL FORCE.
Label the output response Force.

Set Expression to Maximum.

Click Finish. The Force output response is added to the work area.

3. Create the Mass output response.

a.

Proprietary Information of Altair Engineering

From the Directory, drag-and-drop the boxbeam1T01 file, located in
approaches/nom 1/run 00001/m 1, into the work area.

In the File Assistant dialog, set the Reading technology to Altair®
HyperWorks® (hgradioss++.exe) and click Next.

Select Single item in a time series, then click Next.

Define the following options, and then click Next.

p.8
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e Set Type to Global Variables.
¢ Set Request to Mass.
e Set Component to MAG.
e. Label the output response Mass.
f. Set Expression to First Element.
g. Click Finish. The Mass output response is added to the work area.

4. Click Evaluate to extract the output response values.

Active  Label Varname Expression Walue Comment
1 Energy m_1.r1l max(m_1_ds_1) ven 438,583
2 Force mlr?d max(m_1_ds_2) ven
3 Mass mlr3 m_Ll_ds_3[0] 25.446430 Data Source 3 ves

71 Data Sourcel ves

fosy
w

Data Source 2 ves
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Step 6: Run an Optimization Study

In the Explorer, right-click and select Add from the context menu.
In the Add - HyperStudy dialog, select Optimization and click OK.
Go to the Select Input Variables step.

Review the lower and upper bound ranges of the input variables.

Go to the Select Output Responses step.

o U A W=

Apply an objective to the Mass output response.
a. In the Objectives column for Mass, click .

b. In the pop-up window, set Type to Minimize and click OK.

Active Label Varname Objectives Constraints Evaluate From
1 Energy mlrl [+ [+] Sabver
2 Force m_lr2 [ +] [+] Solver
Si Mass mlr3 Minirmize ven [+ Sobver

7. Apply a constraint to the Energy output responses.
a. In the Constraints column for Energy, click &.
b. In the pop-up window, define the following and click OK.
e Set Type to Deterministic.
e Set Bound Type to >=.
e For Bound Value, enter 450.

8. Apply a constraint to the Force output responses.

Proprietary Information of Altair Engineering

7y Altair



Altair HyperStudy 2019 Tutorials p.10

a. In the Constraints column for Energy, click &.

b. In the pop-up window, define the following and click OK.
e Set Type to Deterministic.
e Set Bound Type to <=.

e For Bound Value, enter 75.

Active Label Varname Objectives Constraints Evaluate From
1 Energy m_1_rl 2 == 45000000 vew Solver
2 Force m_1_r 2 2 <= 75000000 vew Solver
3 Mass m_1_r 3 Minimize ven 2 Solver

9. Click Apply.

10. Go to the Specifications step.

11. In the work area, set the Mode to Adaptive Response Surface Method (ARSM).
Note: Only the methods that are valid for the problem formulation are enabled.

12. Click Apply.

13. Go to the Evaluate step.

14. Click Evaluate Tasks to launch the Optimization.

Step 7: View the Iteration History of an Optimization Study

1. Click the Iteration History tab to display data in a tabluar view. The optimal design is
highlighted green, the infeasible designs are shown with red text, and the violated
constraints are indicated in bold text.

P+ Upperpart B+ Lowerpart % Energy o Force dh Mass |« Objectivel |ff Constraintl |§ Constraint2 Iteration Index Evaluation
1 1.0000000 1.0000000 43858371  89.973709 25446430 25446430 438.58371 89.973709 1 1
2 1.1650000 1.0000000 43471823 69646622 25480009 25.480909 434.71823 69.646622 2 2
3 1.0000000 1.1650000 49014233 68711662 25485611 25485611 49014233 68.711662 3 3
4 10772704 1.0423280 41919440 74710403 25472628 25472628 419.19440 T4.710403 4 4
Fy 1.0256669 1.0904766 440924582 | 75.045273 | 25473280 | 25.473280 449.24582 75.045273 5 5

2. Click the Iteration Plot tab to plot the iteration history of the study's objectives,
constraints, and input variables.

Using the Channel selector, select Objective 1, Constraint 1, and Constraint 2.

In the initial design, the design was infeasible as indicated by the large circular marker
for the first iteration. A view of the constraint plots shows that the second constraint
was violated in the initial design. Initially, the optimizer added some weight in order to
satisfy the design constraints. Notice that both constraints are near their bounds in the
optimal design.

4 | ‘
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