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HS-1506: Material Calibration with a Curve Difference Integral

In this tutorial you will learn how to register a Compose, Python, or Templex function in
HyperStudy. The objective of this tutorial is to find the RADIOSS material parameter values
so that the stress-strain curve of the tensile test simulation matches the tensile test
experimental curve. HS-4200: Material Calibration Using System Identification provides an
alternative method to setup this problem using system identification.

By the end of this tutorial, you will know how to:
e Create an input template from a RADIOSS file using the HyperStudy - Editor
e Register a Compose, Python, or Templex function
e Setup a study

e Run a system identification optimization study

The sample base input template used in this tutorial can be found in <hst.zip>/
HS-1506/. Copy all of the files from this directory to your working directory. The .py
and .oml file contain a function that calculates the area between two curves.

Description of the Model

A quarter of a standard tensile test specimen is modeled using symmetry conditions. A
traction is applied to a specimen via an imposed velocity at the left-end.

The units are: mm, ms, g, N, MPa.
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The material to be characterized is a 6063 T7 Aluminum. It has an isotropic elasto-plastic
behavior which can be reproduced by a Johnson-Cook model without damage (RADIOSS
Block Law2), defined as follows:
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0 = Stress level 1= Hardening Exponent
EP = Plastic strain € = Strain rate coefficient
1= Yield Stress £ = Strain rate
b= Hardening modulus &, = Reference strain rate

In this study, the parameters a, b, n, omax (maximum stress), and the Young modulus are
defined as input variables. The stress-strain curve obtained by the experimental test is
shown in the following image.
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Engineering Stress Versus Engineering Strain Curve (Experimental Data)

For the simulation results, engineering strains will be obtained by dividing the displacement
of node 1 by the reference length (75 mm), and engineering stresses will be obtained by
dividing the force in section 1 by its initial surface (10.2 mm2).
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Engineering Stress Versus Strain Curve (Simulation Results)

Step 1: Create the Base Input Template in HyperStudy

In this step, you can create the base input template in HyperStudy or use the base input
template in the study Directory.

1.

v A W N

Start HyperStudy.

From the menu bar, click Tools > Editor. The Editor opens.
In the File field, open the TENSILE TEST 0000.rad file.

In the Find area, enter /MAT/PLAS JOHNS/1.

Click ». HyperStudy highlights /MAT/PLAS JOHNS/1.

44  §---Z. MATERIALS:
45  f-——l-———|————F-——— | ————F-——— | ———— 4-———|———=5———— | ————f———— | ———- e

£1) /MAT/PLAS JOHNS/

47 Law_ 2

BB B 2HO_I
45 e OOZT e _o0z7
SO B B Hu
S1 e BOAO0 e 33

Select variable E by highlighting the first 20 fields in row 51.

Tip: Quickly highlight 20-character fields by pressing CTRL to activate the Selector
(set to 20 characters) and then clicking the value.

t13 JMAT/PLAS JOHNS/1

4 | -
Proprietary Information of Altair Engineering ) A ta I f



Altair HyperStudy

2019 Tutorials

p.4

7. Right-click on the highlighted fields and select Create Parameter from the context

menu.

8. In the Parameter-varname_1 dialog, Label field, enter E Young.

9. Set the Lower Bound to 50000, the Initial Bound to 60400, and the Upper Bound to

70000.

10. In the Format field, enter $20.5f¢.

Label:

Parameter: varname_1 - HyperStudy

E_Young

Varmame: wvarname_1

Lower Bound Mominal
50000 20400
() Setpercent:
@ Setwvalue:
Format:  =420,5F

Lpper Bound

F0000

+/-

+-

-

| ok || cancel

[ Aoy |

11. Click OK.

12. Define four more variables using the information provided in the table below.

Variabl Label Lower Initial Upper Format
Bound Value Bound
a a_PlasticityYieldStress 90 110 120 %20.5f
b b_HardeningCoeff 100 125 160 %20.5f
n n_HardeningExpo 0.1 0.2 0.3 %20.5f
sigmax |Sigma_Max 250 280 290 %?20.5f
13. Click Save.

14. In the Save Template dialog, save the file as TENSILE TEST 0000.tpl.

15. Close the Editor.
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Step 2: Register the Curve Difference Function

The function curve_difference calculates the integral of the absolute value of the difference
between two curves over the common domain of the supplied functions. This is a robust
function that tends to zero only as the two functions become equal.

Register the curve_difference function using:

- Compose

[21f(x) — g(x)]dx

1. Start Compose.

2. From the menu bar, click File > Open.

3. In the Open File dialog, open the file Curve Difference.oml.

4. Highlight the function curve_difference(...).

5. Right-click on the highlighted text and select Register Function
from the context menu.

6. In the Register Function dialog, click OK.
Close Compose.

Python

1. In your favorite text editor, open the hst pref py.mvw file.

2. Replace <path> with the actual location of the curve difference.py file.

*Id("HyperStudy v11.0")
*BeginDefaults ()
*BeginPlotDefaults ()

*RegisterPythonFunction ("curve difference",
"<path>/curve difference.py", 1)

*EndPlotDefaults ()

*EndDefaults ()

Save the changes you made to the preference file.
Close the text editor.

In HyperStudy, from the menu bar, click File > Set Preferences File.

o v kW

In the HyperStudy - Set Preferences dialog, navigate to your working directory
and open the hst pref py.mvw file.
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Templex

1. From the menu bar, click File > Use Preferences File.

2. In the HyperStudy - Set Preference File dialog, open the curve difference.mvw
file.

Step 3: Perform the Study Setup

To start a new study, click File > New from the menu bar, or click .- on the toolbar.

2. In the HyperStudy - Add dialog, enter a study name, select a location for the study,
and click OK.

Go to the Define models step.
4. Add a Parameterized File model.

a. From the Directory, drag-and-drop the TENSILE TEST 0000.tpl file into the work

area.
45 Explorer = Directory ,f Define Models
Mame ‘ Size .
4 | CAHS-1506 Add Model kd Remove Mode
\f study_lock.xm| 897 bytes ¢ Active  Label Varname Model Type
v hst_pref_py.mvw 173 bytes
|| experiment.xy IKB 4
|| curve_difference.py 3KB | |_] TEMNSILE_TEST_0000.tpl %
|| curve_difference.hml 1KB |
™y area_bw_two_curvesmvw 515 bytes |
_usr 3
| | TEMSILE TEST 0001.rad 323 bytes
e TENSILE TEST 0000.4pl |  58KB ¢
| | TEMSILE_TEST_0000.rad 58 KB ¢
| Study 1.oml 3KB

b. In the Solver input file column, enter TENSILE TEST 0000.rad. This is the name
of the solver input file HyperStudy writes during any evaluation.

In the Solver execution script column, select RADIOSS (radioss).

d. Verify that the Solver input arguments field reads $file. This solver input
argument runs the Starter and the Engine of RADIOSS for the crash analysis, and
also prevents the creation of the .h3d result file from animation files.

Note: X is the number of CPUs to use for the simulation.

Active  Label Varmame Model Type Resource Solver input file Solver execution script  Solver input arguments

1 Modell m 1 {} Parameterized File Ci/.../H5-1506/TENSILE_TEST_0000.tpl (=5 TEMSILE_TEST_0000.rad “’:'?J‘ RADIOSS ( radioss ) S{file} [ 2]
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5. Define a model dependency.
a. Click Model Resources.
b. In the Model Resource dialog, click Add Resource > Add Input Resource.

c. In the Select File dialog, navigate to your working directory and open the
TENSILE TEST 0001.rad file.

d. Set Operation to Copy.

e. Click Close.

f Model Resources - HyperStudy = @
3 Add Resource a Remowe Resource Run Directory Preview
Resources
Mame Operation Yarname

- \ﬁ Study 1(s1)

v {} Model1(m1)
% TENSILE_TEST_00004p! |5/ WriteInput m_1file1

= TENSILE_TEST_0001.rad Copy m_1 file_2

= Model Resources

Close

6. Click Import Variables. Five input variables are imported from the
TENSILE TEST 0000.tpl resource file.

Go to the Define Input Variables step.
Review the input variable's lower and upper bound ranges.

Go to the Specifications step.

Step 4: Perform the Base Run

In the work area, set the Mode to Nominal Run.
Click Apply.

Go to the Evaluate step.

AR W N

Click Evaluate Tasks. An approaches/nom 1/ directory is created inside the study
directory. The approaches/nom 1/run_ 00001/m_1 directory contains the
TENSILE TESTTO1 file, which consist of the time history results of the simulation.

5. Go to the Define Output Responses step.

4 | -
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Step 5: Create and Define Output Responses

In order to fit the RADIOSS stress-strain curve to the experimental data, you must compare
the two curves. In this step, you will use the curve_difference function.

1. Create the Area Between Two Curves output response.

a. Click Add Output Response.

b. Inthe work area, Label field, enter Area Between Two Curves.
2. Create a data source labeled Disp_sim.

a. From the Directory, drag-and-drop the TENSILE TESTO1 file, located in
approaches/nom 1/run 00001/m 1, into the work area.

b. In the File Assistant dialog, set the Reading technology to Altair®
HyperWorks® and click Next.

Select Single item in a time series, then click Next.
d. Define the following options, then click Next.

e Set Type to None/Node 1.

e Set Request to 4 Node 1.

e Set Component to DX-X Displacement.

o File Assistant |

Single serial or time series

Subcase:

Type: [NadefNode 1 - l
Request: [4 Mode 1 v] Filter .
Component: [Dx—x Displacement - l
Preview: 10

o

81,

7

67

5.

41,

&)

P b

1-' - - = - - - = = -

0 T T T T T T T T T

0 200 400 600 200 1000 1200 1400 1800 1300 2000
Index
l < Back ] [ Next > l [ Cancel ]

e. Under Creating a new Data Source, enter Disp sim in the Label field.
f. Clear the Linked to a new Response checkbox.
g. Click Finish
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'ﬁ File Assistant

Create a Data Source & Response

Creating a new Data Source

Label: Disp_sim

vl

Varname: m_1_ds_1

Linked to a new Respanse

Label: Response
Comment: |Data Source 1
CXpressio b 1 ds V@ ximL
< Back | [ Finish ] | Cancel

p.9

3. Create a second data source labeled Force_sim by repeating step 2, except select the

following options:
e Set Type to Section/SECTION_2.

e Set Request to 2 section 1.

e Set Component to FT-Resultant Tangent Force.

4. Create a third data source labeled Strain_exp.

a. In the Expression column of the Area Between Two Curves output response, click

[T 1]

b. In the Expression Builder, click the Data Sources tab.

c. Click Add Data Source. A new data source is added to the work area.
d. In the Label field for the new data source, enter Strain exp.

e. In the File field, click **=,

f. In the Data Source Builder, define the data source and click OK.

¢ In the File field, navigate to your working directory and open the

experiment.xy file.
e Set Tool to File Source.
e Set Type to Unknown.
e Set Request to Blockl1.
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¢ Set Component to Column 1.

I

'ﬁ Data Scurce Builder: Strain_exp ( ds_3 ) - HyperStudy | = '@

File: Z:fUsersfdgallo/Desktophst_tuts/HS-1506 fexperiment. xy

File Reference: study-file:/ffexperiment, xy

=] HyperWorks® reader available { hgtextoolumn.exe )
Tool: File Source -
Subcase:
Type: [L.Inknnwn - ]
Reguest: [Eluckl * [ Filter T
Component: [Culumnl v]
Freview: 014
0.129
0107 :
0.089
D061
0.041 :
Duz- - - - - -
: : R SRt I I R e Jen
0 20 40 60 al 100 120 140 160 180 200

Index

Ok ] [ Cancel

5. Create a fourth file source labeled Stress_Exp by repeating step 4, except select the
following options:

e Set Type to Unknown.
e Set Request to Blockl1.
e Set Component to Column 2.
6. Define the Area Between Two Curves output response.
a. In the Expression Builder, click the Functions tab.
b. From the list of available functions, select curve_difference.

c. Click Insert Varname. The function curve difference ()appears in the Evaluate
Expression field.

4 | -
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ABC
{as) Evaluate Expression

curve differencef(,,,)

d. In the Evaluate Expression field, edit the expression so that it reads
curve difference(m 1 ds 1/75,m 1 ds 2/10.2,ds 3,ds_4).

Note: In the expression, you will notice that the four data sources are entered
differently. The varname for the first two data sources created using the
File Assistant are labeled as m_1_d_#, whereas the varname for the last
two data sources created in the Expression Builder are labeled as ds_#.

The displacements and forces are read from the simulation, whereas from the
experiment you have strains and stresses. In order to convert the displacement
and forces to strains and stresses, you need to divide the displacements by the
length (75) and forces by the area (10.2).

f‘f_c) Evaluate Expression

curve difference(m 1 ds 1/75,m 1 ds_2/10.2,ds_3,d=s_4) |

7. Click OK to close the Expression Builder.

8. Click Evaluate to extract the output response value.

Step 6: Run an Optimization Study

In the Explorer, right-click and select Add from the context menu.
In the Add - HyperStudy dialog, select Optimization and click OK.
Go to the Select Input Variables step.

Review the input variable's lower and upper bound ranges.

Go to the Select Output Responses step.

A

Apply an objective on the Area Between Two Curves output response.
a. In the Objectives column for Area Between Two Curves, click &.

b. In the pop-up window, set Type to Minimize and click OK.

4 | -
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D Add Ohjective D Remove Objective

Active Label Varname Type Target Value Weighted Sum  Reference Value
Objectivel obj_1 Minimize w | 1.0000000 0000000

Click Apply.
Go to the Specifications step.
9. In the work area, set the Mode to Adaptive Response Surface Method (ARSM).
Note: Only the methods that are valid for the problem formulation are enabled.
10. Click Apply.
11. Go to the Evaluate step.
12. Click Evaluate Tasks.

13. Optional. Click the Evaluation Plot tab to plot the optimization iteration history of the
objective.

3.5

3.0

0.57

0.0 - - - = - = - = - - -
0 2 4 8 a8 10 12 14 16 18
Evaluation Index

14. Optional. Click the Iteration History tab to review the iteration history in a table.
Last modified: v2017.2 (9.1144596)
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