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MV-8500: Using the Truck Library

Introduction

The purpose of this tutorial is to walk you through the process of how to build a full truck
model with advanced drivers and how to add events to the model built. The new event
user interface is supported only for models with advanced drivers. Files can be edited or
updated in the event editor. Sixteen event types are supported. To learn more about the
events, see the Full vehicle with Advanced Drivers topic.

The process involves:
e Launching MotionView
e Building a Full Truck Model with Driver
e Adding Events to the Model

¢ Viewing Reports

Step 1: Launching MotionView.

In MotionView, models are assembled from libraries of pre-defined systems using the
Assembly Wizard. The Assembly Wizard dialog guides you through the assembly
process, ensuring that your selections are compatible.

Note The MBD Vehicle Dynamics Tools preferences must be loaded before using the
event builder. Select File > Load > Preference File > MBD-Vehicle
Dynamics Tools from the MotionView interface.

1. Start a new MotionView session.
The MotionView window is displayed.
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Note Set the required truck wizard paths to start assembling the model through
Assembly Wizard dialog.
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2. Click Model > Set Wizard Paths.

SolverMode Ilu'lu-d-el Analysis  Tools |

., Azzambly wizard...
FeT Attachment YWizard...
;:ﬂ Set ‘Wizard Paths...
b aterials. ..

=1

I Irnplicit Graphics. .. sh

Drata Summary. ..

Topaology Summary...

The Set wizard library dialog is displayed.

"\ Set wizard library

Wizeard librery: |carrsme tuck ~]
Asgemblywizard file: Ii|l:'|fpwgram Filees/ARaie/ 201 7.1.0 6-raghphauts_BVT_BW1-den3 lwfmdl/ mdllibyfmodel_wizard wed
Task wizard filo: li|c fProgram Files aRair/ 201 7.1.006-rag hphauto_BYT_BW1 -t 3 wmadl/mdllibtask_wizard wed
MDLstandardinciude fle: | |C:/Program Files/ARair/2017.1.0 6-+aghpMauto_BT_BW1-dev3/tw/mdl/mdlib/sid_inc.mdi

Wizerd library directory. |=" |C#Program Files/AReir/2017.1.0 6-raghpMeuto_BVT_BW1-deva/tw/mdl/mdlib

Rieport log file: | |C:/Users/swanths/ reports

3. From the Wizard library drop-down menu, select the Heavy Truck option. Browse
and locate the required paths from the installation folder and click OK.

Wizard librany: Heawy truck
[Car/Small truck

Assembhy wizard file: serd Custom librany

Task wizard file: |’—_"| CofProgram FilesAltain 2017 100,07 Mt medlf mdlliby truck_task_wizard wed

MDOL standard include file: Iil C:fProgram Files fAlbair/ 20071007 fhwfmdl frmdlliby std_inc.mdl

‘Wizard library directory: |i| CfFrogram Files/Altair/ 20717 10007 e mdl mcllib

Fepor log file: |£|C:.fl.lsarsfmmg.!.mpnrls

7y Altair
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4. Click Model > Assembly Wizard.

ols  SelverMode [Mudel] Analysis  Tools  FlexTo

R Azsembly Wizard...
T Attachment Wizard...

A
:_T EI Ij @ Set wizard Pathz...

M atenals. .

mEI IDI Cﬂlorl M Implicit Graphics...
del -

Drata Surmmarny....

Topalagy Surnmary....

The Heavy truck - Model Type window is displayed.

"\ Heavy truck - Model Type n

Faga 1of11
Select the model type

" Front end of tuck
" Rear end of tuck
o Full truck: with driver

Reset Selection | Message Log... < Back Mext » Cancel
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Step 2: Building a Full Truck Model with Driver.

p.4

In MotionView, truck models are assembled from libraries of pre-defined systems using
the Heavy Truck library. It guides you through the assembly process, ensuring that
your selections are compatible. The Full truck with driver model type builds the model
with steering, front suspension, rear suspension, powertrain, driveline, and driver signal

generator.

1. Select the Full truck with driver option and click Next.

"y Heavy truck - Model Type

Select the model type
" Front end of truck

" Rear end of truck
& Full truck with drivear

Mext >

Reset Selechion | Message Log. < Black

Fage 10111

Cancel

Primary Systems Selection

2. Select the Body and Cab from the Truck body and Cabin body drop-down menus

respectively and click Next.

"\ Heavy truck - Primary Systems for Full truck with driver model

Select bodies

Faga 2oi11

Truck body |Elu|:|y

7l

Cabin body |cab

Reset Selection | Messege Log.. < Back MMt »

7

Cancel
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3. Select Front solid axle suspension for the Front suspension, Rear dual solid
axle suspension for the Rear suspension, Linear Torque Map Powertrain for
the Powertrain, and Driver Signal Generator for the Signal Generator and click

Next.

"y Heavy truck - Primary Systems for Full truck with driver model ﬁ
Select primary systems Fage Jofl1
Frant suspension |Fr|:|r|1 solid axde suspension j
Rear suspension |Rear dual solid axle suspension j
Fowertrain |Linear Torque Map Fowertrain j
Signal Generator |Drwer Signal Ganerator j
Reset Selechon | Message Log.. | < Back MMext » Cancel |

Steering Systems for a Full Truck Model

4. Select Pitman Arm Steering for the Steering linkages, Steering column for the
Steering column, and Steering boost for the Steering boost in the steering
subsystems page.

"\ Heavy truck - Steering systems for Full truck with driver Model ﬁ
Select steering subsystems Fage 40f11
Steering linkages |Pitman Am Steering 7
Steering column |Sleeﬁng calumn j
Steering boost |SIEEring boost j
Reset Selection | Message Log. < Back Mesd > Cancel

7y Altair
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Springs and Stabars for a Full Truck Model

5. Select Leaf springs for the Front spring and Bell crank linked leaf spring for
the Rear spring for the model and click Next.

"\ Heavy truck - Springs and Stabars for Full truck with driver ﬁ
Select springs and stabars Page 50f 11
Frant spring |LECI.1 Springs j
Front stabilizer bars |Na ne j
Rear spring |E|e|| crank linked leaf springs j
Rear stabilizer bars |Nn ne j
Reset Selechon | Message Log.. | < Back [Nt > Cancel |

Note Based on the suspension type selected for the Front suspension and Rear
suspension, the Front spring and Rear spring options are modified
accordingly.

Shock Absorbers

6. Select the required shock absorbers from the Front shocks and Rear shocks drop-
down menus and click Next.

"\ Heavy truck - Dampers for Full truck with driver model ﬁ
Select Shock Absorbers Fage 6ofl1
Front shocks |Fn:|nt shock absorher (with inline jis ) j
Rear shocks |F‘i.enr shock absorbers (with inline jts ) j
Reset Selechon | Message Log., < Back It » Cancel

7y Altair
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Jounce/Rebound Bumpers

7. Select the following options for the Front and Rear Jounce/rebound bumpers and
click Next.

"\ Heavy truck - Jounce/Rebound Bumpers for Full truck with driver model n

Select jounce and rebound bumpers Paga 7of 11

Frant jounce bumpers |Fn:|n1 extarnal jounce bumpers

Frant rebound bumpers | Front estarnmal reb bumpers

Rear jounce bumpers |Renr extarnal jounce bumpers

Lt Led L] Lo

Rear rebound bumpers | Fear estarnal reb burmpers

Reset Selection | Message Log.. | < Back MMext » Cancel |

Driveline Systems

8. In the next page, select Disk Brakes and Two-axle driveline from the Disc
Brakes and Rear driveline drop-down menus respectively and click Next.

"\ Heavy truck - n
Select driveline systems Fage §of11
Disk Brakes |Disk Brakes j
Rear driveline | Two-ade drivaline h
Reset Selechon | Message Log.. < Back MMext » Cancel

Note Based on the suspension type selected, the Rear driveline options are
modified accordingly.

7y Altair
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9.

"\ Heavy truck - RWD Driveshaft Systems for Full truck with driver Model

Select driveshaft systems

Faga 3o0i11

Rear driveshatt |Re ar driveshafl 1-piece

]

Auxiliary driveshaft |Semndnr’y driveshaft

< Back [ »

Feset Selection | Message Log...

]

Cancel

For a full truck with advanced driver, you have to select the required driveshaft
systems from the Rear driveshaft drop-down menu as shown in the image below.

10. Select the required Driver system for the full truck model as shown in the image

below.

"\ Heavy truck - Full vehicle Driver

Select a Driver system

Faga 100f11

Diriver systam |ﬁ-.|1¢ir Diriver

< Back Mend »

Reset Selechon | Message Log.,

]

Cancel

Proprietary Information of Altair Engineering

7y Altair



Altair MotionView 2019 Tutorials p.9

11. Now that you have selected all the required systems for the model, click the Finish
button to complete the process and exit the custom library wizard.

" Heavy truck - Full vehicle Driver ﬁ

Fage 110f11
To complete the assembly process and exit the wizard, use the Finish buttion,

To proceed to the Aftachment Wizard, use the Aftachmenis button.

Reset Selection | Message Log.. < Back Attachments » Finish Cancel

12. The full truck with driver model is displayed in the MotionView window.

& | -
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13.

Session  Project =

Step 3: Adding Events to the Model.

The following steps outline how to add an event to the previously built model. Currently,

sixteen event types are available in the advanced driver models:

Constant Radius

Single Lane Change
Double Lane Change
Swept Sine

Straight Line Acceleration
Straight Line Braking
Sinusoidal Steering
BrakeIn Turn

J Turn

Throttle off cornering
Swept Steer

Pulse Steer

Throttle off TurnIn

Step Steer

Power off In Straight Line

Altair Driver File

Proprietary Information of Altair Engineering

Objects | Varname Il
=& - Model the_modsl

B Bodies (1)

Data Sets ()

Markears (1)

Gl Paims (1)

41 Wedhors (3)

= © Misc SYE_Pnisc

0@ & Body sys_body

EHE & Cab sys_cab

Sl Front solid axle suspension sys_frn_susp

G1El © Reardual solid axle SUSPENSION SYS_Fesr_susp

& O Linear Torgue Map Powettrain — sys_pwiirain

i &l © Driver Signal Generator sys_signal_generator

=@l & Fitman Arm Steering sys_staering

o1&l © Disk Brakes sys_brakes

Gl & Two-axde driveling sys_r_dmvehne

=8l © Rear driveshafl 1-pisce sys_driveshaft

1%l Secondery driveshaft sys_r_owx_driveshafl

5 © Altair Driver altair_drivar

p.10

The subsystems that you have selected in the Custom library wizard to build the
model are displayed in the Project browser.
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Each event type has different options that needs to be addressed. For example, in the
following steps Constant Radius is explained.

1. Right-click on Model in the Project browser and select Add Events from the
context menu.

Session  Project x

Objects [ Varname |

Bl o .
=B Bo Expand All Children
0107 D Collapse All Childran
B Ma ) .
6B Fo Fitter Using Toolbar
E-E Ve Sy
oy
oGl G Sawe As..
§ : Rename F2
L E
5 | Apphy Atachment Candidates qup
:TI - Acld » [N
SHE C _generator
1@ G Delets Del ”
EE o Cu Cirl+x &
=& S Paste Cirl+y  Eline
wH-El O | haft
s o Add Auto Entity r
Add Evants
Data Summary...
#* Find... Cil+F

2. The Add Scripted Driver Task dialog is displayed.

"\ Add Scripted Driver Task
Farent Sy'slem IMudal
Type:  [ConstantRiadius =
Label:  |ConstantRadius 0
“Wariable: |mnlutl

Mote (Literal):

& | -
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3. From the Type drop-down menu, select the Constant Radius event and click OK.

The Constant Radius event is added in the Project browser.

Session  Praject =
Objects | Varmame | Il
@& © Modet the_model
5[0 Bodies (1)
EFE] Data Sets (2)
B Markaers (1)
&-E Points (1)
E-ED Wedors (3)
EHEl O Misc sy5_riss
G1Fl & Body sys_hody
=&l & Cab sys_cab
G El © Frontsolid axle suspension sws_fit_susp
& Fear dual solid axle suspension sys_rear_susp
G-l O Linear Targue Map Powertrain  sys_pwilrain
51-#&l & Driver Signal Generator sys_signal_genarator
FHEl ¢ Pitman Arm Steering sys_sleering
S &l Disk Brakes sys_brakes
= Two-axle driveling sys_r_driveling
G- © Reardiveshaft 1-piece sys_driveshaft
51l © Secondary driveshaft sys_r_aw_driveshaft
E-E © Ahair Driver altair_driver
ol

4. The Event Editor is displayed in the panel area.

L - e

e

:

rindd_[ K| |

Comaant Faders Comsing

Vishichi itk on & ebaighl asd Ben eskick o comin ol anitant radius 8 an ndalwilssle Thiovwhidivelachy s ilwly némiaied
B8 & AT O Wi LVl A TS0t T BRal Voo,

Evvpernt E chbine
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5. The Event Editor window can be invoked by right-clicking on the event type in the

Project browser and selecting Event Editor from the context menu.

B8 O AltairDriver | e I
0@ Expand All Children

Collapse All Children

Filter Using Toolbar
Show Anahyses Only

Seve
Save As

Activate

Deactivate

Rename F2
Apphy Attachment Candidates

Show Shared Instances

Separate Definition

Add L3
Delete Del
Cut Cirlei
Pasta Carl+y
Run Eveant
Fumn All
Ewent Manu >
Diata Summany...

% Find... CirlsF

OR
— You can click on the Event Editor button in the panel area.
6. Click the Event Editor button from the panel area (or from the list).

The Constant Radius event’s parameter is displayed.

FParameters
Radius [m] : 400
Initial straight [m] : 200
Turn direction : Left hd I
Initial velocity [m,s] : 50
Final velocihy [m/s] - 12.0
Time in circular frack [s] 10.0
Initial lateral acc [g's] : 0.064
Final lateral acc [a's] : 0.367
Look ahead fime [5] - 0s
Prediction step size . 0,01
Print interval [5] . 0.05 W

Initial Straight

I Show Diriver Output Settings
Outpust XML File
2]

Simulation Setings

Output Options

Proprietary Information of Altair Engineering
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7. Enter the above information in the Parameters section and browse and locate the
file path in the Output XML File.

8. After entering all the required data, the event is ready to run. Click the Run button.

Note An ADF (Altair Driver File) is generated with all the event parameters at the
XML file path (Output XML File) location. The model is exported and
MotionSolve starts to generate the result files.

Hyperworks MotionSolve is invoked in the background.

Solver  mbd_d.exe

Input file: driver-testxm Progress for PID: 7300

Run command: ./hwsolver.tcl -solver MS -screen ../driver-testxmil -dir

Keaging 1uU actlon Lorces... P Tl
Reading 1 event sensors... ind:

Reading 16 marker displacement requests...
Reading 10 user-expressions reguests...
Reading 35 usersub (REQSUB) requests...
|| Reading 376 graphics...
INFO: Starting SMP run with up to 4 threads.
INFO: Usersub library [C:\Program Files\Altair\2017.0.0.17-raghpMauto_17

USRMES : USER1

INFO: No Drag Info found

<< ALTAIR DRIVER :: Checking MotionSolve license.

Checking out license feature 16 ...

< >

Abort Kill Pause View - Close

9. After the MotionSolve run is completed, close the window and return to the
MotionView interface. The generated file types include: .adf, .plt, and .h3d files.

Step 4: Viewing Reports.

Report templates are a series of pre-defined plots that apply the standard set of plots
required for an event. A report template generates all of the plots and properly labels
them.

1. Click Analysis > View Reports.
lode Model | Analysis Tools FlexTools

| ﬂ Task ¥Wizard.. : om lm
Wiew Reaparts, .

The View Reports wizard is displayed.

& | -
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2. Select the Driver Output Report option from the View Reports window and click

OK.

IC {Users/swaaths/ reports

Dirver Output Report Madel

01/18/17 15:36:28

Owverday options
M Autofit plots

V¥ Auto color plots

3. A series of report templates are displayed in the Plot browser. You can select the

required report template to view in detail.

Driver Qutputs
. Stearing angle . Throttle, Brake and clutch
1] — 'ﬁll:rrm|.l'\|||_|h| T ——— Thrattin
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80 05
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20 0z
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=0 1]
1] 1 2 4 & L] r B 2 10 1] 1 3 4 § -] & T & a 10
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Gear Distance Travalled
11 e L]
rors [ - [ ptmee
105 £ Joom
EHN00
§1oes 0000
E 1 5000
& 09rs m
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08 5000
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