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MV-8050: Using the Leaf Spring Builder

Introduction 

The purpose of this tutorial is to introduce you to the Leaf Spring Builder utility.  In 

this tutorial, you will learn how to: 

• Access the Leaf Spring Builder utility in MotionView

• Populate a leaf spring model with data and save the data in an .lpf file

• Generate a MotionView file (.mdl) of the leaf spring

• Open the model in MotionView

• Create a test of the model and exercise the test using the utility

The Leaf Spring Builder is a utility designed to work with MotionView and the vehicle 

modeling libraries included with MotionView. Spring geometry, bushing rates and a 

number of other physical constants are required as input to the model. Reasonable 

defaults for data are included for many fields, which will make the model run. Accurate 

data should be substituted as it becomes available. The output of the utility is a beam 

and mass model of a leaf spring, in either a MotionView system definition file or a 

complete MotionView model.  

To learn more about the Leaf Spring Builder, see the Leaf Spring Modeling topic. 

Required Files 

Copy the files listed in the table below, located in the mbd_modeling\leafspring
\leaf_profiles folder, to the <working directory>.

File Name File 

Comma Separated Values files Leaf_1.csv 

Leaf_2.csv 

Leaf_3.csv 

Leaf_4.csv 

These .csv files contain coordinate pairs that represent the geometry of the centerline of 

the leaf. The leaf in this tutorial was created by measuring geometry from a light truck 

rear suspension. The rear suspension in this example has a GAWR of 3950 lbs. 

Step 1: Accessing the Leaf Spring Builder. 

To build a leaf spring model, you must first load the MBD-Vehicle Dynamics Tools 

preference file in MotionView. Once loaded, HyperWorks remembers and automatically 

loads the MBD-Vehicle Dynamics Tools preference file each time you start 

HyperWorks. To load the MBD-Vehicle Dynamics Tools preference file follow the steps 

below. 
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Launching MotionView 

1. Start a new MotionView session. 

The MotionView window is displayed. 

 

Loading the Vehicle Dynamics Tools Preference File 

2. Click File > Load > Preference File from the MotionView Menu bar. 

 

The Preferences dialog is displayed. 
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3. From the Preferences dialog, select MBD-Vehicle Dynamics Tools and click 

Load. 

 

Displaying the Leaf Spring Builder 

4. Click Vehicle Tools > Leaf Spring Builder. 

 

The Leaf Spring Dialog window opens. 
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Step 2: Building a Leaf Spring Model. 

Using the Leaf Spring Builder you can define the properties of a leaf spring model, by 

entering the data about the number of leaves, the leaf shapes, cross-sections, material 

properties, and contact properties, the shackle length if your spring employs a shackle, 

the nominal axle load and other information to create a MDL system definition. The 

system definition can be imported into a suspension or full vehicle model. You can also 

test the leaf spring by applying a load and plotting the load versus deflection in the Leaf 

Spring Builder. The Leaf Spring Builder user interface has four parts as shown in the 

following image: 

 

• Browser: Used for navigating and selecting leaf spring components.  

• Property Editor: Used for entering and modifying data. 

• Help Section: Used for describing the data you enter.  

• Visualization Canvas: Used for viewing leaf shapes. When you select data in 

the browser the leaf spring builder displays the corresponding editor, visualization 

canvas and help section. 
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The following steps show you the process involved in creating a leaf spring model using 

the components of the Leaf Spring Builder. 

General 

1. Click on the General option in the Leaf Spring Components browser section. 

 

The entire leaf model is displayed in the Help section. 

Primary Systems Selection 

2. Select the Linear and Pre-Assembly options from the Interpolation Scheme and 

Data Shape Condition drop-down menus.  
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3. Default units are set in the Units tab. 

 

Leaves: Leaves components allow you to add leaves to the leaf spring. 

4. Right-click on the Leaves component and click Add a Leaf, to add leaves. 

 

A Leaf 2 component is added to the leaves component. In a similar manner, add 

two additional leaves (for a total four). 
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Leaf 1 

5. Click on the Leaf 1 component and see where the required data can be entered 

under Leaf Data. 

 

6. Browse and locate the required .csv file, Leaf_1.csv for the Shape Input field. 

OR 

− You can specify the required values for the X coordinate, Z coordinate and width 

and thickness variation manually for the leaf profile. 

Note If the leaf is a constant thickness (and/or width), you need to specify the 

values only in the first row. The same value will be used along the entire 

length of the leaf. 

 

The Leaf 1 graphics are displayed in the Canvas section.  
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7. Click on the Details tab and select the Master option from the Type drop-down 

menu.  Enter the Leaf 1 data for the Details tab as shown in the following image.  

 

The Leaf 1 graphics in the Canvas section are changed accordingly. 

Leaf 2 

8. Click on the Leaf 2 component and enter the required data under Leaf Data in the 

Shape tab. 
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9. Browse and locate the required .csv file, Leaf_2.csv, for the Shape Input field.  

Enter the Width and Thickness as shown in the image below. 

 

The Leaf 2 graphics are displayed in the Canvas section. 
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10. Click on the Details tab and select the Graduated option from the Type drop-down 

menu.  Enter the Leaf 2 values for the Details tab as shown in the following image. 

 

 

11. Click on the Contacts tab and enter the value 12 in the Total number of Contact 

points field and hit Enter. 

The Contacts table for Leaf 2 is generated based upon the values entered.  
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12. Enter the following data into the Contacts table. 

S. No Direction Distance Contact Type 

1 Front 95 METAL_METAL 

2 Front 155 METAL_METAL 

3 Front 234 METAL_METAL 

4 Front 311 METAL_METAL 

5 Front 385 METAL_METAL 

6 Front 457 METAL_METAL 

7 Rear 105 METAL_METAL 

8 Rear 155 METAL_METAL 

9 Rear 234 METAL_METAL 

10 Rear 311 METAL_METAL 

11 Rear 385 METAL_METAL 

12 Rear 457 METAL_METAL 
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13. The entered contact points are plotted on Leaf 2 as shown in the following image in 

the Canvas section. 

 

14. For this example, leave the Tip Liners (Front and Rear) set to Off in the Tip 

Contacts tab. 
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Leaf 3 

15. Browse and locate the required .csv file, Leaf_3.csv, for the Shape Input field. 

 

The Leaf 3 graphics are displayed in the Canvas section. 

16. Click on the Details tab and select the Graduated option from the Type drop-down 

menu.  Enter the Leaf 3 values for the Details tab as shown in the following image. 

 

17. Click on the Contacts tab and enter the value 10 in the Total number of Contact 

points field and hit Enter. 
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18. Enter the following data into the Contacts table. 

S. No Direction Distance Contact Type 

1 Front 95 METAL_METAL 

2 Front 155 METAL_METAL 

3 Front 234 METAL_METAL 

4 Front 311 METAL_METAL 

5 Front 385 METAL_METAL 

6 Rear 105 METAL_METAL 

7 Rear 155 METAL_METAL 

8 Rear 234 METAL_METAL 

9 Rear 311 METAL_METAL 

10 Rear 385 METAL_METAL 
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19. The entered contact points are plotted on Leaf 3 as shown in the following image in 

the Canvas section. 

 

Leaf 4 

20. Browse and locate the required .csv file, Leaf_4.csv, for the Shape Input field. 

 

The Leaf 4 graphics are displayed in the Canvas section. 

21. Click on the Details tab and select the Graduated option from the Type drop-down 

menu.  Enter the Leaf 4 values for the Details tab as shown in the following image. 
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22. Click on the Contacts tab and enter the value 8 in the Total number of Contact 

points field and hit Enter. 

23. Enter the following data into the Contacts table. 

S. No Direction Distance Contact Type 

1 Front 95 METAL_METAL 

2 Front 155 METAL_METAL 

3 Front 234 METAL_METAL 

4 Front 311 METAL_METAL 

5 Rear 105 METAL_METAL 

6 Rear 155 METAL_METAL 

7 Rear 234 METAL_METAL 

8 Rear 311 METAL_METAL 
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24. The entered contact points are plotted on Leaf 4 as shown in the following image in 

the Canvas section. 

 

Leaf Ends: Leaf ends parameters provide the details about the eye hook types at front 

and at the rear ends. Three spring eye types are supported. 
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25. Click on the Front_leaf_end option and enter the following data in the Leaf Ends 

section. 

− Select Spring Eye from the Leaf End Type drop-down menu. 

 

 

26. Click on the Rear_leaf_end option and enter the following data in the Leaf Ends 

section. 

 

Clip: Clip parameter is used to define the Clip properties. The number of clips added in 

the clips parameter are reflected in the Clip Details.  
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27. Click on the Clips component and enter the following data in the Clip Properties 

section. 

 

28. Click on the Axle component and enter the following data in the Axle Properties 

section. 

 

Materials 

29. Click on the Materials component and enter the following data in the Material 

Properties section. 
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Bushings 

30. Click on the Bushings component and use the default values under Bushing 

Properties. 

 

Contacts 

31. Click on the Contacts component (by default there is only one contact 

METAL_METAL). Right-click on the Contacts component and add one more contact 

named METAL_PLASTIC. 

Note Right-click to rename the contact after you have added it. 

32. Click on the METAL_METAL contact and enter the following data in the Contact 

Properties section. 
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33. Click on the METAL_PLASTIC contact and enter the following data in the Contact 

Properties section. 

 

34. Now for this example, go back to the Clips component and click on the Clip_1 

option and update the Contact Property to the METAL_PLASTIC contact. 
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Shackle 

35. Click on the Shackle component and enter the following data in the Shackle 

Properties section.  

 

Clip Details 

36. Click on the ClipDetails option and enter 1 in the Total number of Clips field, with 

respect to the number of clips added in the Clips component.  

37. Enter the following data for the Clip 1 component. 
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Step 3: Importing the Leaf Spring Model into MotionView. 

The Leaf Spring Builder saves the data in an .lpf file. The file can be saved and loaded 

in the Leaf Spring Builder interface. The file is readable and is in TiemOrbit format. To 

make model changes, edit the spring data in the interface and build a new leaf spring 

system definition. 

1. Click on the Build option and browse and locate the required path for the <working 

directory>.  Enter test_leaf_1, as the file name in the Output File Label field 

and view the choices available for building the leaf spring model.  

2. Select the Assemble leaves and apply preload radio button and the Write 

Property File check box and click on the Build button. 

 

3. The Leaf Builder Message window opens. The message window shows the model 

checks that are performed before the test job is submitted to the MotionSolve. 

4. Click OK to exit the window. 
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5. MotionSolve is invoked in the background and it displays several windows as it runs, 

in order to generate the leaf spring MDL system definition file. 

 

6. Once the MotionSolve process is done, close the Leaf Spring Builder dialog. 

7. The Leaf Builder Message window is displayed. 

 

8. Click the OK button in the Leaf Builder Message dialog. 

9. From the Project browser, click on the Model as shown in the following image. 
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10. Click on the Import/Export tab in the panel area. 

 

11. Use the Select file browser and locate the generated .mdl file from the <working 

directory> and click Import. 

 

12. The Import Definition window is displayed.  Use the default options in the window 

and click OK. 
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13. Leaf Spring system is shown in the Project browser. Click on it and resolve the 

attachments.  

 

 

14. The Leaf Spring is displayed in the MotionView graphics window. 
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Step 4: Testing the Leaf Spring Model. 

Testing can be performed with either force or motion applied at the axle center, and can 

be run in quasi-static or transient analysis simulations. Quasi-static analysis is used as 

an example in the following. 

1. Return to the Leaf Spring Builder and click on the Test component in the browser. 
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2. Browse and locate the required Testing Directory and enter the following data:  

select Force as the Test Rig Type and the Quasi-static analysis as the 

Simulation Type (as shown in the following Test section).  Click on the Run Test 

Rig button. 

 

3. The Leaf Builder Message window opens. The message window shows the model 

checks that are performed before the test job is submitted to MotionSolve. Click OK 

to exit the window. 

 

  

Proprietary Information of Altair Engineering 

 

Altair MotionView 2019 Tutorials p.28



 
   

4. MotionSolve is invoked in the background and displays several windows as it runs. 

 

5. Once the run process is completed, the following F-D Curve is generated in the Leaf 

Builder. 
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