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MV-100: Introduction to the MotionView Environment 
 

This tutorial contains an introduction to the MotionView graphical user interface. 

Invoking MotionView: 

• In Windows - go through the Start Menu (Start Menu > Programs > Altair 

HyperWorks installation > MotionView). 

OR 

• In Linux - invoke ~hw_install/altair/scripts/mview in an "open terminal" 

(where ~hw_install is the location where HyperWorks is installed).  

The MotionView interface: 

MotionView is one of the clients that reside under the HyperWorks Desktop (HWD) 

framework.  The framework provides a common layout for all clients.  Other clients that 

are available under this framework are:  Hypermesh, HyperView, HyperGraph 2D, 

HyperGraph 3D, MediaView, TextView, and TableView.  The client is selected, or 

changed, using the Client selector drop-down menu: 
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The image below shows the HWD graphical user interface with MotionView activated as 

the client: 

 

The HWD graphical user interface can be broadly categorized into six segments: 

 Main Menu 

The Main menu bar includes all functionalities that are available through the various toolbars. 

Additionally, the Main menu contains other useful utilities like FlexPrep, Import CAD/FEM, Macros, 

etc. 

 

Note - The Main menu varies between the different clients of HyperWorks Desktop. 

The following table summarizes the functionalities available in the Main menu of MotionView: 

Main Menu Item Functionality Alternatives 

File Provides options to 

manage files (Creating new 

models, Opening and 

Saving models/Sessions, 

Importing and Exporting a 

Solver Deck, etc.). 

The same options are available 

through HWD Standard Toolbar also. 

Edit Provides options to 

manage the pages and 

windows of a session (Cut, 

Copy, Paste, and Overlay 

of the page and window). 

Same options are available through 

Page Edit Toolbar also.  
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View Allows you to manage the 

display of the graphical 

user interface (the display 

of Browsers, Command 

Window, Panel Area, Tab 

Area, Toolbars, etc.). 

 

Solver Mode Allows you to switch 

between solvers modes 

(MotionSolve, ADAMS, and 

ABAQUS). 

 

Model Allows you to access the 

following:  

• Assembly Wizard  

• Attachment Wizard 

• Set Wizard Paths 

• Implicit Graphics 

• Data Summary 

• Topology Summary 

 

Analysis Allows you to access the 

following: 

• Task Wizard 

• View Reports 

 

Tools Provides you with access to 

various tools and special 

utilities:  

• Check Model  

• Freeze Output Ids 

• Import CAD or FE using 

HyperMesh 

• Model Identification Tool 

• CG/Inertia Summary 

• Custom Wizards 

• Reports 

• MS UserSub Build Tool 

• Templex Functions 

• Options 

Check Model – Available in Run 

panel. 
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FlexTools Provides you with access to 

various utilities:  

• Flex Prep – Used for 

generation and 

translation of flexbody 

files. 

• Flex File Gen - Generates 

an animation file for 

ADAMS flexbody results. 

• Fatigue Prep – Helpful in 

the translation of MBD 

result files to other 

formats useful in fatigue 

analysis. 

• Load Export – Allows you 

to export loads from an 

MBD analysis. 

Macros Provides you with access to 

macros that are useful for 

modeling and model 

debugging. 

 

Applications Allows you to invoke other 

HyperWorks applications 

from the MotionView 

graphical user interface. 

 

Help Provides you with access to 

the online help. 

 

 

 HWD Standard Toolbars 

Toolbars provide quick access to commonly used features.  HyperWorks Desktop toolbars are 

static and will not change, regardless of which application is active.  Some of the toolbars become 

inactive when different clients are selected.  In the table below, all of the HWD toolbars are 

introduced. Please be sure to note the toolbars that are not applicable to the MotionView client. 

Toolbar Purpose Image 

Client 

Selector 

Selecting the HWD client 

from the drop-down list.  

Standard Options for file 

management (Creating, 

Editing, Saving, 

Importing, and Exporting 

of files etc.).  
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Page 

Controls 

Options to:  

• Create and Delete 

pages and windows. 

• Expand, Swap, and 

Synchronize selected 

windows. 

Note - To navigate 

through different pages of 

a session, use the 

Previous Page  or 

Next Page  buttons 

(located at the upper right 

corner of the window, 

below the menu bar area 

and above the graphics 

area).  See the Page 

Display and Navigation 

Area topic for additional 

information. 

 

Page Edit Options to manage pages 

and windows of a session 

(Cut, Copy, Paste, and 

Overlay of a page and 

window). 

 

Animatio

n Toolbar 

Provides controls for the 

animation of results. 

 

Note - Available in HyperView and HyperGraph only. 

Standard 

Views   

Options to view model in 

different orthogonal 

views. 
 

3D View 

Controls 

Options to control the 3D 

view of the model 

(Rotate, Pan, Zoom, etc.). 
 

2D View 

Controls 

Options to control the 2D 

view of plots (Pan, Zoom, 

etc.). 
 

Note - Available in HyperGraph only. 
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Reports Options to 

Create/Open/Define 

Report Templates. 
 

Scripting Options to 

Create/Open/Debug/Run 

Tcl and HyperMath 

scripts.  

Note - Not available in MotionView. 

Image 

Capture 

Capture Image/Video of 

the active page. 

 

Note - Please refer to the Hyperworks Desktop User’s Guide > Graphical User Interface > Toolbars topic 

for a detailed explanation of each toolbar listed above. 

 Client Specific Toolbars 

Client specific toolbars provide access to options required for pre- or post-processing of FEA/MBD 

models. MotionView has a set of toolbars for building an MBD model. Each MotionView toolbar group 

provides access to entities with similar characteristics.  For example, all entity such as Joints and 

Motions are grouped in the Constraint toolbar.  The table below shows MotionView toolbars with a 

brief explanation of their usage. 

Toolbar Purpose Image 

General Actions Options to render graphics, 

provide access to the Run panel 

(change solver settings and 

submit jobs to the solver), and 

the Entity Selector.  

Depressing the Entity Selector 

icon  indicates the graphic 

screen is in entity selection mode. 

If no other entity icons are 

depressed, the selection is not 

filtered to a particular entity (any 

entity that has a graphical 

representation on the screen can 

be selected). 

 

Container Entity Select/Add container entities like 

Assemblies, Systems, and 

Analyses. 
 

Reference 

Entity 

Select/Add entities like Points, 

Bodies, Vectors, Markers, etc. 
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Constraint Select/Add constraint entities like 

Joints, Motions, Couplers, etc. 

 

Force Entity Select/Add force entities like 

multi-axial Forces, Spring 

Dampers, Bushings, Beams, 

Contacts, etc.  

Control Entity Select/Add entities like Solver 

Variables, Solver Arrays, SISO 

Controller, Differentials, and 

Sensors which are useful in 

defining controlled simulations. 

 

General MDL 

Entity 

Select/Add general MDL entities 

like Datasets, Templates, Forms 

and Output Requests. 
 

Model Check Checks the model. 

 

Point Macros Access point creation macros 

useful in adding points with 

respect to a reference frame, 

along a vector, along a curve and 

at an arc center. 

 

Other Macros Other macros useful in modeling 

and debugging:  calculate angles, 

find connected entities, create 

markers for a deformable surface 

and contact properties editor. 

 

A left click on an entity icon sets the filter to select that particular entity from the graphic 

screen, while a right-click on a toolbar icon enables adding that entity to the model (see the 

Points example below): 

 

• Left mouse click - Filters selection to a Point entity. 

• Right mouse click - Opens the Add Point dialog to add a Point. 

Note - Mouse over the icons to display a tip about the type of entity that can be selected or added. 
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 Browsers 

Tab Area 

The tab area docks different browsers, the purpose of the browsers is to navigate through the 

hierarchy tree and execute some operations specific to the selected items. Available for all clients is 

the Session Browser, which allows you to browse to the different pages or windows in an HWD 

session, as well as execute certain page and window operations.  In addition to the Session 

Browser, client specific browsers are shown based on the active window.  For example, when the 

MotionView is active client in the working window, the MotionView Project Browser is shown; 

similarly, when HyperView is active, the Results Browser is shown. Specifically, the MotionView 

Project Browser helps you browse/select different modeling entities, in addition to executing 

certain modeling operations. Other browsers include the Organize Browser (used for data 

management and collaboration) and the Process Manager (used for process automation).  Please 

refer to the client specific online help regarding the available browsers.  Finally, browsers can be 

placed on either side of the graphic window (Left/Right/Both) through the Menu bar by using the 

View > Tab Area menu options. 

Mouse Options in the Project Browser 

A left mouse click on an entity in the Project Browser selects that entity and the details of entity 

are displayed in the Panel area (see the example below): 

 

 

A right click on an object brings up a context menu with options that are relevant to the selected 

object.  

For example, a right click on a Point entity brings up a context menu that provides options to either 

Deactivate, Rename, Add, Delete, or Cut the point entity along with options to filter entities. 
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Similarly, a right mouse click on the Model (the topmost folder in the browser hierarchy) displays 

up a context menu with options useful in model building. 

 

 Panel Area  

Below the client specific toolbar is the panel area where you can view and modify the various values 

and properties of a selected entity. Panels may have several tabs which organize the various 

properties and values of the entity type selected. For example, the Spring Damper panel has the 

connectivity information and properties displayed in three tabs (as shown below): 

Connectivity tab: Allows you to specify the type of spring, the bodies to attach, and the 

attachment points. 

 

Properties tab: Allows you to set the stiffness and damping properties of a spring. 
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Preload tab: Allows you to set a 'preload' on a spring by specifying a force value or spring free 

length. 

 

 Graphics Window  

Graphics window is the model visualization area where you can interactively work on the model.  

The following table illustrates the various mouse clicks available for model visualization: 

Operation Action 

Left click on an entity like a Point, 

Graphic, etc. (while the Entity Selector 

and an entity icon is depressed in the 

toolbar). 

Selection (the selected entity is highlighted by 

a white boarder around it). 

Hold the left mouse button and move 

over the model (while the Entity 

Selector and an entity icon is 

depressed in the toolbar). 

Displays the entity name on the mouse tooltip 

and selects the entity upon releasing mouse 

button.  

Right-click on a model entity. Displays a context menu with various options: 

Select, Cut, and Delete against each entity 

name. 

Ctrl + Left mouse button Rotates the model (observe the mouse 

tooltip).  

Ctrl + Left click   Picks the center of rotation. 

Ctrl + Right mouse button Translates/Pans the model. 

Ctrl + Middle mouse button Selects the window to fit.  

Ctrl + Middle click Fits the model to the window. 
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The controls for the mouse can be found under Tools > Options > Mouse: 

 

You can customize the mouse controls using this dialog. 

Note - The items under the Main Menu, Browser, and Client specific toolbars differ from client to 

client. 

Exercise: 

In this exercise you will learn to: 

• Open and Save a model in MotionView.  

• Add a Page and change the Page Layout in a Session.   

• Change between HWD clients. 

• Open and Save a HWD session. 

Prior to beginning this tutorial, please copy all of the files located in the 

mv_hv_hg\mbd_modeling folder to your <working directory>.  See Access the Model 

Files for additional information. 

Step 1: Opening a MotionView model file. 

1. Start MotionView: 

− In Windows - go through the Start Menu (Start Menu > Programs > Altair 

HyperWorks installation > MotionView). 

− In Linux - invoke ~hw_install/altair/scripts/mview in an "open terminal" 

(where ~hw_install is the location where HyperWorks is installed).  
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2. Click the Open Model icon, , on the Standard toolbar. 

OR 

− From the File menu select Open > Model. 

3. From the Open Model dialog, locate and select the model definition file 

SingleCylinderEngine_model.mdl, located in your working directory. 

 

Note MDL stands for “Model Definition Language”.  MDL is an ASCII 

programmable language for modeling in MotionView.  See the MotionView 

Reference Guide for details about the different MDL statements. 

4. Click Open. 

The single cylinder engine model displays in the graphics window (fit to the window). 
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5. Upon successful loading of a model into MotionView, the status bar will display the 

Ready message (in the lower left corner of the screen). The Project Browser lists 

all of the entities in the model. Click on the Expand /Collapse  button of each 

entity (Bodies, Points, Joints, Motions, etc.) to browse through the entities.  Use 

the mouse controls in the graphics area to rotate, pan, and zoom the model. 

6. Expand the Bodies folder in Project Browser by clicking on the  next to Bodies 

( ). 

7. Click on the CRANK_SHAFT body from the bodies listed to review its properties. 

 

Note Each entity will have a label and a unique variable name.  For example, the 

crank shaft body has a label of CRANK_SHAFT and a variable name of 

b_CRANKSHAFT. 

The corresponding entity panel (Bodies in this case) is displayed in the bottom of 

the window.   

8. From the Properties tab, observe the Mass and Inertia properties of the body. 
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9. Click on CM Coordinates tab to review the CM point of the body and its orientation.  

 

The Origin point defines the body CG location and the orientation is defined with 

respect to global reference frame using direction cosines DxDyDz.  

Step 2: Selecting and modifying a motion. 

In this step you will modify the crank shaft rotational velocity to 10rad/sec. 

1. Left click the Motion icon  on the Constraint toolbar to change the graphical 

selection to a motion entity.  Move the cursor in the graphics area with left mouse 

button pressed to identify the motion CrankShaft Rotation and release the mouse 

button to select it.  

 

OR 

− Browse to the Motions entity in Project Browser and click on  next to Motions 

and select CrankShaft Rotation.  

Note Implicit graphics are displayed for all applicable entities, allowing you to 

visualize their location and orientation.  See the MotionView User’s Guide 

for details about controlling the visualization of implicit graphics. 
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2. From the Motion panel, click on the Properties tab. 

3. Enter 10 in the Value field. 

 

Step 3: Saving a MotionView model. 

1. From the File menu, select Save As > Model. 

The Save As Model dialog is displayed.  

Note You can also click the Save Model icon, , on the Standard toolbar to 

the save the file in working directory with the existing name.  If the model 

is new, you will be prompted to input the name of the model. 

2. Browse to your working directory and specify the File name: as 

SingleCylinderEngine_model_10rad_per_sec.mdl. 

 

3. Click Save. 
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Step 4: Solving the model. 

1. Click the Run icon, , on the General Actions toolbar. 

The Run panel is displayed. 

2. Click the Run button to solve the model using MotionSolve. 

 

Upon clicking Run, MotionSolve is invoked and solves the model.  The HyperWorks 

Solver View window appears which shows the progress of the solution along with 

messages from the solver (Run log).  This log is also written to a file with the 

extension .log to the solver file base name. 

3. Once the job is completed, close the solver execution window.  

4. Clear the message log. 

Step 5: Adding pages to a session. 

In this section you will learn how to add a page, change to different HWD clients, change 

the page layout, and navigate between pages.  You will also load the result files to view 

the animation and the plot.  Even though there are both Animate and Plot buttons in 

the MotionView Run panel, clicking those buttons will result in the HyperView and 

HyperGraph clients opening automatically in different windows on the same page, 

however in this exercise you will manually do the same on a different page, in order to 

familiarize yourself with the concept of page and window within the HWD environment. 

1. Click on the Add Page icon  from Page Controls toolbar. 

A new page is added with MotionView as the client.  

Note Please note that the Add Page option adds a page with the current client 

(MotionView in this case). 

2. From the Select application drop-down menu, select HyperView to change the 

current window to HyperView. 
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3. From the Load Model panel, click on the Select file icon  next to Load model. 

 

The Load Model File dialog is displayed. 

4. Browse to your working directory and select the animation results file 

SingleCylinderEngine_model_10rad_per_sec.h3d.  

 

The Load results field is automatically populated with 

SingleCylinderEngine_model_10rad_per_sec.h3d. 

Note H3D is an Altair binary file for HyperView.  The H3D file contains both model 

and results data from a solver run. Please see the Appendix (below) for 

various use cases of H3D files in MotionView/MotionSolve. 
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5. Click Apply to load the results. 

 

6. From the Animation toolbar, click the Start/Pause Animation button  to 

animate the results. 

7. Rotate, pan, and zoom the model using the mouse controls for better visualization 

and understanding of the results. 

8. Click the Start/Pause Animation button  to stop the animation. 

9. Add a window to the current page to plot the results. 

10. From the Page Controls toolbar, click the arrow next to the Page Window Layout 

button  and select the two window layout  from the pop-up menu. 

 

11. Click in the graphics area of second window in order to make it the active window. 

12. Use the Select application drop-down menu to change the application from 

HyperView  to HyperGraph 2D . 

Note The Client selector displays the icon of the current client (HyperGraph in 

this case). 

13. Click the Build Plots icon, , on the Curves toolbar. 

  

Proprietary Information of Altair Engineering 

 

Altair MotionView 2019 Tutorials p.18



 
   

14. From the Build Plots panel, click the Open File icon, , next to Data file. 

 

The Open Data File dialog displays. 

15. Browse to your working directory and select the MotionSolve results file 

SingleCylinderEngine_model_10rad_per_sec.abf. 

 

Note ABF is the Altair Binary File for HyperGraph.  Other output files from 

MotionSolve (.mrf and .plt) can also be used for reading results into 

HyperGraph. 

16. Click Open. 

17. Plot the angular velocities of the crank shaft: 

− For X Type, select Time. 

− For Y Type, select Marker Velocity. 

− For Y Request, select REQ/70000002. 

− For Y Component, select Wx.  
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18. Click Apply and observe Wx = 10 rad/sec. 

 
Two Window Layout (with HyperView and HyperGraph 2D) 

19. From the Animation toolbar, click the Start/Pause Animation button  to 

animate the results. 

20. Click on Expand/Reduce Window icon,  to expand or reduce an active window. 

21. Observe the top right corner of the page which displays the current page (2 of 2). 

Click on Previous Page icon,  or Next page icon,  to navigate to page 1 

(the MotionView model). 

 
MotionView with Single Cylinder Engine Model 
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Step 6: Saving a session file. 

1. From the File menu, select Save As > Session. 

The Save Session As dialog is displayed. 

2. Browse to your working directory and specify the File name as mywork.mvw. 

 

Note A session file saves the complete HWD data (the page, window, client, and 

results information).  Please refer to the Appendix below for details 

regarding the different types of HyperWorks Desktop files. 

3. Click Save. 

Your work is saved as a session file. 
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Step 7: Opening a session file. 

1. From the File menu, select New > Session to start a new session.  

 

Click Yes to the message asking if you would like to discard all of the current 

session data and start new session. 

2. From the File menu, select Open > Session. 

The Open Session File dialog is displayed. 

3. Browse to your working directory and select the session file saved in previous step 

mywork.mvw. 

 

4. Click Open.  

5. Browse through the pages to look at the model, plots, and animation that you 

worked on during the exercise using the   icons. 
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 Appendix 

HyperWorks Desktop file types: 

The following table summarizes the different file types in HWD and the location where the file can 

be loaded and saved. 

File Type Extension Window Mode 

Session script .mvw Any 

Report template .tpl Any 

MDL .mdl MotionView 

Animation .gra, .res (Adams and Optistruct), 

h3d, .flx, .mrf 

HyperView 

Plot .req, .mrf, .abf, .plt, .res (ADAMS) HyperGraph 

Templex script, 

any text file 

.tpl, .txt TextView 

Options for loading and saving different file types 

H3D file use cases in MotionView/MotionSolve: 

H3D is an Altair format for storing model and result information.  In general, an H3D file is used for 

post-processing results in HyperView; however the H3D file has a few other use cases in 

MotionView/MotionSolve. 

Graphic H3D File This type of H3D contains Model information only. A graphical H3D 

file is an imported geometry into MotionView for visualization of a 

body. 

Flexbody H3D File This type of H3D contains Model and Flexible body information. 

Therefore, MotionView can use it as a graphic, as well as to represent 

a deformable body by accessing the modes, mass, and inertia 

information. HyperView can read it as both Model and Results, and 

also animate the mode shapes, modal displacements, stresses, etc. 

(if available). 

Results H3D File This type of H3D is written by MotionSolve. It contains Model and 

Results information. HyperView can read it as both Model and 

Results, and also animate the position, deformation, stresses, forces, 

etc. 

H3D contains different blocks of information based on the above needs: 

• Model Information – Nodes and Elements 

• Flexible Body Information – Modes, Interface Nodes, Mass/Inertia 

• Results – Position, Displacements, Stress, Strain, etc. 
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