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HWD-0060: Using PowerPoint Publishing 

In this tutorial you will learn how to: 

• Publish a HyperWorks Desktop session to PowerPoint

• Modify your session and synch your edits with an opened PowerPoint file.

• Update slides in PowerPoint and synch those edits with a HyperWorks Desktop
session.

The HyperWorks Desktop PowerPoint Publishing feature reduces the effort needed to 
generate and update Microsoft PowerPoint (PPT) presentations from HyperWorks 
Desktop (HWD) sessions.  This is achieved by establishing on Windows a live link 
connection between HyperWorks Desktop and PowerPoint, publishing to PowerPoint on 
Linux is also supported.  The synchronization can be triggered either from HyperWorks 
Desktop or PowerPoint using a PowerPoint add-in.  Changes made in the PowerPoint 
presentation are preserved when new runs are post-processed after updating your 
session; full support of report templates are provided.  The PowerPoint layout can be 
defined the first time you publish using PowerPoint master templates.  

Tools 
PowerPoint 2007 or newer must be installed on the same machine where you run 
HyperWorks Desktop if you publish on Windows using a live-link connection between 
PowerPoint and HyperWorks Desktop.  If you publish on Linux to the file system, you 
need also need PowerPoint 2007 or newer to open or update the presentations on 
Windows. 

To access PowerPoint Publishing, from the menu bar, select File > Publish > 
PowerPoint.  Or, from the Standard toolbar > PPT menu, select Publish to 
PowerPoint. 
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Exercise: Publishing a HyperWorks Desktop 
session to PowerPoint. 

Step 1:  Open the Publishing_Demo_Session file. 
1. From File menu, select New > Session to clear all contents in session. 
2. From the File menu, select Open > Session. 
3. Select the file ../tutorials/mv_hv_hg/animation/Publishing_Demo_Session.mvw. 
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Step 2: Select a master PPT template to define the export options. 
Before exporting your session to PowerPoint, you can optimize the layout using the PPT 
Export Options.  A master template helps you adapt the image size and position the 
images dependent on the master layout.  For more information or to create your own 
company's PowerPoint master template, please see Step 9: Create a PowerPoint 
master template. 

1. From the Preferences > Export Settings menu, select PPT Options.   
Or, from the Publishing PowerPoint dialog, click PPT Options.   
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The PPT Export Options dialog is displayed. 
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2. From the PowerPoint master field, click the file browser icon, , to load the 
following master template file: 
../tutorials/mv_hv_hg/animation/Publishing_Demo_Master.potx. 
Please make sure that Use title attributes from Master PPT is selected when you 
insert the path using Copy and Paste.  Using the file browser will automatically 
change the settings when you confirm your selection and click Open. 

3. Under Visual Position, enter the values outlined in red in the image below and click 
OK. 
These values set the graphics area to a defined position in the PowerPoint slide.  The 
values are a percentage of the whole page width and height. 
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Step 3: Publish the session to PowerPoint. 

1. From the Standard toolbar, select the PPT icon, , or select File > Publish > 
PowerPoint from the menu bar. 
The Publishing PowerPoint dialog is displayed. 

 

Note If this is the first time you are using PowerPoint publishing, click Yes to install 
the Altair Add-in to PowerPoint.  Without installing the PowerPoint Add-in, 
PowerPoint Publishing will not work on Windows. 

 

2. From the Publishing PowerPoint dialog, select New PPT to publish to a new 
PowerPoint presentation. 

  

Proprietary Information of Altair Engineering 

 

Altair HyperWorks Desktop 2019 Tutorials p.6



 
   

3. Click Publish. 
A PowerPoint presentation, Presentation 1, is created from your HyperWorks 
Desktop session. 

 

Note If you click Publish, all selected pages and windows will always be added as 
new slides to your PowerPoint presentation. 

Click Synchronize when Publishing to add new pages to PowerPoint and 
synchronizes images, animations, and headers in the previously created 
PowerPoint pages. This option is explained in Step 4. 

Step 4: Modify your session content and synchronize and update 
an existing PowerPoint presentation. 
1. Return to your HyperWorks Desktop session. 
2. Select the animation window in the upper left corner of the graphics area to modify 

the image.  Use the Rotate button, , to rotate the image 90 degrees.  Press 
Zoom, , once to zoom in on the image.  

3. Select the plot window on the right side of the graphics area to activate it. 
4. Select the Plot Browser tab. 
5. Expand the p1:Crash comparison folder and select c1: LOWER TORSO. 
6. From the Properties table at the bottom of the Plot Browser, select the Line Color 

color palette and change the curve color from red to black. 
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7. Click Line Style and select the last option from line style menu, as shown in the 
image below. 

 

8. Select c2: UPPER TORSO.   
9. From the Properties table, change the line color from green to orange.  Change 

the Line Style to a solid line. 
10. For the c3:Head curve, use the Properties table to change the curve's color to 

purple and select the second from last line style from the line style menu. 
You can also use the Plot Browser to change each curve's note color to match the curve 
colors you selected. 

11. From the Plot Browser, select the Note icon, , at the top of the browser. 
12. Select Note 1.  From the Properties table, click the Border Color color palette and 

change the color from red to black. 
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13. Repeat step 12 for Note 2, changing the border color from green to orange.  
Change the border color for Note 3 from blue to purple. 
The curve color and its corresponding note should match. 
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14. From the Standard toolbar, select the PPT icon, , or select File > Publish > 
PowerPoint from the menu bar to display the Publishing PowerPoint dialog. 
Notice that since you have already published to PowerPoint once, the Opened PPT 
option is selected.  Presentation 1 refers to the PowerPoint slides that were created 
in Step 3. 

 

15. Click Synchronize to only modify the images in the opened PowerPoint presentation 
that were edited in the HyperWorks Desktop session. 
Notice that the PowerPoint slide shows the changes made to the animation and plot 
windows.  
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Step 5: Use the Altair add-in tools to update the PowerPoint 
presentation with changes made in HyperWorks Desktop: 
From PowerPoint, you can update your presentation with the changes you made to your 

HyperWorks Desktop session. 

1. From the HyperWorks Desktop session, select the HyperGraph plot Res. 
acceleration on the right side of the graphics window.  Click Zoom, , three times 
to zoom in on the plot. 

2. Select the animation window in the top left corner of the graphics area.  Click  to 
fit the image in the window.  Click  to rotate the image until it is right-side up. 

3. Return to the PowerPoint Presentation1. 
4. From PowerPoint, click the Altair tab. 

The following toolbar is displayed. 

 

5. Click Sync Live to update PowerPoint with the modifications made to in HyperWorks 
Desktop. 
The changes from your HyperWorks Desktop session are synchronized to the 
PowerPoint file. 
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Step 6: Select only certain pages or windows to publish. 
Sometimes, you may not want to publish ALL the pages from a session to PowerPoint.  
You can use both the Session Browser and Quick Publish to select certain pages and 
windows only. 

Method 1 - Using the Session Browser 

1. Return to your HyperWorks Desktop session. 
2. From the Session Browser > Crash comparison > Publish column, select the 

only the HyperView, HyperGraph, and MediaView windows on the Crash comparison 
page.  Deselect the Linear Acceleration page. 

3. Click the PPT icon, .  From the Publishing PowerPoint dialog, select New PPT 
and click Publish. 
Notice that only the windows on the Crash comparison page were published. 
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Method 2 - Using Quick Publish 

4. Select windows 2 and 3 on page 2 (Linear Acceleration page), as shown in the image 
below.  Right-click to display the Session Browser context-sensitive menu and select 
Quick Publish. 
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Note: Even if a page or window is not selected for publishing under the Publish 
column, it will still be published because Quick Publish overrules the Browser 
settings. 

 The pages and/or windows you selected are attached as new pages to your 
opened PowerPoint project, independent from the settings the in the Session 
Browser for publishing selected pages and windows. 

 

Step 7: Create HyperGraph Note Tags and view them in 
PowerPoint. 
1. Return to the HyperWorks Desktop session. 
2. From the Session Browser, make sure that the Publish column for the Session is 

selected.   
All windows and pages in the session should have a check mark under the Publish 
column. 

3. From the graphics area, activate the Res acceleration plot window and select the 
Plot Browser tab. 

4. Select the Notes icon, , from the toolbar at the top of the Plot Browser. 

 

The plot information is filtered to show only the plot notes for each window. 

5. From the Plot Browser, expand the p1: Crash comparison > w2: XY Plot > Note 
folder to display Notes 1, 2, and 3. 
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6. Select Note 1-3, right-click to display the context-sensitive menu, and select Create 
Tag. 

 

The Tag Table dialog is displayed: 

 

7. Click Close. 

8. From the Standard Toolbar, click .   
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9. From the Publishing PowerPoint dialog, select New PPT and click Publish. 
A new PowerPoint presentation is created which displays Notes 1, 2, and 3. 

 
10. While holding the SHIFT key, select each note, right-click and select Copy.   
11. Select slide 3 and click Paste to paste the notes.  Select each plot window image on 

slide 3 to re-size them and reposition the notes as shown below. 
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12. From the Altair toolbar, select View Names to view the tags names on the 
PowerPoint slides. 

 

13. From the Altair toolbar, click View Values to view the slides in their original state. 
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Step 8: Change the published file format using the Tag Table and 
Publish Settings dialog. 
1. Return to the HyperWorks Desktop session. 
2. From the Session Browser, under Crash comparison, select HyperView. 
3. Right-click on HyperView and select Tag Table from the context-sensitive menu. 
4. Click in the Format column for line 2, Animation_1_1, and change the format from 

PNG to GIF.  Click Close. 

 

5. Under Crash comparison, select Media View. 
6. Right-click and select Publish Settings from the context-sensitive menu. 
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7. From the Publish Settings dialog, use the Format drop-down menu to change the 
format to GIF and click OK. 

 

8. From the Preferences menu, select Export Settings > GIF. 
9. Set the Time Delay for the animated gif to 0.1 seconds and click OK. 
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10. Select Tools > Synchronize Animation.  Ensure the the Master option is 
activated, as shown in the image below.  Click Apply to close the dialog. 

 

Note: When you export to an animated GIF or AVI and you have both animation and 
plotting on the same page, ensure that in the Synchronize Window 
Animation dialog that the animation window with the least time steps on the 
page is checked as the master. If it is not, a screen shot of each time step will 
be made to create the video, which can result in poor performance when a 
time history curve has 2000 time steps and the animation has only 40 time 
steps, for example. 

11. From the Standard toolbar, select the PPT icon, .  Select New PPT and click 
Publish. 

12. From PowerPoint, click F5 to view the presentation in presentation mode.  You will 
see the animation take place. 

13. Click ESC to exit out of presentation mode. 
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Step 9: Uninstall the Altair PowerPoint add-in from PowerPoint. 
Note:This step is optional and only required if you want to remove the PowerPoint    

add-in manually (to clean up your add-in's, for example, or you get an error 
message when starting PowerPoint). 

1. From PowerPoint, click the Office button,  , and select PowerPoint Options.  

Note In Windows 8/PowerPoint 2013, you must use File > Options to view the 
PowerPoint Options dialog. 

2. From the PowerPoint Options dialog, click Add-Ins on the left side of the dialog. 

3. From the Manage drop-down menu, select PowerPoint Add-ins and click Go. 

The Add-Ins dialog is displayed. 

4. From the Add-Ins dialog, select the Altair PowerPointAddin_V# from the list and 
click Remove. 
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Step 10: Create a PowerPoint master template. 
1. Open Microsoft PowerPoint 2007 or newer and create a new, blank presentation. 
2. From the View menu, select Slide Master. 
3. You only need a select number of slide master styles to create a master template for 

PowerPoint publishing.  They are the Slide Master, the Title Slide Layout, and the 
Title Only Layout, as shown below. 

 

Select the rest of the slide template options and click Delete. 

4. Select the Title Slide Layout slide.  From the Insert menu, click Picture to insert 
the following image: ../tutorials/mv_hv_hg/animation/logo.png. 
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5. Perform the following edits: 
• Change the font size of the upper title text box to 28. 
• Change the font size of the lower title text box to 20. 
• Right justify the text. 
• Reposition the text boxes to the right side of the slide. 
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6. Select the Slide Master slide.  Perform the following edits: 
• Delete the text box below the title. 
• Change the title font color to red, bold and left justify the text. 
• Change the font size to 24. 

The edits are also displayed on the two other slides. 

 

7. Return to the Title Slide Layout slide and change the title font to black. 
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8. The template should look similar to this: 

 

9. Save the presentation template. 
10. From the View menu, select Normal.   

The presentation template view should look similar to this: 

 

11. Click the Office button and select Save As to save the presentation template as a 
PowerPoint template (*.potx file). 

12. You can now use this master template when publishing your HyperWorks Desktop 
session to PowerPoint, as shown in Step 2 above. 
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