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HM-4620: Rigid Wall, Model Data, Constraints, Cross Section, and Output using DYNA 

In this tutorial, you will learn how to: 

• Create *PART_INERTIA for the vehicle mass component to partially take into account 

the inertia properties and mass of the missing parts.  

• Create velocity on all nodes except barrier nodes with *DEFINE_BOX and 

*INITIAL_VELOCITY. 

• Make the closest row of nodes of the crash boxes a part of the vehicle mass rigid 

body with *CONSTRAINED_EXTRA_NODES.  

• Create a contact between the crash boxes, the bumper, and the barrier with 

*CONTACT_AUTOMATIC_GENERAL.  

• Specify the output of resultant forces for a plane on the left interior and exterior 

crash boxes with *DATABASE_CROSS_SECTION_PLANE. 

• Create a stationary rigid wall to constrain further movement of the barrier after 

impact with *RIGIDWALL_PLANAR_FINITE. 

• Specify some nodes to be output to the ASCII NODOUT file with 

*DATABASE_HISTORY_NODE. 

 

*PART_INERTIA 
 

 

The INERTIA option enables inertial properties and initial conditions to be defined rather 

than calculated from the finite element mesh. This applies to rigid bodies only.  

When importing a LS-DYNA model into HyperMesh, the *PART_INERTIA IRCS parameter 
value is changed from 0 to 1. The inertia components are changed from global to local axis. 

This allows inertia components to be automatically updated when *PART_INERTIA elements 
are translated or rotated. When selecting *PART_INERTIA elements to translate or rotate, 

select elements by comp. This selection method ensures the inertia properties are 

automatically updated.  

 

*CONSTRAINED_EXTRA_NODES 
 

 

This card defines extra nodes to be part of a rigid body. In HyperMesh, it is created from the 
Solver browser or Model browser, Create Cards menu (access from the Tools pull-down 

menu), or the Quick Access tool (Ctrl + F) when a keyword is entered. 

 

*DATABASE_CROSS_SECTION_(Option) 
 

 

*DATABASE_CROSS_SECTION_(Option) defines a cross section for resultant forces written 

to the ASCII SECFORC file. The options are PLANE and SET.  

For the PLANE option, a cutting plane must be defined. For best results, the plane should 

cleanly pass through the middle of the elements, distributing them equally on either side.  

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.1



The SET option requires the equivalent of the automatically generated input via the cutting 
plane to be identified manually and defined in sets. All nodes in the cross-section and their 

related elements contributing to the cross-sectional force resultants should be defined in 

sets. 

*DATABASE_CROSS_SECTION_SET and *DATABASE_CROSS_SECTION_PLANE are created 
from the Solver browser or Model browser, Create Cards menu (access from the Tools pull-

down menu), or the Quick Access tool (Ctrl + F) when a keyword is entered. 

 

*RIGIDWALL 
 

 

A *RIGIDWALL provides a method for treating contact between a rigid surface and nodal 

points of a deformable body.  

In HyperMesh, *RIGIDWALL keyword cards are created from the Solver browser or Model 

browser, Create Cards menu (access from the Tools pull-down menu), or the Quick Access 

tool (Ctrl + F) when a keyword is entered. 

 

Model Files 
 

 

This tutorial uses the bumper_start.key file, which can be found in 

<hm.zip>/interfaces/lsdyna/. Copy the file(s) from this directory to your working 

directory. 

 

Exercise: Set Up the Bumper Model for Impact Analysis 
 

 

In this exercise, you will define model data, loads, constraints, a cross section, a rigid wall, 
and output for an LS-DYNA analysis of a bumper in a 40% frontal offset crash. The bumper 

model is shown in the image below.  
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Step 1: Load the LS-DYNA user profile 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to LsDyna. 

Step 2: Import the LS-DYNA model bumper_start.key 

1. From the menu bar, click File > Import > Solver Deck. The Import - Solver Deck 

tab opens. 

2. In the File field, navigate to the file bumper_start.key. 

3. Click Import. 

Step 3: Define *PART_INERTIA for the vehicle mass component to 

partially take into account the inertia properties and mass of the 
missing parts 

1. In the Model browser, Component folder, click vehicle mass. The Entity Editor 

opens, and displays the component's card data. 

 

2. In the Entity Editor, edit the component's card data. 

a. Set Options to Inertia.  

b. For XC (X coordinate of center of mass), enter 700. 

c. For YC (Y coordinate of center of mass), enter 0.0. 

d. For ZC (Y coordinate of center of mass), enter 170.  
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e. For TM (translational mass), enter 800. 

f. For IXX (XX component of target inertia), enter 1.5E+07. 

g. For IXY (XY component of target inertia), enter -5.0E+03. 

h. For IXZ (XZ component of target inertia), enter -8.0E+06. 

i. For IYY (YY component of target inertia), enter 5.0E+07. 

j. For IYZ (YZ component of target inertia), enter -900. 

k. For IZZ (ZZ component of target inertia), enter 6.0E+07. 

l. For VTX (Initial translational velocity of rigid body in x direction), enter -10. 

Step 4: Create a *DEFINE_BOX that contains all nodes except barrier 

nodes 

1. Open the Solver browser by clicking View > Browsers > HyperMesh > Solver from 

the menu bar. 

2. In the Solver browser, right-click and select Create > *DEFINE > *DEFINE_BOX 

from the context menu. A new block opens in the Entity Editor. 

 

3. In the Entity Editor, define the block. 

a. For Name, enter box velocity. 

b. Optional. Click the Color icon, and select a color for the block. 

c. For Xmin Ymin Zmin, enter -530, -800, 0. 
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d. For Xmax Ymax Zmax, enter 200, 800, 300. 

 

Step 5: Create initial velocity on all nodes except barrier nodes 

A velocity boundary condition can also be created on a set of nodes from the Solver browser 
or Model browser, Create Cards menu (access from the Tools pull-down menu), or the Quick 

Access tool (Ctrl + F) when a keyword is entered. 

1. In the Solver browser, right-click and select Create > *INITIAL > 

*INITIAL_VELOCITY from the context menu. A new load collector opens in the Entity 

Editor. 
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2. In the Entity Editor, define the load collector. 

a. For Name, enter velocity. 

b. For VX (Initial velocity in the global X direction), enter –10. 

c. Click BOXID, and then click Block. 

 

d. In the Select Block dialog, select box velocity and then click OK.  

 

Step 6: View the closest nodes which are in the pre-defined node 
entity set (*SET_NODES_LIST) named Constrain Vehicle 

Method 1 

1. In the Solver browser or Model browser, right-click on Constrain Vehicle and select 

Review (press Q) from the context menu. The set's nodes highlight. 

 

2. Return all of the entities to their original display color by right-clicking on Constrain 

Vehicle and selecting Review (press Q) from the context menu.  
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Method 2 

1. From the menu bar, click Tools > Edit > Sets. 

2. In the Entity Sets panel, click review. 

3. Set the display RLs/hide RLs toggle to hide RLs.  

Note: This option filters all nodal rigid body sets from the list. 

 

4. Select the set, Constrain Vehicle. The set's nodes highlight. 

 

5. Close the panel by clicking return. 
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Step 7: Create *CONSTRAINED_EXTRA_NODES_SET 

1. In the Solver browser, right-click and select Create > *CONSTRAINED > 
*CONSTRAINED_EXTRA_NODES_SET from the context menu. A new constrained 

extra node opens in the Entity Editor. 

 

2. In the Entity Editor, define the constrained extra node. 

a. For Name, enter ExtraNodes. 

b. For PID, click Unspecified >> Component.  

 

c. In the Select Component dialog, select vehicle mass and then click OK.  
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Step 8: Define the nodes in the Constrain Vehicle set to be a part of 

the vehicle mass rigid body 

In this step, the Entity Editor should still be open for the ExtraNodes constrained extra 

node. 

1. For NSID, click Unspecified >> Set. 

2. In the Select Set dialog, select Constrain Vehicle and then click OK. 

Step 9: View the extra nodes that are a part of the vehicle mass rigid 
body 

1. In the Solver browser or Model browser, right-click on ExtraNodes and select 

Review (press Q) from the context menu. The extra nodes temporarily display red, and 

PID (vehicle mass) displays blue. All of the other entities temporarily display grey. 

 

2. Return all of the entities to their original display color by right-clicking on ExtraNodes 

and selecting Review (press Q) from the context menu. 

Step 10: Create an entity set, *SET_PART_LIST, for the vehicle mass 

component 

All other components not in this set will be included in the contact. 

1. In the Solver browser, right-click and select Create > *SET > *SET_PART > 

*SET_PART_LIST from the context menu. A new set opens in the Entity Editor. 

Tip: You can also create a *SET_PART_LIST from the Model browser, Create Cards 

menu (access from the Tools pull-down menu), or the Quick Access tool (Ctrl + 

F) when a keyword is entered. 
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2. In the Entity Editor, define the set. 

a. For name, enter Exempt Parts. 

b. For Entity IDs, click 0 Components >> Components. 

c. In the Select Components dialog, select vehicle mass and then click OK. 

Step 11: Create *CONTACT_AUTOMATIC_GENERAL contact  

1. In the Solver browser, right-click and select Create > *CONTACT > 

*CONTACT_AUTOMATIC_GENERAL from the context menu. A new group opens in 

the Entity Editor. 
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2. For name, enter impact. 

Step 12: Define the slave surface with slave set type 6, part set ID 
for exempted parts 

In this step the Entity Editor should still be open for the impact group. 

1. Click SSID. 

2. Set the entity selector to Set. 

3. Click Set. 

4. In the Select Set dialog, select Exempt Parts and then click OK. 

5. Select the ExemptSlvPartSet checkbox. The SSTYPE (slave surface type) value 

changes from 2 (part set ID) to 6 (part set ID for exempted parts). 

 

Step 13: Create an entity set, *SET_PART_LIST, to specify the 
elements that will contribute to the cross-sectional force results 

1. In the Solver browser, right-click and select Create > *SET > *SET_PART > 

*SET_PART_LIST from the context menu. A new set opens in the Entity Editor.  
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2. In the Entity Editor, define the set. 

a. For Name, enter CrossSectionPlane-Parts. 

b. For Entity IDs, click 0 Components >> Components. 

c. In the Select Components dialog, select interior crashbox and exterior 

crashbox. 

d. Click OK. 

Step 14: Define a section by creating 

*DATABASE_CROSS_SECTION_PLANE 

1. In the Solver browser, right-click and select Create > *DATABASE > 

*DATABASE_CROSS_SECTION_PLANE from the context menu. A new cross section 

opens in the Entity Editor. 

 

2. For Name, enter CrossSection_Plane. 

Step 15: Define the location and size of the section’s plane 

In this step the plane’s origin (the tail of the normal vector) is defined by a base node. 

The Entity Editor should still be open for the CrossSection_Plane cross section. 

1. Create a base node. 

a. Open the Create Nodes panel by clicking Geometry > Create > Nodes > XYZ 

from the menu bar, or by pressing F8. 

b. In the x field, enter -320. 

c. In the y field, enter -500. 
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d. In the z field, enter 100.  

 

e. Click create. A new node displays. 

 

f. Click return.   

2. In the Entity Editor, define the XTAIL, YTAIL, ZTAIL (base node) for the section. 

a. Click XTAIL, YTAIL, ZTAIL (base node), and then click .  

b. In the graphics area, select the base node you just created.  

Tip: If the base node is not visible, click  on the Visualization toolbar to 

display elements as a wireframe (skin only). 
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c. Click proceed. The Entity Editor displays the coordinates of the base node in the 

XTAIL, YTAIL, ZTAIL field. 

 

3. Set Geometry type to Finite plane. 

4. Define the normal vector. 

a. Click Normal, and then click . 

b. In the panel area, set the orientation selector to x-axis. 

c. Click proceed. 

5. Define the edge vector 

a. Click Edge, and then click . 

b. In the panel area, set the orientation selector to y-axis. 

c. Click proceed. The Entity Editor displays the coordinates of the edge vector L in 

the Normal field. 

6. For LENL (length of edge a, in the L direction), enter 100.  

7. For LENM (length of edge b, in the M direction), enter 200. 

 

Tip: If you know the coordinates of the base node, edge, and normal, you can 

manually enter them in the Entity Editor. 
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Step 16: Specify the parts slave to the cross section 

In this step the Entity Editor should still be open for the CrossSection_Plane cross section. 

1. For PSID, click Unspecified >> Set. 

2. In the Select Set dialog, select CrossSectionPlane-Parts and then click OK. 

Step 17: View the entities slave to the rigid wall 

1. In the Solver browser, right-click on CrossSection_Plane and select Review (press 

Q) from the context menu. The slave entities and rigid wall highlight. All of the other 

entities temporarily display grey. 

 

2. Return all of the entities to their original display color by right-clicking on 

CrossSection_Plane and selecting Review (press Q) from the context menu.  

Step 18: Create a *DEFINE_BOX containing the nodes making up the 
barrier and bumper’s left side.  

These nodes will be slave to the rigid wall.  

1. In the Solver browser, right-click and select Create > *DEFINE > *DEFINE_BOX 

from the context menu. A new block opens in the Entity Editor. 
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2. In the Entity Editor, define the block. 

a. For Name, enter half model. 

b. Optional. Click the Color icon and select a color to display the block. 

c. For Xmin Ymin Zmin, enter -600, -800, 0. 

d. For Xmax Ymax Zmax, enter -460, 0, 400. 

 

Step 19: Define a HyperMesh group by creating 
*RIGIDWALL_PLANAR_FINITE  

*RIGIDWALL are created from the Solver browser or Model browser, Create Cards menu 
(access from the Tools pull-down menu), or the Quick Access tool (Ctrl + F) when a 

keyword is entered. 

1. In the Solver browser, right-click and select Create >*RIGIDWALL > 

*RIGIDWALL_PLANAR_FINITE from the context menu. A new rigid wall opens in the 

Entity Editor. 
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2. For Name, enter wall. 

Step 20: Define the location and size of the rigid wall 

In the Create Nodes panel, XYZ sub-panel, the rigid wall’s origin (the tail of the normal 

vector) is defined by a base node. In this step, you will create a node from the create nodes 

panel and then select it for the base node.  

In this step the Entity Editor should still be open for the rigid wall. 

1. Create a base node. 

a. Open the Create Nodes panel by pressing F8.   

b. Go to the XYZ subpanel, click . 

c. In the x field, enter -600. 

d. In the y field, enter -750. 

e. In the z field, enter 90.  

f. Click create. 

Tip: If the base node is not visible, click  on the Visualization toolbar to 

display elements as a wireframe (skin only). 

 

g. Click return.   

2. In the Entity Editor, enter values for XT, YT, ZT, or select the above node for the rigid 

wall base from graphics area. 
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3. Set Geometry type to Finite plane. 

4. Define the normal vector. 

a. Click Normal, and then click . 

b. In the panel area, set the orientation selector to x-axis. 

c. Click proceed. 

5. Define the edge vector. 

a. Click Edge, and then click . 

b. In the panel area, set the orientation selector to y-axis. 

c. Click proceed. 

6. For Length LENL, enter 165. 

7. For Length LENM, enter 250. 

Note: The input values for LENL and LENM are the length of the edges a and b in the 

L and M directions, respectively. These values define the extent of the rigid 

wall. 

 

Step 21: Use the Entity Editor for the rigid wall to specify the nodes 
in the *DEFINE_BOX half model as slave to the rigid wall 

In this step the Entity Editor should still be open for the rigid wall. 

1. Click BOXID >> Block. 

2. In the Select Block dialog, select half and then click OK. 

3. For FRIC (Interface friction), enter 1.0. 
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Step 22: Specify some nodes to be output to the ASCII NODOUT file 

with *DATABASE_HISTORY_NODE 

1. In the Solver browser, right-click and select Create > *DATABASE > 
*DATABASE_HISTORY_NODE from the context menu. A new output block opens in 

the Entity Editor. 

 

2. In the Entity Editor, define the output block. 

a. For Name, enter nodeth. 

b. For Entity IDs, click 0 Nodes >> Nodes. 

c. In the graphics area, select a few nodes of interest. 

 

d. Click proceed. 
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Step 23: Export the model to an LS-DYNA 971_R# formatted input 

file 

1. From the menu bar, click File > Export > Solver Deck. The Export - Solver Deck 

tab opens 

2. Set File type to LsDyna. 

3. In the File field, navigate to your working directory and save the file as 

Bumper_complete.key. 

4. Click Export. 

Step 24 (Optional): Submit the LS-DYNA input file to LS-DYNA 970 

solver 

1. From the Start menu, open the LS-DYNA Manager program. 

2. From the solvers menu, select Start LS-DYNA analysis. 

3. Load the file bumper_complete.key.  

4. Start the analysis by clicking OK. 

Step 25 (Optional): View the results in HyperView 

The exercise is complete. Save your work to a HyperMesh file. 
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