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HM-4615: Model Importing, Airbags, Exporting Displayed, and Contacts using DYNA 

In this tutorial, you will learn how to: 

• Define *AIRBAG_WANG_NEFSKE for the airbag mesh geometry 

• Define an initial velocity of 3 mm/ms in the negative x-direction for the head with 

*INITIAL_VELOCITY_GENERATION 

• Define a contact between the airbag and head with 

*ICONTACT_AUTOMATIC_SURFACE_TO_SURFACE 

• Define *CONTACT_AIRBAG_SINGLE_SURFACE for the airbag 

• Define a contact between the plate and the airbag with 

*CONTACT_NODES_TO_SURFACE 
 

Import a LS-DYNA model 
 

 

Warning and Error Messages 

When importing a LS-DYNA model, HyperMesh warning and error messages will be written 
to a file named dynakey.msg or dynaseq.msg, depending on the FE input translator being 

used. This file is created in the same folder from which HyperMesh was started.  

 

Unsupported Cards 

On import, the LS-DYNA cards not supported by HyperMesh are written to the 

unsupp_cards panel. Access this panel by clicking Setup > Create > Control Cards from 

the menu bar. Unsupported cards will be exported with the remaining model. 

Care should be taken if an unsupported card points to an entity in HyperMesh. An example 

of this is when an unsupported material references a *PART. HyperMesh stores unsupported 

cards as text and does not consider pointers. 

 

LSTC Dummy Files 

You can read LSTC Hybrid III dummy files into HyperMesh by first converting the tree file to 

FTSS/ARUP tree file format.   

 

Include Files 

HyperMesh supports *INCLUDE. When Include files are imported into HyperMesh, the IDs of 

non-existing entities are maintained and will not be used for new entities.  

Use the Include files import option to specify whether to merge, preserve, or skip Include 

files on import. Access this option by clicking File > Import > Solver Deck from the menu 

bar. 

Support of Include files: 

• The LSDYNA keywords *INCLUDE, *INCLUDE_STAMPED_PART, 

*INCLUDE_STAMPED_PART_SET, *INCLUDE_TRANSFORM, and 

*INCLUDE_COMPENSATION_OPTION are mapped to Include files.  
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• Switch to different types of Include files using the context menu Include File option 

in the Model browser, with the exception of *INCLUDE_TRANSFORM, 

*INCLUDE_STAMPED_PART, and *INCLUDE_STAMPED_PART_SET. 

• Manage INCLUDE_TRANSFORM using the Transformation Manager. 

• During import, if the same Include file is referenced more than once using the 

*INCLUDE_TRANSFORM, then it will be imported, but appended with .#,  where # = 

1…n is shown in the Model browser. These will not be exported unless you clear the 

Instance checkbox. 

• During import, *INCLUDE_STAMPED_PART and *INCLUDE_STAMPED_PART_SET are 

imported as "read only" by default to preserve the associativity. 

• During import, an Include file can be read when *INCLUDE comes after 

*INCLUDE_TRANSFORM. 

• When importing Include files, use Solver options in the Import browser to choose 

the type of Include file to import. This option enables you to set the Include file type 
to one of the following: INCLUDE, INCLUDE_STAMPED_PART, 

INCLUDE_STAMPED_PART_SET, or INCLUDE_COMPENSATION_options. This is the 
only option which enanables you to attach any file of type INCLUDE_STAMPED_PART 

or INCLUDE_STAMPED_PART_SET. 

 

Export Displayed 
 

 

From the Export - Solver Deck tab, select the Export > Displayed option to export only 
displayed nodes and elements. Only model data associated to the displayed nodes and 

elements are exported. This model data includes materials and their associated curves, 

properties, portions of contacts, and output requests.  

 

Create and Review Contacts 
 

 

The table below describes how all slave and master set types are created and specified in 

contacts. 

* For slave surface only 

Slave and master set 

type 
LS-DYNA card Panel used to 

create card 

Equivalent type in 

Interfaces panel, 

add subpanel 

EQ. 0: set segment id  *SET_SEGMENT set_segment 

(contactsurfs) or … 
csurfs 

  Interfaces, add 

subpanel 
entity 

EQ. 1: shell element *SET_SHELL_Optio Entity Sets or… sets 

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.2



set id n 
Interfaces, add 

subpanel 
entity 

EQ. 2: part set id *SET_PART_LIST Entity Sets or… sets 

Interfaces, add 

subpanel 

comps 

EQ. 3: part id *PART Collectors comps 

* EQ. 4: node set id *SET_NODE_Option Entity Sets or… sets 

  Interfaces, add 

subpanel 

entity 

* EQ. 5: include all  Interfaces, add 

subpanel 

all 

* EQ. 6: part set id for 

exempted parts 
*SET_PART_LIST Interfaces, add 

subpanel and then 
card image sub-

panel 

sets 

 

Add subpanel 

While the Interfaces panel, add subpanel has several master and slave entity types to 

choose from in order to specify the LS-DYNA master or slave set for a *CONTACT, only the 

valid master and slave types are selectable for the particular contact you are creating.  

When the master or slave type is set to comps and only one component is selected, the LS-

DYNA type is 3, part ID, and *PART is created. When multiple components are selected, the 

LS-DYNA type is 2, part set ID, and *SET_PART_LIST is created. 

When the master or slave type is set to sets, only those sets valid for the particular contact 
you are creating are selectable. For example, for *CONTACT_NODES_TO_SURFACE, only a 

list of node sets is available for slave; you will not see a list of other set types, like element 

or part sets. 

 

Review Contacts 

Review contacts by clicking review in the Interfaces panel, add subpanel.  

 

Model Files 
 

 

This tutorial uses the airbag_start.key file, which can be found in 

<hm.zip>/interfaces/lsdyna/. Copy the file(s) from this directory to your working 

directory. 
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Exercise: Define Airbag, Velocity, and Contacts for the Airbag 

Analysis 
 

 

This exercise will help you learn how to define LS-DYNA airbags, loads, and contacts using 

HyperMesh.  

In this exercise, you will define an airbag, velocity, and contacts for a LS-DYNA analysis of a 

head impacting an inflating airbag. 

 

Head and airbag model 

Step 1: Load the LS-DYNA user profile 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to LsDyna. 

Step 2: Import the LS-DYNA model 

1. From the menu bar, click File > Import > Solver Deck. The Import - Solver Deck 

tab opens. 

2. In the File field, open the file airbag_start.key. 

3. Click Import. 

Steps 3-5: Define *AIRBAG_WANG_NEFSKE for the 
airbag mesh geometry 
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Step 3: Create a set of parts, *SET_PART_LIST, containing the 

AirbagFront and AirbagRear components 

1. In the Model browser, right-click and select Create > Set from the context menu. A 

new set opens in the Entity Editor. 

 

2. For Name, enter airbag_set. 

3. Set Card Image to Part. 

4. For Entity IDs, click 0 Components >> Components. 

 

5. In the Select Components dialog, select AirbagFront and AirbagRear and then click 

OK. 
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Step 4: Define the airbag (*AIRBAG_WANG_NEFSKE) 

1. Open the Solver browser by clicking View > Browsers > HyperMesh > Solver from 

the menu bar. 

2. In the Solver browser, right-click and select Create > *AIRBAG > 
*AIRBAG_WANG_NEFSKE from the context menu. A new control volume opens in 

the Entity Editor. 

 

3. For Name, enter airbag. 

4. Click SID. The entity selector becomes active. 

5. Set the entity selector to Sets. 

 

6. Click Set. 

 

7. In the Select Set dialog, select airbag_set and then click OK. 

Note: The parts in this set define the airbag's geometry. 
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8. For CV (Heat capacity at constant volume), enter 1023.0. 

9. For CP (Heat capacity at constant pressure), enter 1320.0. 

10. For T (Temperature of input gas), enter 780.0. 

11. Click LCMT (Load curve specifying input mass flow rate) >> Curve. 

12. In the Select Curve dialog, select airbag LCMT curve and then click OK. 

13. For C23 (Vent orifice coefficient), enter 1.0. 

14. Click LCA23 (Load curve defining vent orifice area as a function of pressure) >> 

Curve. 

15. In the Select Curve dialog, select airbag LCA23 curve and then click OK. 

16. For CP23 (Orifice coefficient for leakage), enter 1.0. 

17. For PE (Ambient pressure), enter 1.0E-4. 

18. For RO (Ambient density), enter 1.0E-9. 

19. For GC (Gravitational conversion constant), enter 1.0. 

Step 5: Define an initial velocity of 3 mm/ms in the negative x-
direction for the head with *INITIAL_VELOCITY_GENERATION 

1. In the Model browser, right-click and select Create > Load Collector from the context 

menu. A new load collector opens in the Entity Editor. 

 

2. For Name, enter velocity. 

3. Set Card Image to InitialVel. 

4. Under Options, right-click on NSID and select Create from the context menu. The 

Create Sets dialog opens. 

5. For Entity IDs, click 0 Nodes >> Nodes. 
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6. In the panel area, click nodes >> by Collector. 

7. Select the component, Head. 

 

8. Click select. 

9. Click proceed. 

10. In the Create Sets dialog, click Close. 

11. In the Solver browser, *INITIAL > *INITIAL_VELOCITY folder, right-click on 

velocity and select Review from the context menu. HyperMesh highlights the load 

collector and greys out all of the other entities. 
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12. Return all of the entities to their original display color by righting-click on velocity and 

selecting Reset Review from the context menu. 

 

Steps 6-12: Define a contact between the airbag 
and head with 
*CONTACT_AUTOMATIC_SURFACE_TO_SURFACE 

Step 6: Create a HyperMesh group with the card image 

SurfaceToSurface 

1. In the Solver browser, right-click and select Create > *CONTACT > 
*CONTACT_AUTOMATIC_SURFACE_TO_SURFACE > 

*CONTACT_AUTOMATIC_SURFACE_TO_SURFACE from the context menu. A new 

group opens in the Entity Editor. 

 

2. For Name, enter Airbag_Head. 

Step 7: Specify the head to be the master surface with surface type 
3, part ID 

In this step, the Entity Editor should still be open for the Airbag_Head group. 

1. Click MSID. 

2. Set the entity selector to Components. 

3. Click Components. 
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4. In the Select Components dialog, select Head and then click OK. 

Step 8: Specify all of the airbag to be the slave surface with surface 

type 2, part set ID 

In this step, the Entity Editor should still be open for the Airbag_Head group. 

1. Click SSID. 

2. Set the entity selector to Set. 

3. Click Set. 

4. In the Select Set dialog, select airbag_set and then click OK. 

Note: This set contains the components, AirbagFront and AirbagRear. 

Step 9: View the master and slave entities 

In this step, the Airbag_Head group should still be selected in the Solver browser. 

1. In the Solver browser, right-click on Airbag_Head and select Review from the 

context menu. The master and slave entities temporarily display in blue and red, 

respectively. All of the other entities temporarily display grey. 

 

2. Return all of the entities to their original display color by right-clicking on Airbag_Head 

and selecting Reset Review from the context menu. 

Step 10: Define *CONTACT_AIRBAG_SINGLE_SURFACE for the 

airbag 

1. In the Solver browser, right-click and select Create > *CONTACT > 
*CONTACT_AIRBAG_SINGLE_SURFACE from the context menu. A new group opens 

in the Entity Editor. 
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2. For Name, enter airbag. 

Step 11: Define all of the airbag to be the slave surface with slave 
set type 2, part set ID 

In this step, the Entity Editor should still be open for the airbag group. 

1. Click SSID. 

2. Set the entity selector to Set.  

3. Click Set. 

4. In the Select Set dialog, select airbag_set and then click OK. 

Step 12: View the slave entities 

In this step, the airbag group should still be selected in the Solver browser. 

1. In the Solver browser, right-click on airbag and select Review from the context 

menu. The master and slave entities temporarily display blue and red, respectively. All 

of the other entities temporarily display grey. 
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2. Return all of the entities to their original display color by right-click on airbag and 

selecting Reset Review from the context menu. 

 

Steps 13- 18: Define a contact between the plate 
and the airbag with 
*CONTACT_NODES_TO_SURFACE 

Step 13: Due to the dynamics of the contact, define the AirbagRear 

component to be the master surface with master type 0, set segment 
ID 

1. In the Solver browser, right-click and select Create > *SET > *SET_SEGMENT > 
*SET_SEGMENT from the context menu. A new contactsurf opens in the Entity 

Editor.  

 

2. For Name, enter AirbagRear_master. 

3. Optional. Click the Color icon and select a color for the contactsurf. 

4. For Elements, click 0 Elements >> Elements. 

5. In the panel area, set the second switch to elems. 
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6. Click elems >> by collector. 

7. Select the component, AirbagRear. 

8. Click select. 

9. Click add. 

 

Step 14: Reverse the contactsurf’s pyramids so they point out of the 

airbag 

1. In the panel area, set the first switch to adjust normals. 

 

2. Select the all elements checkbox. 

3. Click reverse. 
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4. Click return. 

Step 15: Create *CONTACT_NODES_TO_SURFACE card 

1. In the Solver browser, right-click and select Create > *CONTACT > 
*CONTACT_NODES_TO_SURFACE > *CONTACT_NODES_TO_SURFACE from the 

context menu. A new group opens in the Entity Editor. 

 

2. For Name, enter Airbag_Plate. 
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Step 16: Specify the AirbagRear_master contactsurf for the contact’s 

master surface 

In this step, the Entity Editor should still be open for the Airbag_Plate group. 

1. Click MSID. 

2. Set the entity selector to Contactsurfs. 

3. Click Contactsurfs. 

4. In the Select Contactsurfs dialog, select AirbagRear_master and then click OK. 

Step 17: Define the plate to be the contact’s slave surface with slave 
type 4, node set ID 

1. For SSID, click 0 Nodes >> Nodes. 

2. In the panel area, set the switch to nodes. 

3. Click nodes >> by collector. 

4. Select the component, RigidPlate. 

5. Click select. 

 

6. Click add. HyperMesh adds the slave selection to the group Airbag_Plate. 
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7. Click return. 

Step 18: View the master and slave entities 

1. In the Solver browser, *CONTACT > *CONTACT NODES TO SURFACE folder, right-

click on Airbag_Plate and select Review from the context menu. The master and 
slave entities temporarily display blue and red, respectively. All of the other entities 

temporarily display grey. 

 

2. Return all of the entities to their regular display color by right-clicking on Airbag_Plate 

and selecting Reset Review from the context menu. 

Step 19: Review the created solver entities using the Solver Browser 

1. In the Solver browser, *CONTACT > *CONTACT_AIRBAG_SINGLE_SURFACE 
folder, right-click on airbag and select Review from the context menu. The master and 

slave entities temporarily display blue and red, respectively. All of the other entities 

temporarily display grey. 

Note: Only slave (red) entities are shown because there are no master entities for 

this type of contact. 
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2. Return all of the entities to their regular display color by right-clicking on airbag and 

selecting Reset Review from the context menu. 

 

3. In the Solver browser, *CONTACT > *CONTACT NODES TO SURFACE folder, right-

click on Airbag_Plate and select Isolate Only from the context menu. Only the 

elements/components that are implicated in this contact display. 

Tip: If master and slave entities are not visible, make sure the 

Show/Isolate/IsolateOnly/Attached checkbox is selected in the Options 
tab of the Browser Configuration dialog. Access the Browser 

Configuration dialog by right-clicking in the Model browser and selecting 

Configure Browser from the context menu. 

 

4. In the Solver browser, *CONTACT > *CONTACT_AIRBAG_SINGLE_SURFACE 

folder, right-click on airbag and select Show from the context menu. The entire airbag 

displays, as this entity contains the entire airbag. 
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5. In the *INITIAL > *INITIAL_VELOCITY folder, right-click on velocity and select 

Review from the context menu. The nodes on which velocity was applied displays. 

 

6. Return all of the entities to their regular display color by right-clicking on velocity and 

selecting Reset Review from the context menu. 

Step 20: Export the model to an LS-DYNA 971 formatted input file 

1. From the menu bar, click File > Export > Solver Deck. The Export - Solver Deck 

tab opens.  

2. Set Template to Keyword971. 
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3. In the File field, navigate to your working directory and save the file as 

airbag_complete.key. 

4. Next to Export options, click . 

5. Set Export to All. 

6. Click Export. 

Step 21 (Optional): Submit the LS-DYNA input file to LS-DYNA 970 

1. From the Start menu, open the LS-DYNA Manager program. 

2. From the solvers menu, select Start LS-DYNA analysis. 

3. Load the file airbag_complete.key.  

4. Start the analysis by clicking OK. 

Step 22 (Optional): View the results in HyperView 

The exercise is complete. Save your work to a HyperMesh file. 
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