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HM-4605: Defining LS-DYNA Model and Load Data, Controls, and Output 

In this tutorial, you will learn to: 

• View LS-DYNA keywords in HyperMesh as they will appear in the exported LS-DYNA 

input file 

• Understand part, material, and section creation and element organization 

• Create sets 

• Create velocities 

• Understand the relation of LS-DYNA entity type to HyperMesh element and load 

configurations 

• Create nodal single point constraints 

• Create contacts with set segment ID 

• Define output and termination 

• Export models to LS-DYNA formatted input files 

 

Tools/Utilities 
 

 

The following tools/utilities set the foundation for settings up an LS-DYNA input deck with 

HyperMesh: 

• LS-DYNA FE input translator 

• FE output template 

• LS-DYNA Utility menu 

• LS-DYNA User Profile  

 

Model Files 
 

 

This tutorial uses the head_start.hm, head_2.hm, and head_3.hm files, which can be found 

in <hm.zip>/interfaces/lsdyna/. Copy the file(s) from this directory to your working 

directory. 

 

Exercises 
 

 

This tutorial contains the following exercises: 

Exercise 1:  Define Model Data for the Head and A-Pillar Impact Analysis 

Exercise 2:  Define Boundary Conditions and Loads for the Head and A-Pillar Impact 

Analysis  

Exercise 3:  Define Termination and Output for the Head and A-Pillar Impact Analysis  
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Exercise 1: Define Model Data for the Head and A-Pillar Impact 

Analysis 
 

 

Element property and material assignment rules are based on the current user profile 

(solver interface).   

 

Element Property and Material Assignment Rules for LS-DYNA Solver 

• Components have no card images; typically "part" card images. 

• Properties and materials are only assigned to components; properties and materials 

are not directly assigned to elements. Use the Entity Editor to assign properties and 

materials to components. 

• Elements are assigned through the property and material assigned to the component 

in which they are organized into. 

• If a component is not assigned to a property or material, then all of the elements 

within that component will not have a property or material assignment. 

 

Property/Material Assignment Schematic 

The figure below shows how the keywords *PART, *ELEMENT, *MAT, and *SECTION relate 

to each other.  
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Relation of *PART, *ELEMENT, *MAT, and *SECTION to Each Other 

*ELEMENT EID PID 

 

*PART  PID SID MID 

 

*SECTION SID  

 

*MAT  MID 

 

A *PART shares attributes such as section properties (*SECTION) and a material model 

(*MAT). A group of elements (*ELEMENT) sharing common attributes generally share a 
common part ID (PID). The figure below shows how the keywords *PART, *ELEMENT, *MAT 

and *SECTION relate to each other. A unique PID assigns a material ID (MID) and a section 

ID (SID) to an element.  

The table below shows how the *ELEMENT, *PART, *SECTION, and *MAT keywords are 

organized in HyperMesh. 

*ELEMENT EID PID Elements are organized into a component collector 

*PART  PID SID MID Component collector’s card image 

*SECTION SID Property collector with a property card image. Assign a 

property to a *PART by pointing to the property collector 

in the component collector’s card image. 

*MAT  MID Material collector with a material card image. Assign the 
material to the *PART by associating the material 

collector to the component collector. 

Create and modify component, property, and material collectors in the Collectors panel, 

Model or Solver browser, and Entity Editor. 

 

View LS-DYNA Keywords in HyperMesh 

Use a HyperMesh card image to view the keywords and data lines for defined LS-DYNA 
entities as interpreted by the loaded template. The keywords and data lines appear in the 

exported LS-DYNA input file as you see them in the card images. Additionally, for some card 
images, you can define and edit various parameters and data items for the corresponding 

LS-DYNA keyword. 

View card images using the Card Editor, which can be accessed by doing one of the 

following: 

• From the menu bar, click Tools > Card Edit. 

• On the Collectors toolbar, click . 
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• In the Model browser or Solver browser, right-click on an entity and select Card 

Edit from the context menu. 

 

Create *MAT 

In HyperMesh, a *MAT is a material collector with a card image. To relate it to a *PART, the 

material collector is associated to a component collector.  

Create a material collector by doing one of the following: 

• In the Model browser or Solver browser, right-click and select Create > Material 

from the context menu. 

• From the menu bar, click Materials > Create. 

• On the Collectors toolbar, click . 

 

Update a Component’s Material 

Change the material assigned to a component in the Component Collectors panel, 

update subpanel, or in the Entity Editor.  

• Access the update subpanel by clicking  on the Collectors toolbar. 

• Access the Entity Editor by left-clicking on a component in the Model or Solver 

browser. 

 

Material Table 

Use the Material Table to: 

• View existing materials in an interactive tabular list 

• Create materials 

• Merge identical materials 

• Search for duplicate materials 

• Change the properties of existing materials 

 

The Material Table can be accessed in the LS-DYNA Utility menu, DYNA Tools page, under 

Parts. 

 

Create *SECTION 

In HyperMesh, *SECTION is a property collector with a card image.  

Create a property collector by doing one of the following: 

• In the Model browser or Solver browser, right-click and select Create > Property 

from the context menu. 

• From the menu bar, click Properties > Create > Properties. 
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• On the Collectors toolbar, click . 

 

Exercise Objective and Tasks 

The purpose of this exercise is to help you become familiar with defining LS-DYNA 

materials, sections, and parts in HyperMesh.  

In this exercise you will set up model data for a LS-DYNA analysis of a hybrid III dummy 

head impacting an A-pillar. The head and A-pillar model is depicted below.  

 
Head and A-pillar model 

This exercise contains the following tasks: 

• Define the material *MAT_ELASTIC for the A-pillar part and head part 

• Define *SECTION_SHELL for the A-pillar 

• Define *SECTION_SOLID for the head 

• Define *PART for the A-pillar and the head 

Step 1: Load the LS-DYNA user profile 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to LsDyna. 
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Step 2: Retrieve the HyperMesh file 

1. Open a model file by clicking File > Open > Model from the menu bar, or clicking  

on the Standard toolbar. 

2. In the Open Model dialog, open the head_start.hm file. The model appears in the 

graphics area. 

Step 3: Define the material *MAT_ELASTIC for the A-pillar and head 

1. In the Solver browser, right-click and select Create > *MAT > MAT(1-50) > 1 - 

*MAT_ELASTIC from the context menu. HyperMesh creates and opens a new material 

in the Entity Editor. 

 

2. For Name, enter ELASTIC. 

3. For Rho (Density), enter 1.2E-6.  

4. For E (Young's modulus), enter 210. 

5. For PR (Poisson's ratio), enter 0.26. 
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Step 4: Define property (*SECTION_SHELL) with a thickness of 3.5 

mm for the A-pillar 

1. In the Solver browser, right-click and select Create > *SECTION > 
*SECTION_SHELL from the context menu. HyperMesh creates and opens a new 

property in the Entity Editor. 

2. For Name, enter section3.5. 

3. For Card Image, select SectShll 

4. Expand NonUniformThickness, and enter 3.5 for T1. 
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Step 5: Define *SECTION_SOLID for the head 

1. In the Solver browser, right-click and select Create > *SECTION > 
*SECTION_SOLID from the context menu. HyperMesh creates and opens a new 

property in the Entity Editor. 

2. For Name, enter solid. 

Step 6: Define *PART for the A-pillar 

MAT_ELASTIC is the material collector named "ELASTIC"; *SECTION_SHELL is the 

property collector named "section3.5". 

1. In the Model browser, Component folder, click pillar. The Entity Editor opens, and 

displays the component's corresponding data. 

 

2. Set Card image to Part. 

3. For Material, click Unspecified >> Material. 

 

4. In the Select Material dialog, select ELASTIC and then click OK. HyperMesh assigns 

the material Elastic to the component pillar. 
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5. For Property, click Unspecified >> Property. 

6. In the Select Property dialog, select section3.5 and then click OK. HyperMesh 

assigns the property section3.5 to the component pillar. 

Step 7: Define *PART for the head 

*MAT_ELASTIC is the material collector named "ELASTIC"; *SECTION_SOLID is the 

property collector named "solid". 

1. In the Model browser, Component folder, click head. The Entity Editor opens, and 

displays the component's corresponding data. 

 

2. Set Card Image to Part. 

3. Assign the material ELASTIC to the component. 

4. Assign the property solid to the component. 

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.9



 

Step 8 (Optional): Save your work 

The exercise is complete. Save your work as a HyperMesh file named head_2.hm. 

 

Exercise 2: Define Boundary Conditions and Loads for the Head and 

A-Pillar Impact Analysis 
 

 

*INITIAL_VELOCITY_(Option) 

LS-DYNA keywords used for defining initial velocity. 

LS-DYNA keyword Velocity applied 

to … 

Setup in HyperMesh 

*INITIAL_VELOCITY set of nodes, 

*SET_NODE_LIST 

Entity set of nodes, load collector 

with InitialVel card image 

*INITIAL_VELOCITY_GENERATIO

N 

one *PART or set of 
parts, 

*SET_PART_LIST 

Entity set of comps, load collector 

with InitialVel card image 

*INITIAL_VELOCITY_NODE individual nodes Created from Velocity panel, 

organized in load collector with no 

card image 

 

*SET 

Graphically view a set’s contents in the Entity Sets panel using the review function. 
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HyperMesh Entity Configurations and Types 

HyperMesh elements and loads have two identifiers: 

• Configuration - a HyperMesh core feature.  

• Type - defined by the loaded FE output template. A configuration can support 

multiple types. Before creating elements or loads, select the desired type from either 

the Elem Types panel. 

 

Only use the Load Types subpanel to directly create loads on nodes or elements. For all 

other cases, define loads by creating a load collector with a card image. For example, 
*INITIAL_VELOCITY_NODE (applied directly to nodes) is created from the Velocities panel, 

while *INITIAL_VELOCITY (applied to nodes in a set) is a load collector with the InitialVel 

card image. 

View a list of element and load configurations in the Elem Types panel and the Load 

Types panel, respectively. 

  

elem types panel 

  
load types panel 

Some element configurations are rigid and quad4. When you load a dyna.key template, the 

following types of the rigid configuration are available: RgdBody, ConNode, and GenWeld 
(*CONSTRAINED_NODAL_RIGID_BODY, *CONSTRAINED_NODE_SET, and 

*CONSTRAINED_GENERALIZED_WELD_SPOT).  

Similarly, some load configurations are force and pressure. Types of the pressure 
configuration are ShellPres and SegmentPre (*LOAD_SHELL_ELEMENT and 

*LOAD_SEGMENT). 

Most element and load configurations have their own panels. For example, rigids are 

created with the Rigids panel and constraints are created with the Constraints panel. 
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*BOUNDARY_SPC_(Option) 

LS-DYNA keywords used for defining nodal single point constraints.  

LS-DYNA keyword Constraint applied to … Setup in HyperMesh 

*BOUNDARY_SPC_NODE individual nodes These are constraints created 

from the Constraints panel and 
organized into a load collector 

with no card image. 

*BOUNDARY_SPC_SET a set of nodes 

*SET_NODE_LIST 

This is an entity set of nodes 

referenced in a load collector’s 

BoundSpcSet card image. 

 

*CONTACT and *SET_SEGMENT 

A LS-DYNA contact is a HyperMesh group. Select groups when you want to manipulate a 

*CONTACT, such as delete, renumber, or display it off. 

 

LS-DYNA Contact Master and Slave Types 

LS-DYNA has multiple contact master and slave types from which to choose. 

 

*SET_SEGMENT and Contactsurfs Panel 

Create a *SET_SEGMENT by right-clicking in the Solver browser and selecting Create > 

*SET > *SET_SEGMENT from the context menu. Additionally, add and remove elements 
from an existing *SET_SEGMENT and adjust the normal of segments without adjusting the 

normal of elements with the Contactsurfs panel. 

The graphical representation of a contactsurf is pyramids, one pyramid for each segment. 

The orientation of a pyramid represents the normal orientation of the segment.  

By default, the orientation of a pyramid is the same as the normal of the element 

underneath. 

 

Exercise Objective and Tasks 

The purpose of this exercise is to help you become familiar with defining LS-DYNA boundary 

conditions, loads, and contacts in HyperMesh.  

In this exercise you will set up the boundary conditions and load data for a LS-DYNA 
analysis of a hybrid III dummy head impacting an A-pillar. The head and A-pillar model is 

depicted below.  
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Head and A-pillar model 

This exercise contains the following tasks: 

• Define velocity on all nodes of the head with *INITIAL_VELOCITY 

• Constrain the pillar’s end nodes in all six degrees of freedom with 

*BOUNDARY_SPC_NODE 

• Define a contact between the head and A-pillar with 

*CONTACT_AUTOMATIC_SURFACE_TO_SURFACE 

Step 1: Load the LS-DYNA user profile 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to LsDyna. 

Step 2: Retrieve the HyperMesh file 

1. Open a model file by clicking File > Open > Model from the menu bar, or click  on 

the Standard toolbar. 

2. In the Open Model dialog, open the head_2.hm file. The model appears in the graphics 

area. 

3. Observe the model using various visual options available in HyperMesh (rotation, 

zooming, etc.). 
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Step 3: Create a node set, *SET_NODE_LIST, containing all the 

nodes in the head component 

1. In the Solver browser, right-click and select Create > *SET > *SET_NODE > 
*SET_NODE_LIST from the context menu. HyperMesh creates and opens a new set in 

the Entity Editor. 

 

2. For Name, enter Vel_Nodes. 

3. For Entity IDs, click 0 Nodes >> Nodes. 

 

4. In the panel area, click nodes >> by collector. 

5. Select the component, head. 

 

6. Click select. 

7. Click proceed. 
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Step 4: Define the velocity 

1. In the Solver browser, right-click and select Create > *INITIAL 
>*INITIAL_VELOCITY from the context menu. HyperMesh creates and opens a new 

load collector in the Entity Editor. 

 

2. For Name, enter init_vel. 

3. Click NSID (Node Set ID), and then click Set. 

4. In the Select Set dialog, select Vel_Nodes and then click OK. 

5. For VX (x-component of mass center of velocity), enter 5. 
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Step 5: Create a load collector for the constraints to be created 

1. In the Model browser, right-click and select Create > Load Collector from the context 

menu. HyperMesh creates and opens a new load collector in the Entity Editor. 

2. For Name, enter SPC. 

3. Optional: Click the Color icon, and select a color to display the load collector. 

4. Set Card Image to <None>. 

Step 6: Create constraints on the pillar’s end nodes 

1. In the Solver browser, right-click and select Create > *BOUNDARY > 

*BOUNDARY_SPC_NODE from the context menu. The Constraints panel opens. 

2. In the panel area, set the entity selector to nodes. 

3. Click nodes >> by sets. 

4. Select the entity set, nodes for SPC. 

 

5. Click select. HyperMesh selects the nodes on both ends of the pillar. 
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6. Verify that all six dof (degree of freedom) checkboxes are selected. 

7. Verify that the load type is set to BoundSPC. 

8. Select the label constraints checkbox to display each constraint's label in the graphics 

area. 

9. Click create. 

 

10. Click return to close the panel. 

Step 7: Define a *SET_SEGMENT for the slave entities, the A-pillar 
elements 

1. In the Solver browser, right-click and select Create > *SET > *SET_SEGMENT > 

*SET_SEGMENT from the context menu. HyperMesh creates and opens a new 

contactsurf in the Entity Editor. 

2. For Name, enter pillar_slave. 

3. Optional. Click the Color icon, and select a color to display the contactsurf. 

4. For Elements, click 0 Elements >> Elements. 

5. In the panel area, set the second switch to elems. 
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6. Click elems >> by collector. 

7. Select the component, pillar. 

 

8. Click select. 

9. Click add. 

10. Review the contactsurf to make sure that its pyramids are pointing out of the pillar. 

 

11. Click return to close the panel. 

Step 8: Define a *SET_SEGMENT for the master entities, the head 
elements 

1. In the Solver browser, right-click and select Create > *SET > *SET_SEGMENT > 

*SET_SEGMENT from the context menu. HyperMesh creates and opens a new 

contactsurf in the Entity Editor. 

2. For Name, enter head_master. 

3. Optional. Click the Color icon, and select a color to display the contactsurf. 

4. For Elements, click 0 Elements >> Elements. 

5. In the panel area, set the first switch to add solid faces.  
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6. Set the second switch to elems. 

7. Click elems >> by collector. 

8. Select the component, head. 

 

9. Click select. 

10. Using the nodes selector, select three nodes that belong to the same face of a solid 

element. 

11. In the face angle field, enter 30. 

12. Click add. 

13. Review the contactsurf to make sure that its pyramids are pointing out of the head. 

 

14. Click return to close the panel. 

Step 9: Create a HyperMesh group with the SurfaceToSurface card 

image 

1. In the Solver browser, right-click and select Create > *CONTACT > 

*CONTACT_SURFACE_TO_SURFACE > *CONTACT_SURFACE_TO_SURFACE from 

the context menu. HyperMesh creates and opens a new group in the Entity Editor. 

2. For Name, enter contact. 
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Step 10: Add the slave and master contactsurfs to the HyperMesh 

group 

In this step, the Entity Editor should still be open for the group, contact. 

1. In the Entity Editor, click MSID and set the entity selector to Contactsurfs. 

2. Click Contactsurfs. 

3. In the Select Contactsurfs dialog, select head_master and then click OK. 

4. Click SSID, and set the entity selector to Contactsurfs. 

5. Click Contactsurfs. 

6. In the Select Contactsurfs dialog, select pillar_slave and then click OK. 

Step 11: Edit the group’s card image to define the AUTOMATIC 

option 

In this step, the Entity Editor should still be open for the group, contact. 

1. In the Entity Editor, for the first Options parameter, select Automatic. 

Step 12: Review the group’s master and slave surfaces 

1. Open the Interfaces panel by clicking interfaces from the Analysis page. 

2. Go to the add subpanel. 

3. Click name=, and select contact. 

 

4. Click review. HyperMesh temporarily displays the master and slave entities in blue and 

red, respectively.  
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5. Click return to close the panel. 

Step 13 (Optional): Save your work 

The exercise is complete. Save your work as a HyperMesh file named head_3.hm. 

 

Exercise 3: Define Termination and Output for the Head and A-Pillar 

Impact Analysis 
 

 

*CONTROL and *DATABASE 

*CONTROL cards are optional, but can be used to change defaults and activate solution 

options, such as mass scaling, adaptive meshing, and an implicit solution. It is advisable to 

define *CONTROL_TERMINATION in a model to specify a job’s end time. 

*DATABASE cards are optional, but are necessary to obtain output files containing results.  

 

Exercise Objective and Tasks 

The purpose of this exercise is to help you become familiar with defining LS-DYNA control 

data and output requests in HyperMesh.  

In this you will define the termination and output for a LS-DYNA analysis of a hybrid III 

dummy head impacting an A-pillar. The head and A-pillar model is shown in the image 

below.  

 
Head and A-pillar model  

This exercise contains the following tasks: 

• Specify the time at which LS-DYNA is to stop the analysis with 

*CONTROL_TERMINATION 

• Specify ASCII output with *DATABASE_(Option) cards 
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• Specify the output of d3plot files with *DATABASE_BINARY_D3PLOT 

• Export the model to an LS-DYNA 970 formatted input file 

Step 1: Load the LS-DYNA user profile 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to LsDyna. 

Step 2: Retrieve the HyperMesh file 

1. Open a model file by clicking File > Open > Model from the menu bar, or clicking  

on the Standard toolbar. 

2. In the Open Model dialog, open the head_3.hm file. The model appears in the graphics 

area. 

Step 3: Specify the time at which you want LS-DYNA to stop the 

analysis with *CONTROL_TERMINATION 

1. In the Solver browser, right-click and select *Create > *CONTROL > 

*CONTROL_TERMINATION from the context menu. HyperMesh creates and opens a 

new control in the Entity Editor. 

 

2. For ENDTIM (termination time), enter 2.5. 
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Step 4: Specify the output of d3plot files with 

*DATABASE_BINARY_D3PLOT 

1. In the Solver browser, right-click and select Create > *DATABASE > 
*DATABASE_BINARY_D3PLOT from the context menu. HyperMesh creates and 

opens a new database in the Entity Editor. 

2. For DT (time interval between outputs), enter 0.1. 

Step 5: Specify ASCII output with *DATABASE_(Option) cards 

1. In the Solver browser, right-click and select Create > *DATABASE > 

*DATABASE_OPTION from the context menu. HyperMesh creates and opens a new 

database in the Entity Editor. 

2. Select the GLSTAT checkbox. 

3. For DT, enter 0.1. 

Note: This specifies the output of global data at every 0.1 ms. 

4. Select the MATSUM checkbox. 

5. For DT, enter 0.1.  

Note: This specifies the output of material energies every 0.1 ms.  

6. Select the SPCFORC checkbox. 

7. For DT, enter 0.1. 

Note: This specifies the output of SPC reaction forces every 0.1 ms. 

Step 6: Export the model as an LS-DYNA keyword file 

1. From the menu bar, click File > Export > Solver Deck. 

2. In the Export - Solver Deck tab, set File type to LsDyna.  

3. From the Template list, select appropriate template.  

4. In the File field, navigate to your working directory and save the file as 

head_complete.key. 

5. Click Export.  

Step 7 (Optional):  Submit the LS-DYNA input file to LS-DYNA 970 

1. From your desktop’s Start menu, open the LS-DYNA Manager program. 

2. From the solvers menu, select Start LS-DYNA analysis. 

3. Load the file head_complete.key.  

4. Click OK to start the analysis. 
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Step 8 (Optional):  Post-process the LS-DYNA results using 

HyperView 

The exercise is complete. Save your work to a HyperMesh file. 
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