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HM-4330: Defining *STEP using Abaqus Step Manager 

In this tutorial, you will learn how to: 

• Load the Abaqus user profile  

• Retrieve the HyperMesh model file 

• Define the *STEP card and specify *STATIC as an analysis procedure 

• Define loads (*CLOAD) and boundary conditions (*BOUNDARY) 

• Define pressure loads (*DLOAD) with an element set 

• Define output requests 

• Export the database to an Abaqus input file 

 

Model Files 
 

 

This exercise uses the abaqus_StepManager_tutorial.hm file, which can be found in 

<hm.zip>/interfaces/abaqus/. Copy the file(s) from this directory to your working 

directory. 

 

Exercise 
 

 

Step 1: Load the Abaqus user profile and the model 

A set of standard user profiles is included in the HyperMesh installation. User profiles 

change the appearance of a panel, however they do not affect the internal behavior of each 

function. 

Complete the steps below to load the Abaqus user profile and the model. 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to Abaqus, Standard 3D. 

3. Open a model file by clicking File > Open > Model from the menu bar, or clicking  

on the Standard toolbar. 

4. In the Open Model dialog, open the abaqus_StepManager_tutorial.hm file. 

Note: The abaqus_StepManager_tutorial.hm file contains pre-defined model data. 

Use this file in the following steps to define the history data portion of this 

model. 

Step 2: Define a *STEP card and specify *STATIC as the analysis 

procedure 

In this step, you will create a *STEP card with the *STATIC analysis procedure.  

1. From the menu bar, click Tools > Load Step Browser. The Step Manager opens. 
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2. Click New. The Create New Step dialog opens. 

3. In the Name field, enter step1. 

4. Click Create. A step, labeled step1, opens the Load Step dialog. 

5. In the first pane, select Title. The Step heading option with a disabled field is 

displayed.  

 

6. Select the Step heading checkbox, and enter 100kN in the text field. 

 

7. Click Update to store the heading information in step1.  

8. In the first pane, select Parameter.  

9. Select the Name and Perturbation checkboxes. 

Note: Notice Name is already set to step1. 

 

10. Click Update. 

11. In the first pane, select Analysis procedure. 

12. Set Analysis type to static  

 

13. Click Update. 

14. Click the Dataline tab. 

15. Select the Optional dataline checkbox to add an additional dataline.  

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.2



16. Add individual data, such as Initial increment, by selecting the appropriate checkbox 

and entering a value.  

Note: When a checkbox is disabled, a space will be added in the ASCII file, and the 

Abaqus solver will use the default value.  

 

17. Click Update. 

 

Steps 3 - 6: Define the Loads (*CLOAD) and 
Boundary Conditions (*BOUNDARY) 

In the following steps you will add the *CLOAD and *BOUNDARY keywords to the current 

load collector by defining loads and boundary conditions.  

Step 3: Create constraints (*BOUNDARY) 

1. In the first pane, select Boundary.  

2. Click New. The Create Load Collector dialog opens. 

3. In the Name field, enter loads_and_constraints. 

4. Click Create.  

5. Optional. In the Load collector table, Display column, click the color icon to select a 

color for the load collector. 

 

6. Verify that the Status checkbox for loads_and_constraints is selected. 

Note: By selecting this checkbox, you are adding this load collector into the loadstep. 

7. Click the loads_and_constraints load collector. A set of new tabs displays. 
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8. From the Define tab, verify Type is set to default(disp). 

 

9. Click Define from ‘Constraints’ panel. The Constraints panel opens. Use this panel 

to create constraints.  

Step 4: Create constraints from the Constraints panel 

1. On the Standard Views toolbar, click  (XZ Right Plane view).  

2. In the Constraints panel, click nodes >> by window.  

3. With the exception of the nodes at the ends of the cradle, draw a rectangle around all 

of the displayed nodes. 

  

4. Select the exterior checkbox. 

5. Click select entities. HyperMesh selects all of the nodes outside the window you drew.  

 

6. Verify that all six dof checkboxs are selected. 

 

7. Click create. HyperMesh creates constraints at the selected nodes.  
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8. Click return to go back to the Load Step dialog. 

9. At the bottom of the Load Step dialog, look at the Load type line. Bc (short for 

BOUNDARY) appears on this line, which indicates step1 is a load type created in the 
load_and_constraints load collector. The corresponding load type in the first pane is 

also highlighted.  

 

Step 5: Create Forces (*CLOAD) 

1. In the first pane of the Load Step dialog, expand Concentrated loads, and select 

CLOAD-Force. A new set of tabs displays. 

 

2. From the Define tab, click Define from ‘Forces’ Panel. The Forces panel opens. Use 

this panel to create forces. 

Step 6: Create forces from the Forces panel 

1. Select the central node on the top side of the bracket arm. 

 

2. In the Forces panel, magnitude= field, enter -100.  
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3. Set the orientation selector to z-axis. 

 

4. Click create.  

  

5. Click return to go back to the Load Step dialog. 

6. At the bottom of the Load Step dialog, notice the Load type now reads Cload-f, which 
indicates CLOAD-force as another load type created in the loads_and_constraints load 

collector. The corresponding load type in the first pane is highlighted.  

 

7. Click Review | Reset. The constraints and forces that belong to the 

loads_and_constraints load collector highlight. 
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8. Revert the highlighted constraints and forces to the load collector color by right-clicking 

on Review. 

Step 7: Define pressure loads (*DLOAD) with element set 

In this step, you will create a *DLOAD pressure load and add it to the current load collector 

with an element set.  

1. In the first pane of the Load Step dialog, expand Distributed loads, and select 

DLOAD. A new set of tabs displays. 

2. From the Define tab, set Define DLOAD on to Element sets. The element sets table 

displays. 

3. Rotate the model to the view as shown in the image below. 

 

4. From the Load Step dialog, set Type to default (Pressure). 

5. Set Element sets to pressure_set.  

Tip: To view the entire list of element sets, click . Use Filter and Sort to narrow 

your search. 

6. Click the right arrow to add the selected set to the element sets table. 
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7. Under Element sets, click Review | Reset Set. The element set highlights. 

 

9. Revert the load collector back to its original color by right-clicking on Review | Reset 

Set. 

10. In the element sets table, Label column, select P for the newly added pressure_set. 

 

11. Because the pressure_set contains shell elements, the direction of normal to the 
elements must be known to determine the sign of the magnitude. Find the direction of 

the normal by selecting the pressure_set element from the table and clicking Show 

faces.   
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12. Clear the display by right-clicking on Show faces. 

13. In the element sets table, Magnitude column, enter -10 for pressure_set.   

Note: The negative magnitude means pressure load in the opposite direction of the 

underlying shell element normals.  

14. Click Update. The HyperMesh database updates. The Load type line, at the bottom of 

the dialog, now displays Dload, which indicates DLOAD as another load type created in 
the loads_and_constraints load collector. The corresponding load type is the first pane 

is also highlighted. 

 

15. In the element sets table, Elset column, click pressure_set.   

16. Click Review | Reset Set to review the loads. 
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17.Revert back to the standard view by right-clicking on Review | Reset Set. 

 

In this exercise, you constrained and applied distributed loads on the model using 
HyperMesh panels. The loads (*DLOAD) information is automatically stored in step1. Next, 

you will specify the output requests for this step.  

 

Steps 8-9: Define Output Requests 

In this exercise, you will specify several output requests for step1. There are two methods 

for defining output request described below. 

Step 8: Request ODB file outputs 

1. In the first pane of the Load Step dialog, expand Output request, and click ODB file. 

 

2. Click New. 

3. In the Create Output block dialog, Name field, enter step1. 

4. Click Create.  
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5. In the Output block table, click step1. A new set of tabs displays. 

 

6. In the Output tab, select the Output checkbox. Leave Output set to field.  

7. Select the Node output and Element output checkboxes. The Node Output and 

Element Output tabs become active.  

 

8. Click the Node Output tab.  

9. Expand Displacement and select U. The Data lines table now displays "U", which 

allows you to request displacement results in the .obd file. 

Tip: You can manually type output request into the Data lines table, including 
unsupported requests. They will be written just as they are entered in the 

table. 

 

10. Click Update.  
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11. Click the Element Output tab.  

12. Select the Position checkbox, and set it to Nodes.  

13. Expand Stress and select S. The Data lines table now displays "S", which allows you 

to request stress results in the .obd file.  

 

14. Click Update.  

Step 9: Request results file (.fil) outputs 

1. In the first pane of the Load Step dialog, expand Output request, and click Result 

file (.fil). 

 

2. In the Define tab, select the Node file and Element file checkboxes. The Node File 

and Element File tabs become active. 

 

3. Click the Node File tab. 
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4. Expand Displacement, and select U. The Data lines table displays "U", which allows 

you to request displacement results in the .fil file. 

 

5. Click Update. 

6. Click the Element File tab. 

7. Select the Position checkbox, and set it to averaged at nodes. 

8. Expand Stress, and select S. The Data line table displays "S", which allows you to 

request stress results in the .fil file. 

 

9. Click Update.  

10. Under the Output block table, click Review | Reset. The Review output block 

dialog opens, and displays the output requests you made. 

Note: This is the format used in the Abaqus input file (.inp).  
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11. Click Close to exit the Review output block dialog. 

12. In the first pane of the Load Step dialog, click Unsupported cards. 

13. Optional. Select the Unsupported cards checkbox to add any unsupported card.  

14. Click Close to exit the Load Step dialog and return to the Step Manager. The Step 

Manager dialog displays all of the information you defined for step1.  

 

15. Click Close to exit the Step Manager dialog. 

 

Steps 10-11: Export the database to an Abaqus 
input file 

The data currently stored in the database must be output to an Abaqus .inp file for use 

with the Abaqus solver.  The .inp file can then be used to perform the analysis using 

Abaqus outside of HyperMesh. 

Step 10: Export the .inp file 

1. From the menu bar, click File > Export > Solver Deck.  

2. In the File: field, enter job1.inp. 

3. To the left of Export Options, click . 

4. Set Export to all. 

5. Click Export. 
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Step 11: Save the .hm file and quit HyperMesh 

1. From the menu bar, click File > Save as > Model. 

2. In the Save Model As dialog, enter job1.hm as the file name. 

3. Click Save. 

 

Notes: 

• After you quit HyperMesh, you can run the Abaqus solver using the job1.inp file 

that was written from HyperMesh. 

• At your site, you can use the ABAQUS license to run this model. 

• If the batch mode option is being used, then enter the name of the .inp file 

exported in the previous step as the input file.  

• After you have successfully completed the analysis, the result file will be available in 

your working directory with the name <jobname.odb>. 

• Use HvTrans to translate the Abaqus solver result file to an H3D file.  

Step 12: Open HyperView from the Application Menu 

1. On the Client Selector toolbar, select HyperView.The HyperView environment 

displays. 

 

2. In the panel area, load the model and results files. 

Note: Load *.h3d files for both the model and result files. 
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3. Click Apply. 

4. On the Results toolbar, click  to open the Contour panel.  

5. Review displacement (v) results by setting the Result type to Displacement (v).  

 

6. Click Apply. 

 

7. In the Results browser, review steps and increments. 
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8. On the Animation toolbar, set the animation mode to linear. 

 

9. Review the animation by clicking . 

10. Review UR-Rotational displacement (v) results by setting the Result type to UR-

Rotational displacement (v) in the Contour panel. 

 

11. Click Apply. 

 

For additional tools and techniques, refer to the tutorial Pre-Processing for Bracket and 

Cradle Analysis using Abaqus - HM-4340. 
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