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HM-4310: Defining Abaqus Contacts for 2-D Models in HyperMesh 

In this tutorial, you will learn how to: 

• Load the Abaqus user profile and model 

• Start Abaqus Contact Manager 

• Define surfaces for 2D solid elements 

• Define surfaces by set 

• Define surface interaction property 

• Define contact pair 

 

Model Files 
 

 

This exercise uses the abaqus_contactManager_2D_tutorial.hm file, which can be found 

in <hm.zip>/interfaces/abaqus/. Copy the file(s) from this directory to your working 

directory. 

 

Exercise 
 

 

Step 1: Load the Abaqus user profile and model 

A set of standard user profiles is included in the HyperMesh installation.  They include: 
OptiStruct, Abaqus, Actran, ANSYS, LS-DYNA, MADYMO, Nastran, PAM-CRASH, PERMAS, 

and RADIOSS. While the user profiles change the appearance of some panels, they do not 

affect the internal behavior of each function. 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, set the user profile to Abaqus, Standard 2D. 

3. Open a model file by clicking File > Open > Model from the menu bar, or clicking  

on the Standard toolbar. 

4. In the Open Model dialog, open the abaqus_contactManager_2D_tutorial.hm file. 

The model appears in the graphics area. 

Step 2: Start the Contact Manager 

1. From the menu bar, click Tools > Contact Manager. The Abaqus Contact Manager 

opens. 
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Step 3: Define surfaces for 2D solid elements 

In HyperMesh, you can define the *SURFACE, TYPE=ELEMENT card by using individual 

element IDs or sets with corresponding face identifiers. In this exercise, you will create 

surfaces by defining individual 2D solid element IDs and corresponding faces.  

Follow the steps below to create the "frame-top" surface. 

1. In the Abaqus Contact Manager, click the Surface tab. 

2. Click New. The Create New Surface dialog opens. 

3. In the Name field, enter frame-top. 

4. Set Type to Element based. 

5. Click the box next to Color and select the desired color. 

 

6. Click Create. The Element Based Surface dialog for defining elements and 

corresponding faces for the surface opens. 

7. Click the Define tab.  
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8. Set Define surface for to 2D solid, axisymmetric, gasket. 

9. Under Select Elements, click Elements. 

10. In the panel area, click elems >> by collector. 

11. Select frame. 

12. Click select. The elements in the frame component highlight.  

 

13. Click proceed. 

14. In the Element Based Surface dialog, set Select edges by to Nodes on edge. 

15. Click Nodes.  

16. In the panel area, select two nodes from the top of a selected solid element as shown in 

the image below. 

 

17. Click proceed. 
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18. In the Element Based Surface dialog, enter 30.00 in the Break Angle field. 

19. Click Add. All of the edges of the selected solids that fall within the break angle of the 

edge defined by the two nodes are found. 

These edges are added to the current surface, and special contactsurface elements are 

created to show the normal direction of those elements. In the current example, they 

show towards the component slider, which is correct.  

 

20. Click the Adjust Normal tab to change the normal direction. The element normal 

should be adjusted towards the mating surface. 

 

21. Click the Delete Face tab to delete the edges that you do not want. 

 

22. When satisfied with the surface definition, click Close to return to the Abaqus Contact 

Manager. 
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Step 4: Define the surfaces by set 

In HyperMesh, you can define the *SURFACE, TYPE=ELEMENT card by using individual 

element IDs or sets with corresponding face identifiers. Using the steps below, you will 

create surfaces by defining a set and corresponding face identifiers.  

Complete the steps below to create the "slider-bot" surface: 

1. In the Abaqus Contact Manager, Surface tab, click Display None to turn off the 

display of all surfaces. 

2. Click New. The Create New Surface dialog opens. 

3. In the Name field, enter slider-bot. 

4. Set Type to Element based. 

5. Click the box next to Color to select the desired color. 

6. Click Create. The Element Based Surface dialog opens, and you can begin defining 

elements and corresponding faces for the surface. 

7. Click the Define tab.  

8. Set Define surface for to Element set.  

9. Set Element set to slider-bot.  

10. Click Review Set. All of the elements in the selected set highlight.  
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11. Right-click Review Set to reset the highlighting. 

12. Click the right arrow to move the slider-bot element set name into the table. 

13. In the Face column, select NoLabel. 

14. Click Update. A new dataline for ELSET slider-bot has been added to the *SURFACE 

card. By selecting NoLabel the face identifier has been left blank. 

 

15. Click Review to review the contents of the *SURFACE card. Right-click on Review to 

reset the highlighting. 

 

16. Click the Optional Parameters tab.  

17. Select the Trimming of open free surface checkbox and select YES.  
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18. Click Close to return to the Abaqus Contact Manager. In the Surface tab, the 
Display option for the slider-bot surface is disabled. At this point, you have created all 

the surfaces required.  

19. Click Display All to display all surfaces. 

 

20. Review surfaces by selecting them from the table and clicking Review. The selected 

surface will be highlighted with white and show up through the solid mesh when using 
performance graphics. If the surface is defined with sets (display option disabled), the 

underlying elements are highlighted. Right-clicking on Review will clear the 

highlighting. 

Step 5: Define the surface interaction property 

In this step, you will define the *SURFACE INTERACTION card with the corresponding 

*FRICTION card.  

Complete the steps below to create the "friction1" surface interaction. 

1. In the Abaqus Contact Manager, click the Surface Interaction tab. 

2. Click New. The Create New Surface Interaction dialog opens. 

3. In the Name field, enter friction1. 

4. Click Create. The Surface Interaction dialog opens. 

5. Click the Define tab.  

6. Set Select mechanical interaction properties to Friction. 
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7. Click the Friction tab. 

8. Set Friction type to Default. 

9. In the second pane, select Direct. 

Note: Selecting this option means that the exponential decay and Anisotropic 

parameters will not be written to the input file.  

 

10. In the No of data lines field, enter 1. A single row displays in the Direct table. 

11. In the Friction Coeff column, click the first cell and enter 0.05. 

For Direct and Anisotropic tables:  

• Change the number of columns in the table by specifying a value in the No of 

Dependencies field; change the number of rows in the table by specifying a value 

in the No of data lines field. 

• Enter values in the table by clicking a cell to make it active and then typing in 

values. The table works like a regular spreadsheet. 

• Read comma-delimited data from a text file by clicking Read From a File. In the 

file browser, select a file and click Open to export the comma-delimited data. The 

row number will be set to the number of data lines found in the file. 

• Access copy, cut, and paste options by right-click in the table. Comma-separated 

data can be copied/cut into or pasted from clipboard with these options. Relevant 

hot keys (for example, Ctrl-C, Ctrl-X and Ctrl-V in Windows) will also work. 

• Activate cells by left-clicking in a cell. Clicking into an already active cell moves the 

insertion cursor to the character nearest the mouse. 

• Highlight cells by left-clicking while moving the mouse over a cell. 

• Move the active cell using the left, right, up, and down arrows. 

• Extend the selection in a specific direction using SHIFT-<arrow>. 

• Move the insertion cursor within a cell using CTRL-left arrow and CTRL –right 

arrow. 

• Selects all cells using CTRL -slash. 

• Delete the character before the insertion cursor in the active cell using BACKSPACE. 

If multiple cells are selected, BACKSPACE deletes all selected cells. 
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• Remove the character after the insertion cursor in the active cell using DELETE. If 

multiple cells are selected, DELETE removes all selected cells. 

• Move the insertion cursor to the beginning of the active cell using CTRL-A. Move the 

insertion cursor to the end of the active cell using CTRL-E. 

• Decrease and increase the width of the column with the active cell in it using CTRL-

minus (-) and CTRL-equal (=). 

• Interactively resize a row or column by left-clicking or right-clicking on a border 

while moving the mouse. 

 

11. Click OK to go back to the Abaqus Contact Manager. 

Step 6: Define the contact pair 

In this step, you will define the *CONTACT PAIR card with corresponding surfaces and 

surface interactions.  

Complete the steps below to create the "slider-frame" contact pair. 

1. In the Abaqus Contact Manager, click the Interface tab. 

2. Click New. The Create New Interface dialog opens. 

3. In the Name field, enter slider-frame. 

4. Set Type to Contact pair. 

5. Click Create. The Contact Pair dialog opens. 

6. Click the Define tab.  

7. Set Surfaces to slider-bot. 
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Note: Clicking New opens the Create New Surface dialog, from which a new 
surface can be created. When you are done creating and defining the surface, 

the Contact Pair dialog will return with the new surface selected as the slave 

surface. 

To ensure that you are dealing with the right surface, click Review. The 
selected surface is highlighted in red, while the rest of the model is grayed out. 

Right-click on Review to clear the highlighting. 

8. Click Slave>> to move slider-bot into the table as the slave surface.  

9. Repeat steps 7 and 8, selecting frame-top and clicking Master>> to move it into the 

table as the master surface. 

Note: To more clearly see the surfaces available for selection, click . This opens an 
enhanced browser where you can easily search for the appropriate item. You 

can also click Filter to filter the items displayed. 

 

10. Set Interaction to friction1, which is the interaction property for the current contact 

pair. 

Note: To more clearly see the interaction available for selection, click . This opens 
an enhanced browser where you can easily search for the appropriate item. 

You can also click Filter to filter the items displayed. 

11. Click the Parameter tab.  

12. Select the Small sliding checkbox. 

13. Click OK to go back to the Abaqus Contact Manager. 
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14. At this point, you have created the contact pairs required. Review any contact pair by 
selecting it from the table and clicking Review. The master surface is displayed in blue, 

the slave surface is displayed in red, and the rest of the model is shown in grey. If a 
surface is defined with sets (display option disabled), the underlying elements are 

highlighted. Right-clicking on Review will clear the highlighting. 

 

15. Click Close to close the Abaqus Contact Manager. 

 

General comments: 

• Click Edit to open the dialog for editing the selected interface, surface, or surface 

interaction 

• Click Delete to remove the selected interfaces, surfaces, or surface interactions. 

Multiple selections can be removed from the Interface table at once. 

• Click Sync to update the Contact Manager with the current HyperMesh database. If 

you create, update, or delete any components, groups, properties, or entity sets 
from HyperMesh panels while the Contact Manager is open, click Sync to update 

the Contact Manager. 

• If you minimize the Contact Manager dialog or if it goes behind HyperMesh, click 

Tools > Contact Manager to restore it. 

• Bubble help exists for important buttons. Place the mouse on the buttons for a few 

moments to view it. 

• Double-click on interface, surface, and surface interaction names in the table to open 

the corresponding edit dialog. Right-click on these names to display a pull down 

menu with options. 

• Left-click or right-click on a table border while moving the mouse can resize columns 

in a table. 

• SHIFT and CTRL keys can be used while left-clicking to select multiple items in a 

table (useful for deleting multiple items).  
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