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HM-4020: Obtaining and Assigning Beam Cross-Section Properties using 
HyperBeam 
 

In this tutorial you will learn how to: 

• Obtain beam section properties for various types of beam cross-sections using 

HyperBeam, a module within HyperMesh 

• Populate the fields of property collectors with beam properties 

• Assign a property collector to a beam element you create 

 

In FEA, beams are typically modeled as 1D elements. In this tutorial you will become 
familiar with the modeling of beam sections for 1D elements (beam, bar, and rod) in 

HyperMesh. The focus is on obtaining and assigning beam-section properties, not on 

creating beam elements themselves.   

 

Model Files 
 

 

This exercise uses the hyperbeam.hm file, which can be found in the hm.zip file. Copy the 

file(s) from this directory to your working directory. 

  
Model geometry 

The model geometry represents different types of cross-sections used in this tutorial: 
standard, shell, and solid. The model consists of a solid cylinder attached to a hollow 

trapezoidal structure, which is further joined to an irregularly shaped solid component (see 

previous image). 
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Exercise: Obtaining and Assigning Beam Cross-Section Properties 

using HyperBeam 
 

 

Step 1: Load the OptiStruct user profile. 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, select OptiStruct. 

3. Click OK. 

Step 2: Retrieve and view the file, hyperbeam.hm. 

1. Open a model file by clicking File > Open > Model from the menu bar, or clicking  

on the Standard toolbar. 

2. In the Open Model dialog, open the hyperbeam.hm file. A model appears in the 

graphics area. 

Note: This model's geometry represents different types of cross-sections: standard, 

shell, and solid. In the following step you will create a standard circular section 
to represent the cross-section of the cylinder, a shell section with lines to 

represent the cross-section of the hollow trapezoidal feature, and a solid 

section with lines to represent the cross-section of the solid irregular feature. 

This model is organized into four collectors: one contains all of the surfaces, 

two contain the lines for the shell-section and the solid-section, respectively, 

and the last component stores beam elements. 

Step 3: Model a standard circular section using HyperBeam. 

In this step, use the standard section subpanel in the HyperBeam panel to quickly model 

a solid circular section.  

In order to define a circular cross-section, HyperBeam requires the diameter of the cross-
section as input. Measure the diameter of the section before invoking HyperBeam using the 

Distance panel from the Geom page.  

1. Use the nodes panel to create three nodes on the circle defining the base of the solid 

cylinder. 

• From the menu bar, click Geometry > Create > Nodes  > Extract on Line. 

• Using the lines selector, select the circular line defining the base of the cylinder. 

• In the number of nodes field, enter 3. 

• Click create. HyperMesh generates three nodes on the line, two of which are 

located at the same location (since the circular line is a line that closes upon itself).  

• Click return. 

Note: With the two independent locations left, you can measure the diameter. 
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Nodes on circle to measure diameter 

2. Use the Distance panel to measure the distance between the two nodes diametrically 

opposed. 

• From the menu bar, click Geometry > Check > Nodes > Distance. 

• Go to the two nodes subpanel. 

• Use the N1 and N2 selectors to select the two nodes, which are diametrically 

opposed, on the circular line that defines the base of the cylinder. The distance= 

field reads 110 units, which indicates the distance between the two nodes and the 

diameter of the circle. 

• Click return. 

3. Use the HyperBeam panel to create a solid circle standard section. 

• From the menu bar, click Properties > HyperBeam. 

• Go to the the standard section subpanel. 

• Set the standard section library to HYPERBEAM. 

• Set the standard section type to solid circle. 

• Click create. The HyperBeam module opens with a solid circle cross-section 

displayed in the center panel. The left pane (HyperBeam view) lists the cross-

sections defined in the model, and the right pane (Results window) displays the 

results for the various beam properties computed for the dimensions displayed. 
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HyperBeam window (standard section) 

4. Modify the diameter of the cross-section. 

• Under Parameter Definition, click the Value field next to Radius (r). 

• In the editable field, enter 55 and then press ENTER. The value of the diameter 

updates, along with the quantities computed for the cross-section in the Results 

window. These properties are calculated based on the dimensions that were input. 
For example, HyperBeam calculates the area of this cross-section, its moments of 

inertia, and its torsional constant. 

Note: Alternatively, drag the graphical handles, which represent the diameter of the 

cross-section, until the diameter changes to the desired value. 

5. Assign the name “Solid Circle” to this cross-section in the HyperBeam view. 

• In the HyperBeam view, right-click on the name of the cross-section under the 

auto1 folder and select Rename from the context menu. 

• In the editable field, enter Solid Circle and press ENTER. 

6. Return to HyperMesh by clicking File > Exit from the menu bar. 

The information that was computed is automatically stored in a beamsect collector with 
the name you specified for the section. This beamsect collector will later be used to 

populate the fields of a property card. 
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Note: Since geometry information was available, this cross-section could have been 

defined as a solid section using the solid section subpanel. A standard section 

was used instead because it did not require selection, although it required a 

diameter measurement. 

You may save your HyperMesh model to your working directory at this point. 

In this step, a beam cross-section for standard sections was created using HyperBeam. 

You also learned how to specify the dimensions for the standard section, and how to 

save this section for subsequent use. 

Step 4: Model a shell section. 

In this step, use the shell section subpanel of the HyperBeam panel to model a beam 

section for the trapezoidal feature of the geometry.  

Use the lines in the pre-defined component shell_section to define the section. These lines 

are located at the mid-plane of the trapezoidal geometry. In addition to these lines, 
HyperBeam also requires the thickness of the feature as input to calculate the shell section 

properties.  

  
Shell section lines 

Use the various panels, such as the Distance panel, to find the thickness of this feature. 

The thickness of the feature is equal to 2 units. 

1. Create a shell section using the lines in the shell_section component. 

• From the menu bar, click Properties > HyperBeam.  

• Go to the shell section subpanel. 

• Set the entity selector to lines. 

• Click lines >> by collector. 

• Select the collector, shell_section. 

• Click select.  

• Set cross section plane to fit to entities. 

• Set section based node to plane base. HyperMesh activates the base node 

selector. 
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• While left-clicking, move the mouse on top of one of the mid-plane lines as shown 

in the image above. Click anywhere on the highlighted line to define the base node. 

• Set part gen to auto. 

• Click create. The HyperBeam module opens. 

Note: The cross section plane option allows the software to define the plane for 
calculating beam cross-sectional properties based on the entity (lines/element) 

selection.  A user-controlled plane can also be defined by changing the cross-

section plane using the toggle. 

When using the fit to entities option, you can select a reference node for the 
plane if you want properties about a point other than the section centroid. This 

is done using the section base node option. This node defines the origin of 

the coordinate system that serves as the reference when computing the 
various beam cross-section properties. All the properties are calculated both 

about the centroid and about the node you select. 

  
Shell section 

The coordinates of the centroid are calculated with respect to the user-defined 

coordinate system appearing at the node location specified earlier. The coordinates of 
the shear center are calculated both from the centroid and from the origin of the 

section. Local Ys and Zs are the coordinates of the shear center with respect to the 
origin of the section, while principal Vs and Ws are the coordinates of the shear center 

from the centroid of the section.  
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2. Modify the thickness of the cross-section and assign it a value of 2 units. 

• In the Model browser, right-click on shell_section.1 and select Edit from the 

context menu. The Edit Shell Section dialog opens. 

 

• In the Part thickness field, enter 2. HyperMesh updates the values for the beam 

properties computed in the Results window. 

• Click Update. 

• Click Exit to close the dialog. 

3. Rename the section, “Trapezoidal Section.” 

4. Exit the HyperBeam module by clicking File > Exit from the menu bar. 

In this step, a beam cross-section representing a shell section was created using 
HyperBeam, and the thickness for the shell section was assigned. The shell section is 

defined with only one thickness as it is defined as one part. For shell sections comprised 

of multiple parts, each part is assigned an independent thickness. 

You may save your model to your working directory. 

Step 5: Create a solid section using surfaces. 

In this step, model the irregular solid feature of the geometry as a solid section using the 

solid section subpanel of the HyperBeam panel.  

The input for a solid section can be 2D elements, surfaces, or a set of lines that form a 

closed area. Use the surfaces in the solid_section collector to define the solid section.  

1. Create a solid section using the surfaces in the solid_section component. 
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• In the HyperBeam panel, go to the solid section subpanel. 

• Set the entity selector to use surfs. 

• Select the highlighted surface in the following image. 

• Set section base node to base node. 

• Click base node. 

• While left-clicking, hover over a line or the surface until the surface highlights. Click 

anywhere on the highlighted entity to select a base node. 

 

Defining the solid section 

• Set analysis type to first order. 

This option tells HyperBeam to use first order (linear) elements to calculate the 

properties of the section.  

• Click create. The HyperBeam module opens, meshes the area enclosed by the 

selected curves with quadrilateral elements, and calculates the properties using 

these elements.  

 

Solid section 
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2. Rename the section "Solid Section" and save your data. 

3. Exit HyperBeam and save your data. 

Step 6: Assign beam properties to a property collector and a beam 

element. 

In HyperMesh, you can assign the beam properties computed in HyperBeam and stored in a 
beamsect collector to your solver beam property card. To achieve this, create a property 

collector with the solver beam property card of interest, and assign the beamsect collector 

to the property collector. 

When creating an actual beam element, assign the property collector to the element itself. 

1. Create a property collector with a PBEAM card and assign the Solid Circle beamsect 

collector to it. 

• Create a property collector by right-clicking in the Model browser and selecting 

Create > Property from the context menu. HyperMesh displays the property in 

the Entity Editor. 

• Name the property standard_section. 

• Set the Card Image to PBEAM. 

• Assign the Material as steel. 

• Assign the Beam Section as Solid Circle. 

The properties calculated using HyperBeam are automatically assigned to the PBEAM 
card. Observe that the values of the parameters (A, I1a, I2a, I12a, J, etc.) are 

extracted from the properties of the selected section. 

2. Use the Bars panel to create a beam element with the standard_section property 

assigned, and a direction vector set to the global x-axis. 

• From the menu bar, click Mesh > Create > 1D  

• Elements > Bars  

• Click property = and select standard_section. 

• Click the lower-left switch and select vectors as the option to define the orientation 

of the beam. 

• Set the orientation selector to x-axis. 

• Activate node A. 

• While left-clicking, hover over the line that runs though the cylinder until it is 

highlighted. Select two nodes at the ends of the line for node A and node B. 

  
Creating a beam element 
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The beam element is created and placed into the beam component. 

Note: When creating beam elements, the z-axis is defined by the two nodes selected 

as node A and node B. The direction of the cross-section (x- or y-axis) is 
defined either by using components, vectors, or a direction node. Due to the 

nature of this solid circle, how you define the x- or y-axis is unimportant. 

Changes made to a beamsect collector (for example, through editing of a cross-section) 

are also automatically applied to any property collector referencing this beamsect 

collector. 

Step 7 (Optional):  Save your work. 

Summary 

In this tutorial, you experimented with the tools and techniques for modeling beam cross-

section and obtaining their properties using HyperBeam. You learned how to edit cross-
sections and assign their properties to property collectors, which can then be assigned to 1-

D elements. 

For more details on how to create 1-D elements, review the tutorial, Creating 1-D Elements. 

Additional techniques for creating 1-D elements from connector entities are discussed in the 

tutorial, Creating Connectors. 
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