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HM-3440: Model Build and Assembly

In this tutorial, you will learn how to:
e Import a PLMXML file.

e Load and create a Common representation and NVH representation for modal
analysis

e Import connector parts, add connector representations, and realize connectors
e Edit part attributes using the Entity Editor to reflect design changes

e Activate configurations

e Import and Export an assembly as a Solver Deck

¢ Renumber entities using the ID-Manager

e Check for errors using the Model Checker

Model Files

This exercise uses the files located in the HM-3440 folder, which can be found in the hm.zip
file. Copy the file(s) from this directory to your working directory.

Exercise

Step 1: Start HyperMesh Desktop and Load the OptiStruct User
Profile

1. Start HyperMesh Desktop.
2. In the User Profile dialog, select OptiStruct.
3. Click OK.

Step 2: Import the PLMXML File
1. Open the Import - BOM tab by clicking File > Import > BOM from the menu bar.

2. In the File field, open the BoM input.xml file.
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3. Click Import. Part assemblies and parts are imported into the session.

p.2

Part Assemblies/Parts
- [ Model
1.F Underbody_000425_Safety
+-[@ Connectors_000481
-8 Center_Rails_000452
B Center_Rail_Connectors_varl_000484

----- B Center_Rail_Connectors_var2_000485

-l Longitudinal_Rails_000497
] Longitudinal_Rails_Connectors_000486
~[{@ Frame_Assembly_000495

g LefiRail_A_000433_Safety

-~ Lefinner_A_000434_Safety

----- B LeftOuter_A_000435_Safety

-3 RightRail_A_000436_Safety

[ Rightinner_A_000437_Safety

----- B RightOuter_A_000438_Safety
=-[[@ CenterRail_A_000426_Safety
CenterRail_varl_A_000427_Safety
B Centerlnner_A_000428_Safety
B CenterOuter_A_000429_Safety
CenterRail_var2_A_000430_Safety
~[ Centerlnner_var2_A_000431_Safety []

-

EDE DS S SIS ESIEEEEEEE®

----- B CenterOuter_var2_A_000432_Safety [l

(9]10]

Underbody
Connectors

Center_Rails

Center_Rail_Connectors_varl

Center_Rail_Connectors_var2

Longitudinal_Rails

Longitudinal_Rails_Connectors

Frame_Assembly
LeftRail_A
Leftinner_A
LeftOuter_A
RightRail_A
Rightinner_A
RightOuter_A
CenterRail_A
CenterRail_varl_A
Centerlnner_A
CenterQuter_A
CenterRail_var2_A
Centerlnner_wvar2_A

CenterQuter_var2_A

Revision Representation Active

A

=

NSNS EEES

Step 3: Load and Create a Common Representation

Steps 3.4 - 3.6 below are optional as the Common representation can be created without
loading the CAD into the session. Since the Common representation forms the basis of
subsequent discipline specific mesh representations, its creation is a prerequisite for the

next steps.

1. Open the Part browser by clicking View > Browsers > HyperMesh > Part from the

menu bar.
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2. In the Part browser, right-click and on one of the column headers and enable the
following columns from the context menu: PDM PID, PDM MID, PDM Material, PDM

Thickness, and PDM MeshFlag.

These columns show the PDM metadata that is parsed upon importation of the PLMXML

file. This information is also shown in the Entity Editor, PDM Data pane.

PDM PID PDM MID PDM Material PDM Thickness PDM Meg
D

Color

(W][n]

Rewision
Representation
Active

CID

PID

MID

Material

Thickness

r OONFSEEESSEEEEEEEDT

101 PDMPFID 27

102 POM MID 27
PDM Material

107 PDM Thickness 25

104 PDM Mesh Flag 55
PDM Variant Condition

201 PDM Variant Scope 17

20; Al [ferme 15

301 10 Steel 17

302 10 Steel 15

3. Right-click on the Frame_Assembly_000495 part assembly and select
Representations > Load > from Session from the context menu.

4. In the Change Representations dialog, Load tab, select the CAD representation.

@ Change Representation

Create Load Library

Representations
@ caD

Farts &

>

Available
848

BatchMesh Unavailable
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5. Click OK. All available CAD representations are imported into the session.

=

Part Assemblies/Parts € uUD Revision Represe
-li@ CenterRail_A_000426_Safety B CenterRail_A A
: ¥ CenterRail_var1_A_000427_Safety @ CenterRail_varl_A A

- Centerlnner_A_000428_Safety B Centerlnner_A A- CAD
[Ijﬂ Center_Inner (]
- CenterOuter_A_000429_Safety [ CenterOuter_A A- CAD
: [Ijlﬂ Center_Outer 1]
- B CenterRail_var2_A_000430_Safety B CenterRail_var2_A A
- Centerlnner_var2_A_000431_Safety [] Centerlnner_var2_A
@ Center_lnner_var2 1]
-l CenterOuter_var2_A_000432_Safety I CenterD
@ B Center_Outer_var2 0
-Ip LeftRail_A_000433_Safety I LefiRail_A
-~ Leftinner_A_000434_Safety W Lefinner_A
@B Left_lnner @
- LeftOuter_A_000435_Safety [ LeftOuter A A- CAD
. @@ Lef_Outer m
~[@ RightRail_A_000436_Safety Il RightRail_A A
-~ Rightinner_A_000437_Safety [ Rightinner_A A- CAD
‘. g B Right_Inner o
B RightOuter_A_000438_Safety m RightQuter_A A- CAD
B Right_Outer O

6. Right-click on the Frame_Assembly_000495 part assembly and select
Representations > Create from the context menu.

7. In the Change Representations dialog, Create tab, select Common (0/8).

G Change Representation X

Create |pad Library

W Representations Available
Commaon 08
[ Crash&mm 0/
O] Crash 10mm 0/
[T Durahility G 0/
[ rMvH10mm 0/
[ rMvH1Smm 0/
[l TetraGmm 0/

| 1 of 7 selected

Midsurface method | Skin "l Save to Library

4 | -
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8. Click OK. Available CAD representations are sent to the BatchMesher for processing.

Note: In the case of sheet metal parts, the BatchMesher extracts the midsurface from
the solid CAD representation. You can choose a Midsurface method, include
Skin, Offset, Offset + Planes, Offset + Planes + Sweeps.

i BatchMesher - O 4
File Help
Run Setup Configurations User Procedures
MName Geom Type Mesh Type Status
. Run Status 73
- Run 1 Results in - C:\Users\Documents\bm_190113_001
- # Pre-Run procedure Done ’E
- # Left_Inner.jt Auto Common Done
- Left_Outer.jt Auto Comman Done
- # Right_Inner.jt Auto Comman Done
- # Right_Outer.jt Auto Comman Done
- % Center_Inner.jt Auto Commaon Done
- & Center_Outer.jt Auto Common Done
- % Center_Inner_var2.jt Auto Common Done
- % Center_Outer_var.jt Auto Common Done
- # Post-Run procedure Working
Load Mesh Details Run Details | Quality Report Pause Resume Now | Resume At: | 1/13/19 105 Cancel
Check the status of mesh jobs.

9. In the BatchMesh dialog, click Yes to load the new representations for the eight parts.
10. Repeat steps 3.7 - 3.10 to create NVH10 and NVH15 representations.

Step 6: Add Connector Representations

1. In the Part browser, right-click on the Connectors_000481 part assembly and select
Representations > Load > from Session from the context menu.

2. In the Change Representation dialog, Load tab, select the Connector
representation.

@ Change Representation X
Create Load Library
Representations Available
@ Connector a3
Farts & BatchMesh Unavailable
Cancel

/4 | -
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3. Click OK. Connectors are loaded, and the Representation column shows the Connector

representation loaded.

Part Assemblies/Parts ) €
- & Model ]
- Underbody_000425_Safety
+-f@ Connectors_000481
+-[@ Center_Rails_000482
: ~[ Center_Rail_Connectors_| %
: [ Center_Rail_Connectors_var2

--f@ Longitudinal_Rails_000497 I

@ Longitudinal_Rails_Connectors_000486 [
--F@ Frame_Assembly_000495 i

Step 7: Design change - modify Center Rail part attributes

1. In the Part browser note the PID of parts CenterInner_var2_A_000431_Safety and

CenterOuter_var2_A_000432_Safety.

Part Assemblies/Parts
- [JE Model
--[7 Underbody_000425_Safety
*?:] Connectors_000481
- Frame_Assembly_000495
@ CenterRail_A_000426_Safety

+-fi@ CenterRail_varl_A_000427_Safety
--[@ CenterRail_var2_A_000430_Safety

© uD
(1|

[ Underbody

B Connectors

B Frame_Assembly
B CenterRail_A

[ CenterRail_varl A
Il CenterRail_var2 A

Revis... Representation |Active CID| PID

A
A
A
A
A

A

FFI ‘Centerlnner_va r2_A_000431_Safety

] Centernner_var2_A

A-3 NVH15mm

103|103

/B CenterOuter_var2_A_000432_Safety

I CenterOuter_var2_A

A-3 NVH 15mm

104|104

-3 LeftRail_A_000433_Safety
-[@ RightRail_A_000436_Safety

I LeftRail_A
I RightRail_A

A
A

FEEGEEEEEEE

2. In the Model browser, switch the view mode to Properties.
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3. Select PID 103 and 104. The EntityEditor opens and displays the two properties
common corresponding attributes.
% Properties ID @ Include Defined Type Cardlmage | Thickness MID Material Type |Material
i& Lefiinner_A p01 201 0 2D PSHELL 17 10 ISOTROPIC  Steel
i LeftOuter_Ap01 202 @ 0 2D PSHELL 15 10 ISOTROPIC  Steel
% Rightinner_A p01 301 0 2D PSHELL 17 10 ISOTROPIC  Steel
i RightOuter_A.p01 302 0 2D PSHELL 15 10 ISOTROPIC  Steel
% Centerlnner_A p01 101 W 0 2D PSHELL 27 10 ISOTROPIC  Steel
i CenterOuter_A.p01 102 0 2D PSHELL 27 10 ISOTROPIC  Steel
4 Centernner_var2_Ap01 103 [ 0 2D PSHELL 25 10 ISOTROPIC  Steel
4z CenterOuter_var2_Ap01 104 [ 0 2D PSHELL 25 10 ISOTROPIC  Steel

Name
Solver Keyword
Color
Include
Defined
Card Image
Material
User Comments
-
MID2
MID2_opts
n2_T3
MID3
MID3_opts
T5_T

RICHKA

Value

PSHELL

[l |

[Master Model]
PSHELL

(10) Steel

Hide In Menu/Export
25

10

(]

10
]

nn

In the Entity Editor, T field, enter 3.0.

In the Part browser, notice the attribute modification you made is updated in the
Thickness columns. Save these changes to ensure that they are available if the current
representation is unloaded.

-

Part Assemblies/Pars @ UD Revis... Representation |Active CID PID MID Material Thickness P
- & Model (1|
*E---—_] Underbody_000425_Safety [ Underbody A
B Connectors_000481 B Connectors A
Frame_Assembly_000495 W Frame_Assembly A
+ [ CenterRail_A_000426_Safety B CenterRail_A A
CenterRail_varl_A_000427_Safety [ CenterRail_varl_A A
CenterRail_var2_A_000430_Safety B CenterRail_var2_A A
*kl Centerlnner_var2_A_000431_Safety [| Centerlnner_var2_A A-3 NVH 15mm 103 103 10 Steel 3.000000
h{:l CenterQuter_var2_A_000432_Safety [l CenterOuter_var2_A  A-3 NVH 15mm 104 104 10 Steel 3.000000
LeftRail_A_000433_Safety W LefRail_A A
+-[ RightRail_A_000436_Safety B RightRail_A A
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Step 8: Create Part Sets

Create part sets Varl and Var2 for Variant 1 and Variant 2 in the Part Set view.

1. In the Part browser, enable the Part Set view.

Model Part x

LN E

2. Create two part sets.

a. In the Part Set view, right-click and select Create > Part Set from the context
menu.

b. Name the part sets Varl and Var2.

3. Group common and unique parts by dragging-and-dropping parts from the Part view
onto the part set.

Var 1:
e Center_Rail_Connectors_varl_000484
e Centerlnner_A_000428_Safety
e CenterOuter_A_000429_Safety

e Center_Rail_Connectors_var2_000485
e CenterInner_var2_A_000431_Safety
e CenterOuter_var2_A_000432_Safety

Part Sets & UD  ®PartAssemblies/Parts € UuUD
i Varl - [ Model (]

[ Center_Rail_Connectors_var1_000484 [ Center_ +.[5§ Underbody_000425_Safety M Undq

-l Centerlnner_A_000428_Safety B Centerl * ¥ Connectors_000481 B Conr

- CenterQuter_A_000429_Safety [ Center( . § Frame_Assembly_000495 B Fran

*LE- Var? v B CenterRail_A_000426_Safety B Cent

- Center_Rail_Connectors_var2_000485 [l Center_ ¥ CenterRail_varl_A_000427_Safety [0 Cent

-l Centerlnner_var2_A_000431_Safety [] Centerls T | CenterRail_var2_A_000430_Safety Il Cent

- CenterOuter_var2_A_000432_Safety [l Center( “ J LeftRail_A_000433_Safety [ LefiF

.- RightRail_A_000436_Safety W Righ

Step 9: Create Configurations

Create configurations Varl and Var2 for part sets Varl and Var2 in the Configuration view.

1. In the Part browser, enable the Configuration view.

Model Part x

L1 L0

2. Create two configurations.

/4 | -
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3. In the Part Set view, right-click and select Create > Configuration from the context

menu.

Name the configurations Varl and Var2.

5. Group part sets that are unique by dragging-and-dropping part sets from the Part Set
view onto the configuration.

a. Group the Varl part set into the Var 1 configuration.

b. Group the Var2 part set into the Var 2 configuration.

Configurations | @ UID Active
@& Varl ]

Part Sets
T---nﬂl Varl

- o Var2

- Center_Rail_Connectors_var1_000434 [l Cer
-l Centerlnner_A_000428_Safety
- CenterQuter_A_000429_Safety

* Part Assemblies/Parts € U
~ & Model (1|

«.[5§ Underbody_000425_Safety mvu

+[§ Connectors_000481 lc

--[[§ Frame_Assembly_000495 | 3

¥ B CenterRail_A_000426_Safety lc

© uD ~ +-F@ CenterRail_varl_A_000427_Safety [ C

= B CenterRail_var2_A_000430_Safety [l C

@ LefiRail_A_000433_Safety mL

W Cer .- RightRail_A_000436_Safety [ =
[ cer

- Center_Rail_Connectors_var?_000485 [ Cer
- Centerlnner_var2_A_000431_Safety [ Cer
-~ CenterOuter_var?_A_000432_Safety [l Cer

Step 10: Activate the Var 2 Configuration

1. In the Part browser's Configuration view, Active column, enable the checkbox for

Var 2.

All of the parts, part assemblies, components, and part sets

become inactive.

not associated with Var 2

Configurations @ UID Active

@ Varl =
C L Van
i & Var2

L@ var
Part Sets [ %)
& Varl
. Center_Rail_Connectors_varl_000434 W

Centerlnner_A_000428_Safety 1 ]

CenterOuter_A_000429_Safety (]
- db Va2

B Center_Rail_Connectors_var?_000485 [
B Centerlnner_var2_A_000431_Safety [
B CenterOuter_var2_A_000432_Safety [l

* Part Assemblies/Paris

- & Model
.7 Underbody_000425_Safety
v # Connectors_000481
; @ Center_Rails_000482

: @ Longitudinal_Rails_000497

i # Frame_Assembly_000495

B CenterRail_A_000426_Safety

' CenterRail_varl_A_000427_Safety

Centerlnner_A_000428_Safety

CenterQuter_A_000429_Safety
i CenterRail_var2_A_000430_Safety

-~ LefiRail_A_000433_Safety

@ RightRail_A_000436_Safety

EEEE®

Center_Rail_Connectors_varl_000434 Wl
& | Center_Rail_Connectors_var?_000485 [l

SEEEOSECOEEE

uiD

Underbody

Connectors

Center_Rails
Center_Rail_Connectors_varl
Center_Rail_Connectors_var?
Longitudinal_Rails
Frame_~Assembly
CenterRail_A
CenterRail_varl_A
Centerlnner_A

CenterQuter_A
CenterRail_var2_A
LeftRail_A

RightRail_A

Revision Representation Active

A

A

A
A- Connector m
A- Connector
A

A

A

A (a]
A-3 NVH 15mm ]
A-3 NVH 15mm ]
A

A

A
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Step 11: Export Assembly as a Solver Deck

1.

Open the Export — Solver Deck tab by clicking File > Export > Solver Deck from
the menu bar.

In the File field, enter frame var2 model.fem.
Under Export Options:

e Set Export to Custom to ensure that inactive parts are not written to the solver
deck.

e Under Comments, select the Part Assemblies/Parts checkbox.
Click Export.

Save the model as frame assembly.hm.

Step 12: Import Assembly Solver Deck

1.
2.

Start a new HyperMesh Desktop session.

Open the Import — Solver Deck tab by clicking File > Import > Solver Deck from
the menu bar.

In the File field, locate the frame var2 model.fem solver deck.
Click Import.
In the Part browser, verify that the BOM was imported correctly.

Note: All part assembly and part metadata in the original model should be present,
with the exception of the Representation name.

Step 13: Import Realizations

1.

2.
3.

Proprietary Information of Altair Engineering

Open the Import - Model tab.

Click ¥, then open the Realizations.hmn file.

The Spotweld component, in the Realizations.hn file, references a material that has
the same ID as a material that already exists in the current session, therefore under

Entity Management, set Materials to Keep Existing Attributes.

Name Value
Solver Keyword PLSOLID
Name Spotwelds
D 500
Color ]
Include [Master Model]
Defined v
Card Image PLSOLID
Material (10) Steel
User Comments Hide In Menu/Export

p.10
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Click Import. Connector parts are imported.

Step 14: Realize Connectors

1. In the Part browser, right-click on the Spotwelds component and select Make Current
from the context menu.

2. In the Part browser, right-click on the Longitudinal_Rail_Connectors and select Hide
from the context menu. The display of the component’s connectors is turned off in the
graphics area enabling you to get a better visual of each component's connectors.

3. Open the Connector browser by clicking View > Browsers > HyperMesh >

Connectors from the menu bar.
In the Connector Entity browser, select the acm (shell gap) connector folder.

In the Entity Editor, set Property Script to no/skip post script.

In the Connector Entity browser, select all of the connectors.

Note: Connector links are defined via Parts to ensure that connectors realize even if
you, accidentally, renumber all of the entities in the model.
Entities Layer Telerance Linkl Link2 Link]
= | § acm [shell gap] [136]
~() 100000 2 20.0 B CenterDuter_A_000429_Safety B Certerlnner_~_000428_Safety
10000 2 200 B CenterDuter_A_000429_Safety B Centerlnner_&_000428_5afety
100002 2 200 B CenterDuter_A_000429_5 afety B Centerlnner_&_000428_5 afety
100003 2 200 B CenterDuter_&_000429_Safety B Certerlnner_A_000428_Safety
100004 2 200 B CenterDuter_A_000429 Safety B Certerlnner_f_000428_Safety
100005 2 200 B CenterDuter_A_000429_Safety B Centerlnner_&_000428_5afety
100006 2 200 B CenterDuter_A_D00429_Safety B Centerlnner_&_000428_5 afety
100007 2 200 B CenterDuter_A_000429_Safety B Certerlnner_~_000428_Safety
100002 2 200 B CenterDuter_A_000429 Safety B Certerlnner_f_000428_Safety
100009 2 200 B CenterDuter_A_000429_Safety B CenterDuter_var2_A_000432_5 afety
100010 2 200 B CenterDuter_&_000429_Safety B CenterOuter_var?_4_000432_S afety
100011 2 200 B CenterDuter_A_000429_Safety B CenterOuter_var?_A_000432_S afety
100012 2 200 B Centerlnner_var2_g_000431_Safety [l Centerlnner_a_000428_Safety
() 100013 2 200 B Centerlnner_var?_4_000431_Safety [l Centerlnner_4_000428_Safety
S d000dd o 200 m_C bl 2 000499 O k) . kol 000420 O —f -}

Right-click on the selected connectors and select Rerealize from the context menu.

In the Part browser, right-click on the Spotwelds part and select Isolate Only from the
context menu. Verify that the realized FE resides in the Spotwelds component.

Step 15: Renumber Nodes and Elements

Open the ID-Manager by clicking Tools > ID-Manager from the context menu.

2. In the ID-Manager, select Components, Properties, and Materials then right-click
and select Exclude from the context menu.

Entities
B 92 Master Model

Ed Modes
B Elements
& Components

s Properties
I Materials

1D Excluded Min
1]

4k 4t
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3. For the Master Model, enter 1,000,000 in the Min field and 1,500, 000 in the Max field.

b an

Entities ID E ®izluded bir
£ az: Master Model 0 1000000
- [ Nodes 1000000
[ Elements 1000000
a@ Components ®
> fi Properties 4
L e Materials =®

1500000
1500000
1500000

#0verflow kMin Reserved Max Re
24682

12671
12011

4. Correct ID overflow by right-clicking on the Master Model and selecting Correct >

Overflow from the context menu.

Step 16: Run the Model Checker

1. Open the Model Checker by clicking Tools > Model Checker > OptiStruct.

2. In the Model Checker, right-click and select Run from the context menu.

3. Verify that the model is error free.

Step 17: Export the Solver Deck

1. From the menu bar, click File > Export > Solver Deck.

2. In the Export — Solver Deck tab, File field, enter the file name

frame var2 assembled.fem.

3. Under Export options, Comments, select the Part Assemblies/Parts checkbox.

4. Click Export.
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