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HM-3400: Creating Connectors 
 

In this tutorial, you will learn how to: 

• Weld the two front trusses to each other by creating connectors at pre-defined weld 

points 

• Weld the two front trusses to the reinforcement plate by creating connectors 

between shell elements 

• Weld the right rails to each other and to the front trusses by creating connectors 

from a master connectors file 

• Update weld type of NASTRAN/OPTISTRUCT ACM (area contact method) welds, 

which already connect the rear trusses to each other, by first creating connectors 

from these welds and then realizing the connectors into two-noded weld elements. 

 

Model Files 
 

 

This exercise uses the frame_assembly.hm file, which can be found in the hm.zip file. Copy 

the file(s) from this directory to your working directory.  

 

Exercise 
 

 

Weld the two front trusses by creating connectors between geometry surfaces at pre-

defined weld points. 
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 Step 1:  Retrieve and view the model file. 

1. Start HyperMesh Desktop. 

2. In the User Profile dialog, select OptiStruct. 

3. Click OK. 

4. Open a model file by clicking File > Open > Model from the menu bar, or click  on 

the Standard toolbar. 

5. In the Open Model dialog, open the frame_assembly.hm file. A model appears in the 

graphics area. 

6. On the Visualization toolbar, click  to shade your model's geometry and surface 

edges. 

7. Observe the model using various visualization options available in HyperMesh (rotation, 

zooming, and so on). 

Step 2:  Display only the assembly assem_1 for elements and 
geometry.  

1. In the Model browser, click  (Model View).  

2. Expand the Assembly Hierarchy folder and sub-folders. 

3. Set the entity selection to  (Elements and Geometry). 

Note: This options turns on/off both elements and geometry when you perform right-

click operations in the Model browser. 

4. Right-click on assem_1 and select Isolate from the context menu. HyperMesh only 

displays the components that are in the assem_1 assembly. 

Step 3: Load the Connector Browser. 

1. Open the Connectors browser by clicking View > Browsers > HyperMesh > 

Connector from the menu bar. 

2. Review the layout of the Connector browser. Currently there are no components or 

connectors listed because there are no connectors in the model. 

Note: Use the Connector browser to view and manage connectors. The top portion 
of the browser is referred to as the Link Entity browser, and it displays 

information about linked entities. The middle portion is referred to as the 

Connector Entity browser, and it contains a list of the connectors in your 
model. The bottom portion of the browser is referred to as the Connector 

Entity Editor, and it displays attributes assigned to the connector(s) selected 
in the Connector Entity browser. HyperMesh groups the connectors based on 

their connection type.  
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Step 4:  Create welds between the geometry for the two front 

trusses at the pre-defined weld points. 

Connectors can be created automatically or manually. The automatic approach creates and 
realizes connectors automatically. The manual approach allows you to create and realize 

connectors manually. Realization is the process in which the connector creates the weld 

entity. 

Use the Spot, Bolt, Seam, and Area panels to create connectors automatically within the 

Connector browser, and use the create and realize subpanels to create connectors 

manually. 

1. Verify that the current component is Con_Frt_Truss. 

Note: The current component is always boldfaced in the Model browser, Component 

folder. 
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2. Open the Spot panel by right-clicking in the Connector Entity browser and selecting 

Create > Spot from the context menu. 

3. Go to the spot subpanel. 

4. Set the location selector to points. 

5. Select the six pre-defined weld points by clicking points >> by collector. 

6. Select the component Con_Frt_Truss. 

 

7. Click select. 

8. Set the connect what selector to comps. 

9. Click comps. 

10. Select the components Front_Truss_1 and Front_Truss_2. 

11. Click select. 

12. In the tolerance = field, enter 5. 

Note: The connector will connect any selected entities within this distance of itself. 

13. Click type= and select weld. 

14. Under connect what, switch the toggle from elems to geom. 

 

Spot panel settings for steps 4.4 through 4.14. 

15. Click create. HyperMesh automatically creates and realizes six connectors (Status bar 
reads, "6 spot connectors created, 6 realized."), and organizes them as geometry (not 

elements) in the current component collector, Con_Frt_Truss. 

Note: Green connectors indicate that the creation of the weld entity was successful. 

There are four states of connectors: realized (green ), unrealized (yellow 

), failed (red ), and modified ( ). If connectors were created manually, the 

color of the connectors changes from yellow to green, which indicates that they 

are realized into weld elements. As mentioned above, if you create connectors 
automatically they will be green immediately as there is no interim unrealized 

(yellow) state.   
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HyperMesh also adds fixed points to the surfaces at the ends of the weld elements to 
guarantee connectivity between the weld elements and the shell mesh that will be 

created on the surfaces. 

 

Weld element with fixed points created on the surfaces 

16. Click return. 

Step 5:  Review the Connector Browser. 

1. In the Connector Entity browser, expand the RBAR folder.   

Note: The RBAR folder contains the six connectors that you just created. HyperMesh 
grouped all of them under RBAR because that is the type of connector created. 

Notice the IDs of the connectors in the Entities column, the Links of the 
connectors, and the State of the connectors. You may need to increase the 

size of the tab area to see the State column. 
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2. In the Link Entity browser, right-click on Front_Truss_1 and select Find from the 

context menu. HyperMesh isolates the component in the graphics area and highlights 

the six connectors in the Connector Entity browser to indicate that these connectors 

have Front_Truss_1 as a link. 

 

3. Right-click on Front_Truss_1 and select Find Attached from the context menu. 
HyperMesh finds the components that are attached to Front_Truss_1 through the 

connectors. 

Note: Front_Truss_1 and Front_Truss_2 are now both highlighted in the Link Entity 

browser, which indicates that they are displayed in the graphics area. 
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Step 6:  Create a shell mesh on the two front truss components. 

1. Open the AutoMesh panel by pressing F12. 

2. Go to the size and bias subpanel. 

3. Set the mesh mode to automatic.  

Note: It may currently be set to interactive. 

4. Set the entity selector to surfs. 

5. Click surfs >> displayed. 

6. In the elem size = field, enter 10. 

7. Set the mesh type to mixed. 

8. Set the elems to surf comp/elems to current comp toggle to elems to surf comp. 

9. Click mesh. HyperMesh meshes the surfaces. 

10. Zoom into the area with a connector and note how the fixed point created from the 

weld has ensured that the mesh seeding passes through the weld. 

11. Click return. 

Step 7:  Display only the assembly assem_2 for elements and 
geometry.  

In this step you will display the reinforcement plate that needs to be welded to the two front 

trusses. 

1. In the Model browser, set the entity selection to  (Elements and Geometry). 

2. Right-click on assem_2 and select Isolate from the context menu. 

 

Weld the two front trusses to the reinforcement plate. 

Step 8:  Create connectors between the shell mesh of the front 

trusses and the reinforcement plate at pre-defined points. 

In this step you will manually create connectors between the shell elements of the front 

trusses and reinforcement plate at pre-defined weld points. 

1. In the Model browser, Component folder, right-click on Con_Truss_Plate and select 

Make Current from the context menu. 
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2. Open the Spot panel. 

3. Go to the create subpanel. 

4. Set the location selector to points. 

5. Click points >> by collector  

6. Select the component Con_Truss_Plate. 

7. Click select. 

8. Set the connect what selector to comps. 

9. Click comps. 

10. Select the components: Front_Truss_1, Front_Truss_2, and Reinf_Plate. 

11. Click select. 

12. Under connect what, switch the toggle from geom to elems. 

13. Set the num layers to total 2. 

14. Set connect when to now. 

15. Click create. HyperMesh creates eight spot connectors with comp links (Status bar 
reads "8 spot connectors created with comps links.") at the selected weld points, and 

organizes them into the current component collector, Con_Truss_Plate. 

Note: In the Connector Entity browser, these eight connectors are currently 

grouped as undefined.  

16. In the Connector Entity browser, expand the undefined folder.  

Note: The connectors in this folder are colored yellow, which indicates that they are 

unrealized. 

Step 9: Realize the connectors in the component Con_Truss_Plate 

into weld elements. 

In this step you will realize the undefined, unrealized connectors and assign them a 

connector type. 

1. In the Connector Entity browser, select the following unrealized connectors: 7, 8, 11, 

and 12. 

Hint: These connectors are displayed along the top of the Reinf_Plate component. 
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2. In the Entity Editor: 

• Set Config Name to weld. 

• For Tolerance, enter 7.  

• Set Connectivity to mesh dependent. 

• Set Adjust Option to adjust realization. 

• Set Adjust Realization to project and find nodes 

Note: When this option is active, the nodes will be equivalenced if the realized 

finite element of the connector is coincident to a node of the shell mesh it is 

being connected to. If there are no suitable nodes present, the closest node 

of the element the projection is landing is connected.  

3. In the Connector Entity browser, right-click on the selected connectors and select 
Rerealize from the context menu. The selected connectors realize into the weld 

elements. 

Note: The mesh has not been remeshed to connect the two components.   

4. In the Connector Entity browser, select the four remaining unrealized connectors (9, 

10, 13, 14). 

Hint: These connectors are displayed along the bottom of the Reinf_Plate 

component. 

 

5. In the Entity Editor: 

• Set Config Name to weld. 

• For Tolerance, enter 7. 

• Set Connectivity to mesh dependent. 

• Set Adjust Option to adjust mesh. 

• Set Adjust mesh to remesh. 
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6. In the Connector Entity browser, right-click on the unrealized connectors and select 

Rerealize from the context menu. HyperMesh realizes the selected connectors, and 

remeshes the mesh to connect the two components. 

 
The two front trusses welded to the reinforcement plate with weld elements at the connectors  

Step 10: Display only the assembly assem_3 for elements and 
geometry.  

1. In the Model browser, set the entity selection to  (Elements and Geometry). 

2. On the Visualization toolbar, click  to shade your model's elements and mesh 

lines. 

3. Right-click on assem_3 and select Isolate from the context menu. 

 

Weld the two right rails to each other and to the two front trusses by creating connectors from a master 

connectors file. 
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Step 11:  Create connectors to connect the right rails to each other 

and to the front trusses by importing a master connectors file. 

1. From the menu bar, click File > Import > Connectors. 

2. In the Import tab, click  in the File field. 

3. In the Select connector file dialog, open the rails_frt_truss.mwf file. 

4. Click Import. HyperMesh imports connectors and organizes them into a new 

component, CE_Locations. 

Note: It will take a few seconds for HyperMesh to import the connectors. 

 

Step 12:  Realize the connectors in the component CE_Locations into 

weld elements. 

1. In the Model browser, Component folder, right-click on CE_Locations and select 

Make Current from the context menu. 

2. In the Connector Entity browser, click the undefined folder. The Entity Editor opens 

and displays the undefined connector’s corresponding data. 

3. In the Entity Editor: 

• Set Config Name to Weld. 

• For Tolerance, enter 7. 

• Set Connectivity to mesh dependent. 

• Set Adjust Option to adjust realization. 

• Set Adjust Realization to project and find nodes. 
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4. In the Connector Entity browser, right-click on the selected connectors and select 

Rerealize from the context menu. 

 

Right rails welded to each other and to the front trusses with weld elements at the connectors 

Step 13:  Display only the assembly assem_4 for elements and 

geometry. 

1. In the Model browser, set the entity selection to  (Elements and Geometry). 

2. Right-click on assem_4 and select Isolate from the context menu. 

 

Weld to the two front trusses by duplicating and reflecting selected connectors created from the master 

connectors file 
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Step 14:  Create a new component collector to hold new connectors. 

1. In the Model browser, right-click and select Create > Component from the context 

menu. HyperMesh creates and opens a component in the Entity Editor. 

Note: HyperMesh makes this new component, the current component. 

2. For Name, enter CE_Locations_Dup. 

3. Click the Color icon, and select a color. 

 

Step 15:  Duplicate the connectors created from the master 

connectors file and reflect them. 

1. In the Model browser, Component folder, right-click on CE_Locations and select 

Show from the context menu. 

2. Open the Reflect panel by clicking Connectors > Reflect > Connectors from the 

menu bar. 

3. Set the entity selector to connectors. 

4. Click connectors >> by collector. 

5. Select CE_Locations. 

6. Click select. 

7. Click connectors >> duplicate >> current comp. HyperMesh duplicates the displays 

the connectors, and organizes them into the current component, CE_Locations_Dup. 

8. Set the orientation selector to x-axis. 

Note: This is the axis normal to the plane of interest. 

9. Specify a base node to reflect about by double-clicking B. 

10. Click x=. HyperMesh activates the x=, y=, and z= fields. 

Note: Their values are all 0.000 by default, which is the base point you want to 

reflect about. 

11. Return to the reflect panel by clicking return. 

12. Click reflect. HyperMesh reflects the connectors. 

13. Click return. 

Note: The connectors are yellow, which indicates that they are unrealized. 
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Step 16:  Update the connectors for the left rails to link them to the 

left rail components. 

1. In the Connector Entity browser, expand the RBAR folder. 

2. Sort the connectors by their state by clicking State. HyperMesh organizes all of the 

realized connectors at the top of the list. 

Tip: You may need to increase the size of the tab area to see the State column. 

3. Click State again. HyperMesh organizes all of the unrealized connectors at the top of 

the list. 

4. In the Link1 and Link2 columns, review the the unrealized connectors. 

Note: Some of the connectors are linked to the components, Right_Rail_1 and 
Right_Rail_2. This data is from the rails_frt_truss.mwf file that you 

imported. These links need to be updated to reflect the components, 

Left_Rail_1 and Left_Rail_2. 

5. Select all of the unrealized connectors in the list. 

 

6. In the Entities column, right-click on the selected connectors and select Update Link 

from the context menu.  

7. In the Update window, Search column, set the Link Type to comps. 

8. In the Search column, click the Link Select field. 

9. In the panel area, click component. 

10. Select the component, Right_Rail_1. 

11. Click proceed. HyperMesh inserts Right_Rail_1 into the Link Select field. 

12. In the Replace column, set the Link Type to comps. 

13. In the Replace column, click the Link Select field. 
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14. In the panel area, click component. 

15. Select the component, Left_Rail_1. 

16. Click proceed. HyperMesh inserts Left_Rail_1 into the Link Select field. 

 

17. Click Update. HyperMesh updates the connectors' links. 

18. Repeat 16.7 through 16.17, except search for the Right_Rail_2 component and 

replace it with the Left_Rail_2 component. 

19. Scroll through the list of unrealized connectors to make sure that none of the 

connectors are linked to the right rail components. 

20. Close the Update window by clicking X next to Update. 

Step 17:  Realize the connectors in the component 

CE_Locations_Dup into weld elements. 

1. In the Connector Entity browser, select all of on the unrealized connectors, which are 

organized in the CE_Locations_Dup component. The Entity Editor opens and displays 

selected connector’s common attributes. 

2. In the Entity Editor: 

• Set Config Name to weld. 

• For Tolerance, enter 7. 

• Set Connectivity to mesh dependent. 

3. In the Connector Entity browser, right-click on the selected unrealized connectors and 

select Rerealize from the context menu. HyperMesh realizes the selected connectors 

into weld elements. 

Step 18:  Verify that all connectors are realized and identify the pairs 

of adjacent connectors. 

1. In the Connector Entity browser, expand the RBAR folder. 

2. From the State column, verify that all of the connectors are realized. 

3. Zoom into one of the two areas where the front trusses are connected to the rail 

components. 

Note:  At these two areas, there are pairs of adjacent connectors.  

4. On the Visualization toolbar, click  (Visualization Options). 
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5. In the Visualization tab, click (Connectors). 

6. Under Color by, select Layer. HyperMesh changes the connectors color to purple 

because under Layers, 2t is defined by the color purple. 

Note: This option indicates that each of these connectors link two components. 

Because each pair of connectors creates a series of two weld elements, you can 
combine each pair into a single connector, which links the three components 

together. 

Step 19:  Isolate the pairs of adjacent 2t connectors identified in the 

previous step.  

1. In the Model browser, turn off the geometry display for all of the components. 

2. In the Link Entity browser, select Front_Truss_1, Front_Truss_2, Right_Rail_1, 

and Left_Rail_1. 

3. Right-click and select Find Between from the context menu. HyperMesh finds and 

displays 12 connectors between the four components you selected. 

 

Step 20:  Unrealize the displayed connectors.  

1. Open the Unrealize panel by clicking Connectors > Unrealize from the menu bar. 

2. Click connectors >> displayed.   

Note: The Status bar reads "12connectors added by 'displayed'. Total selected 12." 

3. Click unrealize. HyperMesh unrealizes the connectors, and deletes the weld elements 

associated to them. 

4. Click return. 

Step 21:  Combine the pairs of adjacent 2t connectors into 3t 

connectors. 

1. Open the Connector Quality panel by clicking Connectors > Check >  Connector 

Quality from the menu bar. 

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.16



2. Go to the connectors (unrealized) subpanel. 

3. Click connectors >> displayed. 

4. In the tolerance = field, enter 7. 

5. Click preview combine. HyperMesh finds 12 connectors that need to be combined. 

Note: The status bar reads, "12 connector(s) found that need to be combined." 

6. Click combine. HyperMesh combines the connectors, and displays them in a dark blue 

color to indicate that they have three layers. 

Note: The status bar reads, "6 connectors deleted."  

7. Optional: If the connectors are not visible, right-click in the Link Entity browser and 

select Find Between. 

8. Click return. 

Step 22:  Realize the 3t connectors in the component Con_Frt_Truss 
into weld elements. 

1. In the Model browser, Component folder, right-click on Con_Frt_Truss and select 

Make Current from the context menu. 

2. In the Connector Entity browser, select the 6 unrealized connectors. The Entity 

Editor opens and displays the selected connector’s common attributes. 

3. In the Entity Editor: 

• Set Config Name to weld. 

• For Tolerance, enter 10. 

• Set Connectivity to mesh dependent. 

4. In the Connector Entity browser, right-click on the selected connectors and select 

Rerealize from the context menu. HyperMesh realizes the connectors. 

5. Verify that there are now three links for the six connectors you just updated. 

6. On the Visualization toolbar, click  (Visualization Options). 

7. In the Visualization tab, click (Connectors). 

8. Under Color by, select State. 

Step 23: Display only the assembly assem_5 for elements and 

geometry. 

1. In the Model browser, set the entity selection to  (Elements and Geometry). 

2. Right-click on assem_5 and select Isolate from the context menu. 

Step 24: Create connectors from existing ACM welds. 

In this step you will use the Fe Absorb tool to obtain connectors from the existing ACM 

welds (elements) in the component, Con_Rear_Truss. 
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1. From the menu bar, click Connectors > Fe Absorb. 

2. In the Automated Connector Creation and FE Absorption dialog, set FE configs to 

custom. 

3. Set FE type to optistruct 5 sealing. 

4. Toggle the Elem filter from All to Select. 

5. Double-click Elements. 

6. In the panel area, click elems >> by collector. 

7. Select the component, Con_Rear_Truss. 

8. Click select. 

9. Click proceed. 

10. Select the Move connectors to FE component checkbox. 

11. Click Absorb. HyperMesh absorbs the elements into realized, 2t connectors at the 
locations of the ACM welds, and organizes them into the Con_Rear_Truss component, 

the same component to which the ACMs belong. 

 

12. Click Close. 

  

Proprietary Information of Altair Engineering 

 

Altair HyperMesh 2019 Tutorials p.18




