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HM-3130: QI Mesh Creation 
 

In this tutorial, you will learn how to create and optimize a 2D mesh based on user-defined 

quality criteria. 

HyperMesh has a set of features designed to help you achieve good element quality more 

efficiently. These features use settings from the qualityindex panel to generate or modify a 
mesh. This allows HyperMesh to give results that account for your preferences for which 

element quality checks are more or less important than others. The quality index (Q.I.) 
optimization features are found in the Automesh, Smooth, and Qualityindex panels. You 

can use these functions separately or in unison. 

 

Model Files 
 

 

This exercise uses the planar.hm file, which can be found in the hm.zip file. Copy the 

file(s) from this directory to your working directory.  

  

 

Exercise 1: Creating and Optimizing a 2D Mesh Based on User-

Defined Quality Criteria 
 

 

Step 1: Open the model file, planar.hm. 

1. Start HyperMesh Desktop. 

2. From the menu bar, click File > Open > Model. 

3. In the Open Model dialog, open the planar.hm model file. 
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4. Observe the model using the different visual options available in HyperMesh (rotation, 

zooming, and so on). 

Step 2: Working with node and element quality optimization. 

Within the qualityindex panel, there are tools you can use to select individual nodes or 
elements, and then alter the position or shape of the node/element to optimize the element 

quality for the surrounding elements. The element qualities are optimized according to the 
settings in the qualityindex panel. These features are very useful for improving element 

qualities in local areas of the mesh. 

1. Open the qualityindex panel by clicking Mesh > Check > Elements > Quality 

Index from the menu bar, or selecting qualityindex from the 2D page. 

2. On the right-hand side of the panel, note the value for comp. Q.I.=. It should read 

85.09. 

Tip: Keep this number in mind so that you can judge how much progress you make 

in improving the element quality. 

 

3. Click cleanup tools. The QI criteria is replaced by a series of yellow buttons, each 

representing a tool for element cleanup. 

 

4. Experiment with the modify hole and washers tool. 

• Use these options on the hole in the mesh to reposition nodes on the hole's edges, 

change the radius of the holes, and link holes with their washers so that the 

washers rotate or resize along with changes made to the holes. 

radial Use this option to alter the radius of a hole (and, optionally, the 

washer). 

To alter the radius of the hole, click and drag a node in the 

graphics area. The element orientation remains constant, but 
the hole may become larger or smaller based on the input. 

There are additional controls to enable or disable automatic 

remeshing when altering the hole dimensions. 
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radius: (and 

edit check box) 

This field displays the current radius of the hole that the 

selected node belongs to. By default it is a display-only field. 

If you do not want to click and drag a node in the graphics 
area, you can select the edit check box and specify a desired 

radius. Once you click a node in the desired hole, the radius will 

change to the specified value. 

angular Use this option to move the nodes around the edges of the hole 

without changing the hole diameter or the spacing between 

nodes. 

 

angle: (and 

edit check box) 

This field displays the current angle of the hole that the 
selected node belongs to, relative to its original (unmodified) 

starting position.  By default it is a a display-only field. 

If you do not want to click and drag a node in the graphics 

area, you can select the edit check box and specify a desired 
angle. Once you click a node in the desired hole, the angle will 

change to the specified value.  
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radial & 

angular 

Use this option to simultaneously change the hole's radius and 
the orientation of nodes around its edge. Like the angular 

option, the node spacing remains proportionally consistent, 

though actual spacing will be scaled in accordance with changes 

in the hole radius. 

 

radial and 
angular: (and 

edit check 

boxes) 

These fields display the current angle and radius of the hole 
that the selected node belongs to. By default they are both a 

display-only field. 

If you do not want to click and drag a node in the graphics 

area, you can select both edit check boxes and specify a 

desired angle and radius. Once you click a node in the desired 
hole, the angle and radius will simultaneously change to the 

specified values.  

circumferential Used primarily on openings like slots, this option rotates the 

nodes along the circumference of the slot without altering the 
hole's size or shape/orientation. The capability works on 

enclosed slots or holes, it is not designed to work on slots with 

an opening. 
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circumferential 

(and edit check 

box) 

This field displays the current arc length of the hole that the 

selected node belongs to. By default it is a display-only field. 

If you do not want to click and drag a node in the graphics 

area, you can select the edit check box and specify a desired 
arc length. Once you click a node in the desired hole, the arc 

length will change to the specified value.  

link washers To change the radial or angular position of nodes, as well as 

drag and scale the washer nodes along with them, select this 
check box. In order for the link washers option to work, you 

must select the allow to move fixed and shared nodes 

check box in page 3 of the quality index panel. 

   

Starting point (no changes 

made yet) 

Link Washers option 

turned off. 

Link Washers option 

turned on. 

 

remesh 

number of 

layers: 

To specify the number of washer layers to automatically remesh 

after you alter the node position, select this check box. 

5. Experiment with the place node tool. 

• Use the following place node options to reposition some of the nodes in the mesh 

and change the shape of the surrounding elements. To reposition a node in the 

mesh, click and drag it.  

• The affected elements will change color as you reposition the node to indicate their 

quality grade at the node's current position. Observe how the comp. Q.I. changes. 

along 
surface / 

normal to 

surface 

Use this toggle to determine which direction the node will move. To 
move the node along the plane or curvature of the surface, select 

along surface. To move the node directly away from the surface in 

a normal direction, select normal to surface. 

 

Movement along surface; note that the node cannot normally exceed the edge of the 

mesh. 
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Movement normal to surface 

With the place node tool highlighted, click-and-drag a node in the 
graphics area to relocate it. The elements that depend on that node 

will dynamically adjust as you drag, resulting in a QI change. 

allow 
movement 

out of 

boundary 

To move the nodes past the edges of a mesh boundary, select this 
check box. This option is only available when along surface is 

selected.  

 

Movement along surface, allowing movement out of boundary. 

move 

midnodes 

To move the midnodes associated with the node you are moving, 
select this check box. This option is useful when you are working 

with second order elements. 

6. Experiment with the swap edge tool. 

Use the Swap Edge tool to consider the elements to which the edge belongs, and find 

alternative orientations for it.  

 

Each time you click an edge in the graphics area, it switches to the next valid 

configuration. If an edge swap will not improve element quality, a message to that 
effect displays in the status bar. To force the swap anyways, click the edge a 

second time. Additional clicks will cycle through the possible edge positions. The 

number of possible edge positions depends on the types of elements involved. 

For a pair of trias, there are two possible positions for their shared edge. For a pair 

of quads, there are three possible positions.  For a quad and a tria, there are six 

possible positions.   
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7. Experiment with the node optimize tool. 

• Use the Node Optimize tool to automatically move a selected node to optimize the 

overall quality of its surrounding elements. The options along surface, normal to 
surface, and along and normal to surface work exactly as described for the 

place node tool. The only difference is that node optimize moves the node 

automatically, while place node requires you to choose the location manually.  

• To move the midnodes attached to the node you are optimizing, select the with 

attached midnodes check box. This option is useful when you are working with 

second order elements. 

• Try selecting some of the nodes on the mesh. In particular, select nodes of 

elements that are highlighted red, since these have the worst quality. You should 

see each node move as it is selected, improving the surrounding mesh quality. 

Notice what happens to the value of the comp. Q.I., it should improve as you 

select more nodes. 

8. Experiment with the element optimize tool. 

• Use the Element Optimize tool to automatically optimize the shape of the selected 

element and the elements surrounding it. It is similar to Node Optimize, except 

that its effects are wider-spread.  

• To move the midnodes attached to the element you are optimizing, select the with 

attached midnodes check box. This option is useful when you are working with 

second order elements. 

• Try selecting some of the elements on the mesh. In particular, select elements that 

are highlighted red, since these have the worst quality. You should usually see the 

shape of the element change as it is selected, improving the surrounding mesh 
quality. Notice what happens to the value of the comp. Q.I. , it should improve as 

you select more elements. 

9. To exit the panel, click return. 

Step 3: Resetting the part by remeshing. 

In this step, you will use the AutoMesh panel to regenerate the original mesh so you can 

try to fix the element quality using a different method. 

1. To open the Automesh panel, click Mesh > Create > 2D AutoMesh from the menu 

bar, or select Automesh from the 2D page. 

2. Go to the size and bias subpanel. 

3. Verify that the entity selector is active and set to surfs. 

4. Select surfs >> all. 

5. In the element size= field, enter 15.  

6. Set the mesh type to quads. 

7. Set the meshing mode to automatic. 
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8. Switch the connectivity option from keep connectivity to previous settings. 

 

9. Click mesh. HyperMesh regenerates the mesh. 

10. To exit the panel, click return. 

Step 4: Using QI optimization smoothing. 

The Smooth panel also has quality index optimization features. In this step, you will use 
these features to adjust the element quality according to the settings in the qualityindex 

panel for an entire group of selected elements. Once you have adjusted the element quality, 

you will compare the smooth function to the node and element optimization used in the step 

2. 

1. To open the Smooth panel, click Mesh > Cleanup Elements > Smooth from the 

menu bar, or select smooth from the 2D page. 

2. Go to the plates subpanel. 

3. Select smooth: elems >> displayed. 

4. Switch the mesh algorithm from autodecide to QI optimization. 

5. There are several optional controls that are enabled when you select QI optimization, 

that you should understand, but are not needed for this tutorial: 

Controls Function 

target quality 

index= 

The target value you would like the quality index to be 

after the smoothing operation. This value is not 
guaranteed from smoothing. The smooth operation will 

attempt to hit this target. 

time limit If you are working with large models, select this check box 

to ensure the smoothing routine does not take more time 

than you want to allow. 

feature angle The Smooth panel evaluates the angle between the 

normals of two adjacent elements. If this angle is equal to 
or greater than the value specified in this field, HyperMesh 

will not allow the nodes shared by the elements to move. 
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use current criteria 

/ criteria file 

If use current criteria file is selected, HyperMesh will use 

the current criteria file for your Q.I. settings. 

If criteria file is selected, you can select and use a 

different criteria file for your Q.I. settings. If a criteria file 

is specified, leave this option blank. 

recursive 
optimization 

procedure / single 

optimization step 

If recursive optimization procedure is selected, the 
automesher takes more than one pass in generating the 

best quality mesh it can. This option make take longer 

than single optimization step. 

If single optimization step is selected, the automesher 
will only take one pass in generating the best quality mesh 

it can. It is suggested that you use this option for larger 

models. 

6. Click smooth. The status bar displays a message that says “result selection 

approximate quality index = 0.11”  

7. Compare this value to 85.10, which is the quality index value you had after creating the 

original mesh. In this case you should see that it is significantly lower, which indicates 

that the element quality is much better. 

8. To exit the panel, click return. 

Step 5: Using the QI settings in the Mesh panel. 

The AutoMesh panel is capable of using the quality index settings to automatically decide 

what pattern of mesh it should generate. 

1. Open the AutoMesh panel.   

2. Go to the batchmesh/QI optimize subpanel. 

3. Set the toggle to QI optimize. 

4. Verify that the entity selector is set to surfs. 

5. Select surfs >> all. 

6. In the elem size= field, enter 18. 

7. Set the mesh type to quads. 
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8. The QI optimize subpanel has several controls that you should understand, but are not 

needed for this tutorial 

Controls Function 

use current criteria 

in QI panel 

If use current criteria file is selected, HyperMesh will 

use the current criteria file for your Q.I. settings. 

If criteria file is selected, you can select and use a 
different criteria file for your Q.I. settings. If a criteria file 

is specified, leave this option blank. 

Smooth across 

common edges 

Select this check box if you would like the nodes 

generated on a surface edge to be moved off the surface 

edge when the algorithm smoothes the mesh. 

feature angle The QI optimize subpanel evaluates the angle between 

the normals of two adjacent elements. If this angle is 
equal to or greater than the value specified in this field, 

HyperMesh will not allow the nodes shared by the 

elements to move. 

Keep/ Redo / 

Break connectivity 

Keep Connectivity creates a new mesh with node 
seeding at its edges to match any existing adjacent 

meshes. 

Redo Connectivity redoes existing adjacent meshes at  
the same time as it meshes the current selection, to 

ensure that each surface's mesh matches up along the 

shared edges. 

Break connectivity allows the Mesher to mesh without 

affecting surrounding mesh. 

9. Click mesh. HyperMesh regenerates the mesh. 

10. To exit the panel, click return. 

11. Use the qualityindex panel to check the quality index of this mesh, and compare it to 

the previous mesh. 

12. Look at the value for the comp. Q.I.= field. It should be 0.12, which is much lower that 

the 85.10 value of the mesh you originally generated. 
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